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About HyperCube

 HyperCube is a Macintosh and Windows application program specifically directed to 
the analysis and display of multi and hyperspectral imagery.  This includes the static and 
dynamic display of the image cube and the generation of spectral classifications using both 
imagery and spectral libraries.  In addition, HyperCube contains functions to filter, warp, 
mosaic, reformat, calibrate, combine, photogrammetrically project and to perform arithmetic 
on imagery and data. 
 The current version number of HyperCube is shown in the lower right hand corner of the 
splash screen by selecting About... in the Apple menu or the Help menu in the Windows ver-
sion.

Macintosh Version
 The Mac version of HyperCube is a “Carbonized”  OS X native program that will also 
run on the Mac Classic OS, versions 8.6 (including CarbonLib 1.6) and above.  If running on 
the later OS use Get Info in the Finder to allocate as much memory as possible.  HyperCube 
will run with only 8 MB but some functions may have to be broken into successive opera-
tions.  More typically, 80 MB is a good size.  Scaled overviews permit selectively loading 
full resolution subsets into memory.  HyperCubeʼs Info window (described in Image Op-
erations) will show a running tally of available memory.
 Memory limitations and sizing are not applicable when running on Mac OS X as the OS 
will dynamically allocate memory as necessary.

Windows Version
 The Windows version runs on the Windows® 95 through XP operating systems.  There are 
no other special requirements or considerations.  The Mac and Windows versions are 99.9% 
identical with one significant difference: the Windows version does not support the Mac Pict 
image format.  It uses TIFF as the basic image format.  Although this documentation was 
done on a Mac version of InDesign® using both OS 9 and OS X Mac examples, the Windows 
GUI matches it one-for-one.  Any slight (very slight) difference between the two versions is 
delineated in the text (in particular see the “Load Selection” button in section Band List).  
Also, see “Windows version” in the index.
 The Windows version uses the Control (Ctrl) key instead of the Macintosh special com-
mand key.  So, for example, to perform a paste operation press the Ctrl and V keys simultane-
ously.  The Mac Option key is replaced with the Alt key in Windows.
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Loading Images
Files, Data, Images and Display
 At the present time almost every window that is displayed on a computer monitor con-
sists of 8 bit gray or 24 bit color (or possibly a few bits more).  HyperCube can handle data 
up to 32 bits per pixel with a spatial extent up to 10,000 by 10,000 pixels.  How data is con-
verted from a source file to a display is described below.

Pixel depth:
 8 bit - display directly as gray or pseudo color.

 24 bit color - display as true color.

 16 bit signed or unsigned - keep 16 bits in memory as “attached data” and remap
     by various methods to 8 bits for display (the image load dialogs contain
     options for remapping),
     See section Data Mapping for other ways to remap after loading).
 
 32 bit float or long - keep full depth in memory and convert for display.

 64 bit and higher - not presently supported in HyperCube.

Spatial size:
 Image sizes greater than 2048 pixels or 2048 lines can be loaded as a scaled overview 
image (see Related functions below) and used to outline areas that are loaded at full resolu-
tion.  Image subsets may also be loaded.

Multiband Images:
 Each band that is loaded into memory includes the attached source data for that band.  
However, the number of bands loaded into memory does not affect spectral classifications in-
cluding most statistical operations.  Therefore, it is not necessary to load an entire multiband 
image in order to exploit it (see sections Header Files and Band List).

Related functions:
 HDF, JPEG, NITF, TIFF, Raw and Multiband images,
 Attach Data,
 Overviews,
 Gray Mapping, Color Mapping, Data Mapping,
 Statistical Measures,
 Image Arithmetic,
 Classify Function.

 Note, to see the underlying data of a display pixel choose menu Windows -> Show Info 
which in addition to listing the gray or color display pixel will also show any data value.  Du-
plicating an image also makes a copy of the attached data.  Some operations, such as menu 
Applications -> Shaded Relief, also copy the source data and attached it to the newly con-
structed image.
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Intrinsic File Types
 The intrinsic image file format for the 
Mac is TIFF for OS X and Pict for the 
Classic OS.  HyperCube also automati-
cally recognizes Pict, TIFF, JPEG and .SUN 
(SRF) file types in the menu File->Open...  
(shown at the right) provided their Finder 
file types (not the file name suffix) are prop-
erly set.  If the list does not show the file you 
are expecting then the image must be opened 
using menu File -> Open As... with you 
specifying the file type.  If Edit -> Options 
-> Detailed Messages is checked then the 
header contents of the various file types will 
also be listed and is a good diagnostic tool.
 The Windows version of HyperCube uses File -> Open... (shown below in General File 
Types) to load all types of image formats except Pict which is not supported.  TIFF is the 
general file type for Windows. Use the Files of type: popup menu to select which type.

General File Types
 Any image supported by HyperCube can be opened by Open As... in the Mac version 
and just Open... in the Windows version as shown by the dialogs below and the following 
page. 

Windows standard Open... file dialog.
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SRF (Sun Raster Files) and TARGA
 Sun raster (SRF) and TARGA formatted images can be loaded by se-
lecting Open As... from the File menu and then  choosing the appropriate 
item in the Format popup menu.  No other dialog is required as these im-
ages contain sizing information in their header.  HyperCube should be able 
to read 8 bit and 24 bit compressed and uncompressed Sun images. Hyper-
Cube can also save images in the Sun format but not TARGA. 

Macintosh OS X standard Open As... file dialog.

Currently supported 
file types.
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ERDAS Imagine®
 Certain types of ERDAS Imagine® *.img files can be read (imported in some cases) into 
HyperCube by selecting menu File -> Open As... and choosing ERDAS Imagine® as the 
file type.  The supported pixels depths are: 8 bit unsigned, 16 bit unsigned, 16 bit signed, 32 
bit signed and 32 bit float gray scale single and multiband images.  Also, 8 bit pseudo and 
24 bit true color images can be loaded.  Once loaded the images may be saved in any format 
including Imagine®.
 An Imagine® multiband image should be reformatted into the HyperCube multiband 
format with corresponding *.hdr and *.wvl files.  Loading a multiband image brings up the 
following dialog immediately after the Open As selection.  Choosing either Load or Re-
format displays the two subseqent dialog paths.  Spectral classifications can not be directly 
performed until an Imagine® multiband image has been converted to HyperCube multiband.

Chosing Load in the first dialog displays 
this dialog showing the initial defaults 
for loading the specified multiband 
image file.  Edit as needed and  select 
Load Overview or Load Image.  The 
Mac version of HyperCube will have the 
Swap bytes check box on while in the 
Windows version it will be off.

Choosing Reformat in the first dialog above 
results in HyperCubes s̓ general Utilities -> 
Reformat File dialog.  See section Reformat-
ting a File. 

 If Load Overview is selected in the Load dialog then a scaled overview of the selected 
band is loaded.  Any portion of the overview image can be designated and saved, including 
automatically reformatting the subset (see section Saving Overviews).
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 The Hierarchical File Architecture (HFA) of a given ERDAS Imagine® image file can be 
displayed by first toggling on menu Edit -> Options -> Detailed Messages and then loading 
the file.  It is quite extensive and is displayed in several text windows containing the HFA 
nodes.  Shown below are the results after loading a single 16 bit gray scale image.  Note that 
a 210 multiband image has over 2000 nodes.

A partial listing of the 12 
HFA nodes in the loaded 
image file.

Corresponding dictionary 
defining the structure of each 
possible node.

A listing of offsets showing 
the location of each image 
data block within the file.

 Any loaded image can be saved in the Imagine® *.img format via menu Save As... and 
selecting ERDAS Imagine® as the type.  Note: HyperCube does not generate the histogram 
or statistics of HFA nodes when saving, only those nodes needed for loading and displaying.
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ESRI Shape Files
 HyperCube can load and display certain types of ESRI (Environmental Systems Research 
Institute, Inc.) Shape Files.  In particular are those produced by HyperCube via the Class 
Map Editor Export function.  Shape files consist of a main file that should have a .shp exten-
sion along with the index file (.shx extension) and a dbase file (.dbf extension).  No use is 
made of the last two files but their contents can be displayed in a scrollable text window by 
selecting File- > Open As..., choosing ESRI Shape and selecting the desired file extension 
type.  For convenience, the main shape file itself does not have to have the .shp extension 
whereas the other two do require their proper extension.
 Shown below is the result of opening the three shape files that were exported by the Utili-
ties -> Class Map Editor.  Each text window contains a parsing and because of the possible 
large size of shape files not all of the records may be shown.  Also, the shape plot sizing is 
abitrary unless it was exported from HyperCube.

The three shape files and the corresponding plot that were produced via the 
Utilities->Class Map Editor Export function.  Only a portion of each file is 
shown in the text windows.  See section Class Map Editor for more details.
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HDF Files
 The Hierarchical Data Format (HDF) was developed at the National Center for Super-
computing Applications (NCSA) at the University of Illinois at Urbana-Champaign.  Most 
of the image/data formats described in the NCSA HDF Specification and Developerʼs 
Guide, Version 4.1r5, Novmenber 2001 can be loaded and saved in HyperCube. The strong 
exceptions are: the complex data type is not supported and the number of dimensions (rank) 
must be less than or equal to three for Numeric and Scientific Data Groups.  
 Load an HDF image by selecting menu File -> Open As... and choosing HDF as the 
file type.   This results in the following dialog listing all of the single images and Scientific 
Data sets residing in the file.  The list displays the characteristics of each embedded image.  
Select 1 or more images (use shift click for a contiquous region and command click for dis-
contiguous selections) and then Load.   If an image is multiband (number of bands greater 
than 1) then a subsequent dialog appears exactly as described in section Image Format 
Dialogs allowing you to load any portion or overview of the multiband image.

 If menu item Edit -> Options -> Detailed Messages is 
toggled on (checked) then a listing of all of the  recognized 
tags in the header portion of the HDF file is generated.  
This is a tiny fraction of the tags contained in the image 
example shown above.

A listing of the 5 images within the HDF file.  
The first and last images are multiband with 
pixel depths of 16 and 8 bits per pixels respec-
tively.  Selecting the first image brings up the 
dialog shown on the right (see section Image 
Format Dialogs).
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JPEG Files
 Baseline JPEG files may be loaded and saved by HyperCube.  Specifically, these are de-
fined by ISO 10918 as:

       • DCT - base process
       • 8 and 16 bit samples per component (a little beyond baseline)
       • Sequential
       • Huffman coding
       • 1,2,3 or 4 components
       • Interleaved and non-interleaved scans

 To load a JPEG image file select File -> Open As..., JPEG and choose the file.  If the 
image is not in JPEG format then you will get an alert message.  Once loaded, a JPEG image 
is treated like any other loaded image and can be saved in any of the image formats.
 Saving an image, either gray, pseudo or true color, is done via File- > Save As..., JPEG 
when the image is the active window.  This displays a subsequent dialog (after the standard 
save file dialog) that allows you to choose the level of compression as shown below.  Also 
shown on the right is a text file dump of the various JPEG markers for the loaded image 
which appears if Edit -> Options->Detailed Messages has been checked before the image 
is loaded.
 Note: Because JPEG is a lossy format you cannot save a classmap in JPEG format.  The 
color correspondence will be lost, use NITF, PICT, SRF or TIFF.

A portion of the JPEG markers defining 
the contents a loaded JPEG image.  This 
text window appears automatically if 
Edit->Preferences->Detailed Messages is 
checked.

Three levels of compression 
available to you when saving 
an image in JPEG format.
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NITF Files
 NITF (National Imagery Transmission Format) images are loaded via menu File->Open 
As...  and then choosing the NITF item in the Format popup menu.  HyperCube can read 
versions 2.0 and 2.1 NITF data, gray, pseudo, true color and multiband images including 
embedded baseline JPEG.  Any graphics or text within the NITF file is ignored.  If the image 
is multiband, larger than 2048 (pixels or lines) or the pixel depth is greater than 8 bits (e.g., 
short or float) you are presented with the dialog shown below.  This allows you to load either 
an overview of the image (necessary if very large) or the entire image.  Overview images are 
then used to select full resolution subsets that are subsequently loaded using menu File -> 
Load Selection (see section Overviews).  If there is insufficient memory to load then you 
will be alerted with a message stating how much additional memory is needed.  Saving a 16 
or 32 bit image as NITF saves the data as short or float.  
 If the NITF image is multiband you may select the starting band and the number of bands 
to load and if Overview is chosen, the overview band and scale as well.  To exploit a NITF 
multiband image you must first save the loaded image cube.  However, there are possible 
memory constraints doing this and the best technique is to use menu Utilities -> Reformat 
Cube File to convert the NITF file into an image cube file.

A description of the image.

What part of the image to load.  
Initially, set to the image size.

Select either an overview or the image at full resolu-
tion.  You will be notified if insufficient memory.

How to remap the data for display.  
Also, see section Pixel Exclusion.

For the given size image, the scale 
automatically computed to display 
the whole image within the monitor.

If multiband which bands to load.

If menu Edit->Options->Detailed 
Messages is checked then each 
NITF image load will produce 
windows listing the main header 
and image header contents.  
Also, if the image header defined 
a coordinate system, use the Info 
Window to display them.
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TIFF Files
 TIFF ( Tagged Image File Format) images are loaded via menu File -> Open As...  and 
then choosing the TIFF item in the Format popup menu.  HyperCube can read 8 bit and 
higher baseline TIFF 6.0 images plus 16 and 32 bit tiled format images.  Note that neither 
LZW nor embedded JPEG encoding are included in the baseline TIFF although JPEG images 
can be read by themselves (see section JPEG Files).  If the image is larger than 2048 (pixels 
or lines) or the pixel depth is greater than 8 bits (e.g., short or float) you are presented with 
the dialog shown below.  This allows you to load either an overview of the image (neces-
sary if very large) or the entire image.  Overview images are then used to select full resolu-
tion subsets that are subsequently loaded using menu File -> Load Selection (see section 
Overviews).  If there is insufficient memory to load then you will be alerted with a message 
stating how much additional memory is needed.  Saving a 16 or 32 bit image as TIFF saves 
the data as short or float in strip format even if the source format was tiled.  
 If the TIFF image contains Geo tags (e.g., itʼs a GeoTIFF) then any coordinates will be 
extracted and used as the image reference (see section Image to Reference Coordinates).  
Saving a GeoTIFF embeds the four image corners as Geo tie points regardless of the source.

A description of the image.

What part of the image to load.  
Initially, set to the image size.

Select either an overview or the image at full resolu-
tion.  You will be notified if insufficient memory.

For the given size image, the scale 
automatically computed to display 
the whole image within the monitor.

Not used for TIFF, see NITF,

If menu Edit->Options->Detailed Messages is 
checked then each TIFF image load will produce 
the window at right listing the main TIFF tags 
and any Geo tags.

How to remap the data for display.  
Also, see section Pixel Exclusion.
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Raw
 The Raw image format permits you to specify the dimensions and format of general im-
age files and the resulting size of what will be loaded into an image window.  The only differ-
ence between a Raw format and Multiband format (explained later) is that the Raw format 
results in loading a single image plane.  Opening a Raw image always results in displaying 
an 8 bit image with the underlying source data in memory.  You have considerable control on 
how this file data is converted to 8 bits for display.  The Raw image file to be opened is se-
lected by choosing Open As... from the File menu and then selecting Raw from the Format 
popup menu.  Since any file can be considered as a Raw image, the open dialog displays all 
file types.  You must know which files represent meaningful images.
 Any operations that process the image (e.g. Fourier, Image Arithmetic, Line Profile 
Plots, Mosaic, Warp) always use the actual underlying data instead of the 8 bit display 
values.  Moving the cursor over a data mage displays the data value when the Info window is 
open.  Histograms and Line Profile Plot operate on the data.  See the Applications section 
for examples of data usage.

The Open As... dialog showing the 
selection of a Raw format file.

Multiband and LAN/GIS
 A multiband image differs from a raw image in that it consists of 2 or more registered 
bands each having the same spatial dimensions.  Multiband images are selected from the 
same custom open file dialog as Raw shown above but with Multiband chosen from the 
Format popup menu when you select Open As... from the File menu.  Raw and multiband 
images are defined by a format dialog (see below)  that appears immediately after the Open 
button is clicked.  This dialog lists all of the information necessary to correctly read and 
interpret the image file and to load the image into a window for display.  The initial content 
of the dialog is read from a simple ASCII text header file having the same name as the im-
age file but with a .hdr extension (see section Header Files).  If this file doesnʼt exist (i.e. 
has yet to be created) then the dialog fields are empty.  In either case you can edit the dialog 
fields and save the proper values to create/update the *.hdr file.  Subsequent opening of the 
image or image.hdr file will display the image definition in the format dialog.
 If a multiband image is known to be in the LAN/GIS format with a properly embedded 
header then it may be loaded by selecting LAN/GIS from the Format popup menu.  Hyper-
Cube will attempt to decipher the header (either byte order) and preset these values into the 
dialog shown on the following page.  It is then possible to edit and save the header (in Hyper-
Cube format) for subsequent loading.  The actual LAN/GIS header is not modified.
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Image Format Dialogs

An image format dialog showing the defini-
tion of an 16 bit 512 by 512 raw image ready 
to load the entire image with remapping.  The 
Pixel type is unsigned short and Byte order 
indicates big endian.  The image will be con-
verted to 8 bits for display but will also retain 
the 16 bit underlying data that will be used in 
all operations.

 The upper portion of the dialog window defines the parameters of the image as it appears 
on disk.  Only the data length is determined by HyperCube, all other information must come 
from you or the .hdr file.  However, HyperCube does check the input for consistency.

 Pixels:     The number of pixels (columns) per line (row).

 Lines:   The number of lines (rows).

 Header:  The number of bytes, if any,  to skip at the beginning of the file.

 Pixel type: A popup menu specifying the format of each pixel
      8 bit unsigned
      16 bit unsigned
      16 bit signed
      32 bit floating
      32 bit signed long

 Byte order: A popup that indicates whether the most significant data byte is low order
     in memory (little endian) or high order (big endian).  Only meaningful for
     16 bit and larger data.  If gray values seem incorrect, try a different order.
      PC (little endian)
      Mac,Sun (big endian)
      Unknown.

 The lower portion of the dialog window is where you specify what rectangular subset of 
the image file is to be loaded into memory.  There are also options that determine how the 
pixels are to be converted to 8 bits for display (the full pixel depth always remains in memo-
ry).  Pixel conversion is explained more fully in the later multiband example.
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 Specifically, the requested size fields have the following effect:

 Starting pixel: The first pixel within a line to load and corresponds to the left edge  
       of the resulting image display window.  Pixel numbering  begins  
       with 1, not zero.

 Starting line:  The first line of the image file to start loading and corresponds to   
      the top line in the image display window.  Line numbering begins at 1.

 # of pixels:  How many pixels per line should be loaded.

 # of lines:   How many lines of the image are to be loaded.

 Auto Remap:  If this check box is selected then the image pixels are automatically  
      converted from their pixel type to 8 bits based upon the distribution
      of their histogram and upon the percentage popup menu.  Generally,  
      this is meaningful only for 16 bit and wider data.

 %:     If Auto Remap is checked then this popup specifies what percentage
       of the distribution of the histogram about the median is mapped to the  
      display interval [0,255].  See the statistical display window shown in  
      the multiband dialog example.

 Save hdr...  This button brings up the standard Mac save file dialog and allows   
      you to save the *.hdr file defining this image.  Subsequently, opening  
      this image will refill the dialog fields from the *.hdr file.

 Load hdr...  Displays an Open file dialog so that you can load a possibly different
      header file.  There are no restrictions on the fileʼs name.

 Stats:    When clicked, this button reads the image file and generates    
      various statistics within the rectangular area that you want to load.
      The results are displayed graphically in a new window.  See
      section Statistics.

 Cancel:   The customary button for aborting the image load.

 Load:    Loads the image automatically computing statistics as necessary.

 Overview:   This button loads a reduced resolution  view of the source
      image.  The initial scaling is determined by the display screen size and  
      the Starting pixel, Starting line, # of pixels, and # of lines.
      You can select a different scaling.  See section Overviews.
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 The image format dialog window for a hyperspectral image is shown below.  It includes 
all of the raw image fields plus additional to define band depth and the relationship of the file 
pixel values to an absolute [0,1] range for comparison with a reflectance library or when clas-
sifying one image cube against a different image cube (see section Classify Function).

 
The additional fields are defined as:

 Bands:   Total number of bands in the image.

 Interleave:  A popup menu indicating the type of data arrangement:
      Band Line 1 through N for band 1, Line 1 through N for band 2,...
      Line Line 1 for all bands, Line 2 for all bands,...
      Pixel Pixel 1 for all bands, Pixel 2 for all bands,...

 scale & offset: These are the transformation coefficients that convert a file pixel to  
      the range [0,1]. This has nothing to do with display only spectral   
      library matching and classifications with another cube.   In the
      example above the  file pixels lie between 0 and 1000 so the
      transformation is .001 and 0.  Also, see Load Gains & Offsets.

 Starting band: Which band from the image will be the first display band.  Band
      numbering begins at 1.

 # of bands:  How many sequential bands beginning at the starting band should
      be loaded.

 Load hdr...  Displays an Open file dialog so that you can load a possibly different
      header file.  There are no restrictions on the fileʼs name.

The cube image format dialog showing the defi-
nition of a 210 band image with 16 bit  pixels.  
Auto remapping of a 95% interval about the 
median will be used to load bands 60 through 
69.  The pixel values were previously calibrated 
to lie between 0 and 1000 will be converted to a 
[0,1] range by scale.
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 Remap bands individ: Each bandʼs statistics is used to rescale it for presentation.
        Choosing this option produces a display cube having a
        uniform brightness and contrast.  This only alters the display
        and does not affect any subsequent analytical operations.
        Also, see  Remap bands as a group which preserves
        the relative band to band brightness differences.

    ... sigma:  For each bandʼs mean and standard deviation, pixels within
        [mean - sigma*sd, mean + sigma*sd] are mapped to [0,255]. 
 

 Remap bands as a group:  The composite statistics for all of the bands that are
        to be loaded are computed and applied globally.  The result
        is a display cube that represents the intensity variation of the
        image cube file.

 Load Gains & Offsets... Allows you to open a text file containing a list of gains and
        offset pairs that will be applied every time cube file data is   
        accessed and affects all analytical operations such as
        plots and classifications.  The number of gain & offset pairs  
        must equal the number of cube file bands, not just the number  
        of bands loaded.  After a gains & offsets has been loaded the
        the data is internally converted to floating even if the source
        file data is integer and the gains and offsets were also integers.
        Therefore, subsequent operations will be a little slower than
        if no gains and offsets were in effect.  The scale and offset   
        fields that are used in Normalization to convert data to [0,1]  
        interval are applied after any gains & offsets, so be sure to
        change this transformation to match the new range.
        After loading a G & O file the Remap Bands check box will
        be on.  This is necessary due to the new floating point range.
        Remap can be checked off but the resultant display image
        cube will probably be very unsatisfactory.  In any case, this
        will not affect the plots or classifications.
        See sections Spectral Calibration, Reformatting a File
        for more on gains & offsets.

 Use G & O:    Automatically enabled and checked on after a gains and offsets  
        file is loaded but may be checked off to discard the gains and
        offsets.  To determine later whether a G & O file is being used  
        by a cube open the Info window, (Windows -> Show Info),
        and examine the Kind field.  It will show Kind: CUBE w/G&O
         if one is being used.

The remaining cube file dialog fields are identical to those of the raw format.
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Overviews
 The File- > Open As menu items:  Multiband, Raw and certain ERDAS Imagine®, 
NITF and TIFF  dialogs each contain an Overview button.  Its purpose is to generate an im-
age of reduced scaling that displays the entire or user specified subset of the image at a scale 
so that scrolling is not needed.  A dialog is presented showing the nominal scale factor and 
the overview band which you may edit.
 The Requested Input Size, the bottom portion of the dialog, specifies the area of the im-
age used to generate the overview.  The remapping options are used as normal to produce a 
decent appearing image.  When generating a multiband overview, dialog item Starting band 
is the default image for the overview.
 Once an overview image has been generated you can draw a rectangle (see section 
Selection Rectangle) on it that defines the portion of the source image to load by choosing 
menu File -> Load Selection.  Doing so brings up the dialog defining the image along with 
the Starting pixel, Starting line, # of pixels, and # of lines representing the image subset 
delineated by the selection rectangle.  If no selection rectangle has been drawn on the over-
view then the fields will be set to the spatial extent of the overview.  For multiband images, 
the original Starting band and # of bands are not changed.  You may edit any value before 
clicking the Load button.

Choosing Overview from the dialog at the 
upper left generated a 1:2 scale of the  im-
age shown above.  A selection rectangle 
was drawn and File->Load Selection was 
used to display the dialog at the lower left.  
Note the new values that delineate the im-
age shown below when the Load button was 
clicked.
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Saving Overviews
 An overview image serves as a convenient method of automatically extracting the source 
file and saving it in a possibly different file format.  This applies to both a selection rectangle 
and the entire image.  Specifically, NITF, TIFF and Raw image overviews can be saved in 
any of those 3 file types.  Cube image overviews can only be saved in cube image format.  
Save is always performed on the source image file depth .  Any reference coordinates associ-
ated with the source image overview are correctly propogated to the saved image file.  If the 
overview is color then the output is restricted to NITF and TIFF.
 Shown below is a typical dialog that appears after selecting menu File->Save As when 
saving an overview image.  In this case the the overview has a selection rectangle defined.  
Also, see sections: ERDAS Imagine®, NITF Files, TIFF Files and Overviews for detail 
concerning the generation of overviews.

A true color 1:6 overview image 
with a selection rectangle.

The reloaded image resulting from clicking 
the Full Res button in the above dialog.
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Header Files
 As stated previously, each image file can have a unique ASCII text header file that con-
tains all the image characteristics needed to load and display it.  This file has the same name 
as the image but with a .hdr extension and must reside within the same folder as the image 
file.  The two header files shown here (opened as Text files) correspond to raw and multiband 
examples respectively.  They consist of key word assignments, one pair per line in no specific 
order (see section Keyword Format).  A missing assignment defaults to “no” or zero.  Any 
value can be overridden when brought up in the image format dialog and optionally re-saved.  
Although header files can be generated using HyperCube (see section Loading/Saving Text 
Files) and saved as “Text”, itʼs easier to fill in the dialog fields and click the Save hdr... but-
ton.
 HyperCube can read certain ENVI® header files.  Not every format is supported.  The 
program first looks for the beginning ENVI® keyword and if found parses only the informa-
tion necessary to conform to its own header parameters including wavelengths and bad band 
definitions.  You are alerted if an ENVI® header file is being read.  Saving (Save hdr...) in-
formation extracted from an ENVI® file writes a new HyperCube file not an ENVI® header 
file.

Raw      Multiband       Raw with Ref Coords

Various examples of header files.  The last 4 lines of the two right examples list the 
corner coords of the source image in an external reference system where each keyword 
specifies an X,Y pair (see next section, Keyword Format).  Any combination of 1,2,3 or 
all 4 keywords may be given.  Selecting menu Windows -> Show Info will display the 
computed reference coord as a function of the window cursor position.  Section Image 
to Reference Coordinates describes how to edit these values.
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Keyword Format

 Keywords used in the header file are defined below.  Each keyword is of the form:
   keyword = value.  None of the words are case sensitive.

 Keyword    Value
 samples    number of source image pixels per line

 lines     number of source image lines

 bands     number of source image bands, if multiband or sync

 file type    multiband
       raw

 data type   1 - unsigned byte
       2 - unsigned 16 bit short
       3 - signed 16 bit short
       4 - 32 bit float
       5 - 32 bit signed long

 interleave   bsq - band sequential
       bil - line sequential
       bip - pixel sequential

 xstart    starting pixel within the source image to load

 ystart    starting line within the source image to load

 numpixels   number of pixels to load beginning at xstart

 numlines    number of lines to load beginning at ystart

 byteorder   little endian - PC
       big endian - Mac, Sun

 bandstart   starting band to load for display purposes

 numbands    number of bands to display starting at bandstart

 autoscaling   yes - remap image for display purposes

 percent    % of  remapping statistics to use for display purposes

 bandnormalize  yes - remap each displayed band using its own statistics

 sigma     number of standard deviations used by bandnormalize
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 normScale   scale factor to convert pixel values to [0,1] range

 normOffset   offset to convert pixel values to [0,1] range

 sync type   tc - true color synthetic cube
       % - classify overlay synthetic cube representing percentage
       # - classify overlay synthetic cube representing counts
       d - classify overlay synthetic cube representing thresholds

 icords    G - reference coords represent latitude and longitude
       formatted as ddmmss.sZ for latitude (y) where Z is N or S
       followed by dddmmss.sZ for longitude(x) where Z is E or W
       D - decimal degrees latitude (y) and longitude (x)
       Note the order: latitude value followed by the longitude value.
       Also, icords is not required to define a general reference.

 upper left   x,y reference coord pair corresponding to pixel, line [1,1]

 upper right   x,y pair corresponding to pixel, line [# image pixels,1]

 lower left   x,y pair corresponding to pixel, line [1,# image lines]

 lower right   x,y pair corresponding to pixel, line [# image pixels,# image lines]

 color specific  red, green and blue wavelength values corresponding to those in
       menu Image -> Cube Color Composite -> Definitions

 color intervals red, green,blue wavelength intervals corresponding to those in
       menu Image -> Cube Color Composite -> Definitions
 
 color equalize  0 - use color percent value in Cube Color Composite
       1 - use histogram equalization for Cube Color Composite

 color percent  remapping percentage corresponding to the value in
       menu Image -> Cube Color Composite -> Definitions
       keyword not present if color equalize = 1

      



HyperCube Pictorial Userʼs Guide  8/31/04 Page 26

Image to Reference Coordinates
 You can specify the relation between image coordiantes and a reference coordinate 
system by including keywords such as upper left, upper right..., described in sections 
Header Files and Keyword Format or at any time an image window is active by choos-
ing menu Edit -> Options -> Image to Ref Coords.  This brings up a dialog showing the 
current pairings of the image corner coordinates and the corresponding reference coordinates.  
If no relation has been defined then the mapping is the identity and the reference values will 
match the image values.  Note that the dialog is completely general and you may specify 
other than the given corner coordinate pairings, e.g., a known image interior point and the 
matching reference point.  From 1 (simple translation) to 4 (least squares affine) pairs can 
be specified.  Set unwanted pairings to all zeros.  Saving an image after defining an image to 
reference relation saves the equivalent corner coordinate to reference mapping in the imageʼs 
header file.  The option for formatted latitude and longitude is specific:  ddmmss.sy where y 
is either N or S for latitude and dddmmss.sz where z is E or W for longitude.  Some general 
reference values donʼt correspond to latitude and longitude and you will get a warning mes-
sage when selecting from General to lat and long.  The Residuals button displays the dif-
ference between the input reference values and the the computed reference values from the 
resulting affine transformation.
 Note: Changing the image origin via Edit- > Options- > [0,0] Image Origin will disable 
all Image to Reference correspondences in effect and you will have to re-establish them.  
Also, some image formats such as NITF and TIFF have reference coordinates in their headers 
(see sections NITF Files and TIFF Files).  

The correspondence between image coordinates and a reference system expressed in 
latitude and longitude.  Clicking Okay will define the relation which can be displayed 
dynamically in the Info window.  This relation will be included in the header file if the 
image is saved.  Clicking the Cancel button ignores any changes but does not remove 
an existing relation.  Clicking the Disable current button removes the reference rela-
tion.  The Residuals button computes and displays the difference between the input 
values and the resulting transformed reference values.
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Wavelength File
 In order to perform analytic operations on a multiband image, it is necessary to know the 
wavelength associated with each image band.  Similar to the *.hdr file there is an ASCII text 
file that specifies this information.  The wavelength file has the same name as the multiband 
image file but with a .wvl extension (previous versions of HyperCube used wav extension 
which are still read correctly if the .wvl extension is not found).  For an N band image there 
are N rows of values.  HyperCube can parse 3 different formats: a row consisting of just the 
wavelength, a row consisting of a band number and wavelength and a row consisting of band 
number, wavelength, band width and status.  Each element in a row is separated by a tab 
or space with the row terminated by a return or new line.  The file can be generated using a 
spreadsheet or word processor and is completely editable in HyperCube.  Below is the text 
*.wvl file for a 210 band image and the way it appears in the program for editing.  See section 
Band List for a definitions of the various options.
 HyperCube can also extract the wavelengths as well as other image parameters from an 
RSI ENVI® header file (see section Header Files).

 If the *.wvl (or the older *.wav) file doesnʼt exist for the multiband image then band num-
bers will be substituted for wavelength values and you will get a warning message during the 
image loading process directing you to menu Windows -> Show Band List  where several 
options are available for creating/modifying one.  See section Band List  for more detail.

The HyperCube band list after selecting 
menu Windows -> Show Band List while 
cube image drII is active.

One of the three possible ASCII *.wvl 
files defining wavelengths recognized by 
HyperCube.  This format also includes 
the band widths and satus of each band.
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Statistics
 Shown below and on the following page are the results of clicking the Stats button when 
loading a Raw or Multiband image.  Two histograms are generated: a basic data plot that can 
be resized and magnified and a remapping plot defining how the data is converted for display.  
Also, see section Histograms.

 The numbers shown for Min, Max, and so on are the values for the pixels in the image 
file within the rectangular area chosen by the user for subsequent loading.  In this case they 
are confined to 16 bit unsigned [0,65535] pixels.  In the above example the remapping limits 
extend over the full range of the input data because the percent default is at 100.  Another 
example using hyperspectral data appears on the following page.

 The statistics window is important for visualization because based upon its values the 
image file pixels are remapped to the 8 bit [0,255] display range.  Explicitly, the image file 
interval:

  [pixel_median - %/2, pixel_median + %/2]  is mapped to  [0,255].

  Values < pixel_median - %/2 are set to zero.

  Values > pixel_median + %/2 are set to 255.

If the resulting loaded image appears too bland (washed out) then the auto remapping per-
centage should be made lower using the % edit field.  If the image appears too contrasty then 
the percentage should be made larger.

The histogram of an image with 16 
bit unsigned pixels along with vari-
ous statistics.

The yellow highlight covers the entire area 
to match the 100% remapping specified in 
the load dialog.  In this case pixel value 
883 will be mapped to zero and value 1534 
will be mapped to 255 for display.
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 Below are display snippets of the example multiband data after being loaded with 3 dif-
ferent auto remapping percentages.

 Regardless of how the imagery is remapped for display purposes, all analytic operations 
such as plotting, spectral classification and image arithmetic can operate upon the image file 
as well as the converted display values.  So although saturation and underflow typically oc-
curs when displaying multiband images all of the arithmetic is performed on the full range of 
the file data.
 If Remap Bands Individually is chosen in the image format dialog then each band 
will be correctly gray mapped but at the expense of maintaining their relative brightnesses.  
Again, this will not affect any classifications or plotting.  If menu Edit -> Options -> De-
tailed Messages is checked on then two scrollable lists will be output showing the individu-
al statistics and remapping coefficients for each band.

100% Interval 95% Interval 70% Interval

The complete histogram and 
statistics of a 210 band hyperspec-
tral image having 16 bit unsigned 
pixel values.

The yellow highlighting delineates 
the 95% area that will be remapped 
to [0,255] for display.  Pixel values 
below 16 will be black and those 
above 490 will be white.
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Image Operations

Zoom
 Image zooming is selected via menu Image -> Zoom.  It is automatically enabled when-
ever the active window is an image window, otherwise it is disabled. Each  Zoom In magni-
fies an image by 2 until it reaches 16 times then it is disabled.  Each Zoom Out de-magnifies 
by 2 until the magnification is unity.  The current zoom factor is displayed in each windowʼs 
title bar.  Zooming is performed by pixel replication and is a “virtual” image in that a saved 
zoomed image is un-zoomed.  To generate a “real” magnified image use Magnify in the 
Image menu.  Printing or copying a zoomed window does produce a zoomed output. The 
keyboard equivalents for Zoom In and Zoom Out are command +  and - respectively.

Selection Rectangle
 Many image operations can be constrained to a 
subset of an image by drawing a selection rectangle 
within the image window.  This is done by position-
ing the cursor to one corner of the area, pressing the 
mouse button and dragging to the opposite corner 
and releasing the mouse button.  When completed 
the area will be delineated by a rotating marquee at 
the boundary as shown here.  A single mouse click 

(double click  in the Windows version) anywhere within the image window or pressing the 
delete key or choosing Clear from the Edit menu will deselect the rectangle.  The rectangle 
may be repositioned by pressing and holding down the mouse while the cursor is within the 
selection boundary and dragging to a new position and then releasing the mouse.  The cur-
sor changes to a multiple arrow while dragging.  Each image window can have at most one 
selection rectangle.  Itʼs possible to unintentionally hide a selection if a window is re-sized.  
Scrolling a window will bring the selection area back into view.

Copy, Paste & Duplicate
 HyperCube allows copying and pasting entire images or selection rectangles between the 
Mac clipboard and its own image windows as well as other applicationʼs windows.  Only Pict 
type data is recognized.  This is a standard clipboard data type used by every application.  In 
order to perform a copy draw a selection rectangle about the image area to be copied, then 
choose Copy from the Edit menu or the keyboard equivalent, command C.  If there is no 
selection rectangle active or the window contains a plot or list or some other non-image then 
the entire window is copied to the clipboard.  To paste something already in the clipboard, 
click anywhere within the destination window to activate it and choose Paste from the Edit 
menu or its keyboard equivalent, command V.  Paste will not be enabled unless there is Pict 
data or color pixel value in the clipboard.  The pasted data appears in the center of the view-
able area of the front most image window with a selection rectangle around it.  It does not 
paste into an existing selection and if there was one it just disappears.  If the target image is 
too small to hold the paste then the clipboard data is re-sized to fit within the image boundar-
ies.  The pasted data can be moved by clicking and holding down the mouse within the selec-
tion rectangle and dragging it to a new position.  The cursor changes to a hand during the 

© 1935 Paramont
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repositioning.  A single click anywhere within the image window embeds the paste.  Pressing 
the delete key or choosing menu  Edit->Clear erases the selection without pasting it.
 If File -> New... is chosen and there is something in the clipboard to paste then the 
default size of the new window will be set equal to the size of the image in the clipboard.  
Performing a paste will copy the clipboard to the new window.
 A copy of the currently active image window or selection rectangle can be made by 
choosing the Edit -> Duplicate menu.  This option is available for almost every type of 
window.  The duplicated image will have the same name as the original followed by the word 
“Copy”.  Some HyperCube operations, such as constructing a cube, automatically make im-
age duplicates.  Also, see section Saving and Copying Scrollable List.
 Any time that the cusor is over an image window, regardless if the window is front most, 
the current pixel value may be copied to the clipboard by also pressing the option key, e.g.  
command+option+C combination (Ctrl+Alt+C in Windows version).  This value may subse-
quently be used as the selected color in many HyperCube functions, (see sections Image to 
Mask, Adjacency, Selection Point Colors and Class Map Editor).

Gray Mapping
 The contrast and brightness of the active gray scale or color  image window may be inter-
actively changed by selecting menu Image -> Gray Map.  This opens a window containing 
controls to modify the pixels in the image and a graphical plot of the current transformation 
and resulting histogram.  The GrayMap  window applies only to the image window that 

was active (front most) when Gray Map... was selected.  However, every image window 
can have its own gray mapping operator.  For Linear mapping the Contrast and Brightness 
sliders control the slope and y intercept of the graphical plot respectively.  The horizontal plot 
axis  represents the input pixels [0,255] and the vertical axis represents the remapped pixel 
values, also in the [0,255] range.  Initially, the slope is 1 and the intercept is 0 signifying that 
the input is identically mapped to the output.  The contrast range is [-9,9] and the brightness 
range is [-56,56].  Negative slopes produce complementary pixels.  Above is an example of 
gray mapping applied to just a selection rectangle within an image.  If there is no selection 
rectangle then the entire image is gray mapped.  Clicking the Apply button embeds the gray 
mapping into the selection area, or the entire image if no selection.  There is one exception: 

The effect of modifying the brightness within a selection rectangle.
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Rubberband gray mapping being applied to a selection 
area.  The sliders are not used and are grayed out.

an 8 bit color indexed image is remapped entirely regardless of any selection rectangle.  If 
a GrayMap window becomes hidden behind another window you can bring it to the front 
by selecting its name from the Windows menu.  As long as the Apply button has not been 
clicked the identity gray mapping can be recovered by clicking the Reset button.  A histo-
gram dynamically displays the entire imageʼs histogram as a function of the current transfor-
mation starting with the unmapped histogram of the image.
 Rubberband gray mapping doesnʼt use the slider controls.  It allows you to position the 
cursor within the plot area while holding down the mouse button.  The graph then tracks the 
cursor and consists of two slopes with the cursor at their break point.  Rubberband mapping 
is very useful in bringing out shadow detail without completely washing-out the surrounding 
area.  An example of this is shown below.
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Color Mapping
 You can modify the color balance of an image  by selecting menu Image -> Color Map.  
It is similar to gray level mapping (Gray Map).  Sliders are used to independently modify 
the red, green and blue brightness and contrast of an image and its hue (color tint), satura-
tion (purity) and intensity (overall brightness) while showing the effect on the 3 historgrams.  
Note that subtracting a color is the same as adding its complement and vice versa: adding is 
subtracting the complement.  The controls and buttons perform the same as gray mapping 
with the same exception:  Apply modifies an entire 8 bit indexed color image regardless of 
any selection rectangle.
 An image may have only one operator attached to it at a time.  Specifically, Gray Map, 
Color Map, and the two filtering operators: Static and Dynamic (described in later sections) 
are all mutually exclusive.  Also, see section Info Window which describes displaying the 
red, green, blue, hue, saturation and intensity values associated with the cursor position.

Color balance emphasizing green 
within a selection rectangle.

Effect of modifying the hue, saturation 
and intensity within a selection rectangle.
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Data Mapping
 Windows containing images that represent more than 8 bit pixels are automatically 
mapped from their full pixel depth (e.g., 16 bit signed and unsigned, 32 bit float and signed 
long) to 8 bits for display when they are loaded or created (the underlying data is kept in 
memory at full pixel depth, see section Files, Data, Images and Display).  Menu item Image 
-> Data Mapping... allows you to interactively remap the source data (in memory) to 8 bits.  
It does not change the actual underlying data, only the way it is displayed.  This menu item 
is only enabled for single gray scale images with pixel depths greater than 8 bits.  It does not 
apply to image cubes (a single band may be remapped by displaying it and choosing menu 
Edit -> Duplicate and performing Data Mapping on the duplicate).
 If the source image contains a selection rectangle then the remapping is restricted to that 
region.  Button Reset restores the displayed image to its state before Data Mapping was 
enabled.  Additionally, a selection rectangle can be drawn within the Data Histogram area 
of the dialog and will linearly remap data values falling within the histogram rectangle limits 
and truncate others to zero or 255.

The selection rectangle within the image has been remapped using 
median interval percent of data within the rectangle.

The hist equal remap was first applied to the image selection rectangle 
followed by a selection drawn over the Data Histogram dialog further 
limiting the linear remapping of the histogram equalized values.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 35

Flips & Rotations
 Each loaded image can be flipped and rotated in orientation.  As shown below there are 3 
kinds of flips and 3 rotations.  The Left->Right flip changes the order of the pixels within a 
line and the Top -> Bottom flip changes the order of the lines.  Band Order is only enabled 
for multiband images and re-sequences loaded bands but not their wavelengths.  Therefore,  
the last band becomes the first band and the first band becomes the last band.  Flips and rota-
tions are global operations and ignore any selection rectangles.

 The Rotate menu item is similar to Flip.  Rotations 
may be 90, 180 or an arbitrary number of degrees.  90 
and 180 operate on an entire image (including multi-
band) while General can rotate a selection rectangle as 
well as the whole image and uses the currently selected 
interpolation method (see section Magnify).  Note that 
rotating a non-square image results in interchanging the number of pixels and lines. Also, 
flips and rotations disassociate the new image geometry from the original image file geom-
etry.  Therefore, library matches and classifications of multiband images will be erroneous as 
well as spectral plots of their files.
 The Reformat Cube File function in the Utilities menu is used to change the internal 
structure of the multiband image file itself not just what is loaded in memory.  It also regener-
ates the *.hdr and *.wav files as necessary.  

Flip, Rotate and Shift appear in the Image menu.
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Shifts
 The Image -> Shift menu item operates 
on whole images and allows both integral and 
fractional shifts.  All of the integral shifts are 
cyclic so that pixels shifted off one end appear 
on the opposite end so they are invertible. The 
fractional part of a shift is not invertible. It is 
done in the frequency domain by applying a 
linear phase shift to the Fourier transform of 
the line or column.  Therefore, a 1.6 pixel left 
shift followed by a 1.6 pixel  right shift will not exactly reproduce the original image.  Left 
and Right shifts can be applied to All lines or just the Even lines.  They are useful in cor-
recting interleaving errors in captured video images.  Below is an example of such an image 
before and after shifting only the even lines.  Shifts applied to a cube only affect the currently 
displayed band.  Overwrite is a toggled flag.  If checked (on) then the shift overwrites the 
source image or cube band, else the result of the shift generates a new separate image.  A 
warning is given when overwriting.

Magnified captured video frame before and after Shift Right Even lines.

Filtering (Spatial Domain)
 HyperCube provides several methods for filter-
ing an image in both the spatial (pixel) domain 
and the frequency (Fourier) domain.  The later is 
described in the Image Functions section.  Spatial 
filtering convolves the image pixels with various user selected matrices and HyperCube pro-
vides two methods:  a 3x3 interactive kernel and a 5x5 static kernel.  The 3x3 contains sliders 
for altering the matrix elements while the 5x5 uses edit fields and operates as a one-shot.  You 
may save the 5x5 coefficients and read existing 5x5 convolver values including those saved 
by Photoshop™.
 Each type of convolver is an operator to the specific image window that was active when 
Image -> Filter was selected from the Image menu.  Closing the image also closes the filter.  
If a selection rectangle is present on an image then the filter is constrained to that area.  The 
filtering does not become permanent until the Apply button is clicked.
 Filtering is an image operator and as stated earlier an image may have at most one opera-
tor at a time, e.g.  if Gray Map is active on an image then it must be closed before any filter-
ing can be applied.
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The various sliders on the 3x3 convolver have the following actions:

  Diagonal  Modify the 4 corners, (1,1), (1,3), (3,1), and (3,3)
  Edge   Modify only the (1,2), (2,1), (2,3) and (3,2) elements
  Center  Modify only the (2,2) element

Note that since the sliders produce positive and negative values many positions donʼt produce 
meaningful image manipulations.  The Sharp <--> Blur slider tries to solve this problem by 
parametrically modifying the other 3 sliders to produce a continuous range from sharpen to 
blur.  The 3 by 3 matrix window shows the instantaneous convolver coefficients as depicted 
in the figure below.

The 3x3 convolver applying a 
sharpening function to a selec-
tion rectangle within an image.

 The 5x5 static convolver, shown at right, allows you to 
input  25 separate coefficients.  All of the coefficients must 
be integers.  The Scale value is divided into the coefficients 
and the Offset value is added to the final resultant pixel.  
The popup menu has several predefined kernels which may 
be modified.  A loaded or save kernel will occupy the User 
menu slot.  Since there are so many degrees of freedom itʼs 
easy to generate meaningless pixels and experimentation 
helps.  Any set of coefficients may be saved via the Save... 
button and retrieved with the Load... button.  The coeffi-
cients are compatible with those produced by Photoshop™  
and HyperCube will recognize the later.
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Magnify
 A whole image or the contents of an 
image selection rectangle can be magnified 
producing a new independent image.  The 
magnification range is mostly unlimited as 
long as the resultant image is at least 32 by 
32 in size and there exists enough RAM.   
The type of interpolation can be replication, 
bilinear or cubic resampling.  Menu Image 
-> Magnify toggles between Image and 
Selection depending on whether or not a 
selection rectangle is exists on the object 
image window (see section HyperCube 
Menus).  A submenu specifies several 
magnifications and permits you to enter an 
arbitrary factor that is preset to .75x.  Menu, 
Edit -> Options -> Mag/Rotate Interpolation determines the type of interpolation.  The 
initial interpolation is set to Replicate.  Included below are examples of a 4x magnifica-
tion using each type of interpolation.  Replication is best for viewing the actual pixels while 
bilinear and cubic produce photographic like enlargements.  Also see the HyperCube section 
describing Warp.  

Original selection

Replicate

Bilinear

Cubic

A 4x magnification applied 
to an image subset utilizing 
all three interpolators.  The 
original is shown at 2x for 
clarity.
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Info Window
 HyperCube contains one window, Info,  that is always available and dynamically displays 
information about any of the other HyperCube windows.  The kinds of information depend 
upon which window the cursor is in.  When the program starts, Info is hidden and can be 
shown at anytime by selecting menu Windows -> Show Info.  It is not a floating window 
when running in the Classic Mac OS and if it becomes obscured by another window can be 
brought to the front by Show Info.  It is a floating window in Mac OS X and in Windows.  
To hide it click its close box.  To print it, use the keyboard equivalent command P instead of 
the mouse so that the cursor doesnʼt move off its current position and change the Info values.
 The types of information displayed include the amount of remaining free memory, the 
type of window, and the position and current gray or color values of the pixel beneath the 
cursor.  The origin of all windows is [1,1] at the upper left unless [0,0] Image Origin is 
selected from menu Edit -> Options.  And when placed on a histogram plot it shows the bin 
number and on a profile plot the x,y,z values.  Various Info window examples appear below.

Cursor over a gray 
scale image.  Data 
value matches pixel 
value.

A true color image pixel 
with the red, green and 
blue color components.

Cursor over a spectral 
plot window.

Over a Raw image with 
external reference coords 
(see section Header Files).

Cursor over a profile plot 
showing the correspond-
ing x,y,z image values for 
a point on the profile line.

The cursor is positioned over a 
flicker window.  Values change 
according to the flicker rate.  
Image 1 has been offset using 
the arrow keys.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 40

Components to Color
 Three gray scale images  are com-
bined to form a composite true color 
image and is chosen by selecting Image 
-> Convert Image -> R,G,B to Color 
or H,S,I to Color (Hue, Saturation and 
Intensity to color).  Since any three gray 
scale images can be used, including 
bands of a multiband cube image, Hyper-
Cube displays a dialog window asking 
you to specify which image represents 
which of the three colors.  The three 
components do not have to be the same 
size, the true color result will be their 
minimum size.  If all three images are 
bands from the same image cube the 
Link to Cube check box is enabled and if selected the resultant color image will be logi-
cally connected to the parent cube image.  This image can then be used to select points for 
subsequent spectral plotting and classification (see section Classify).  If red, green and blue 
are all cube bands (not necessarily from the same cube) then Entire Cube may be selected 
and a synthetic color cube will be automatically generated in which each band consists of the 
corresponding components (bands) from the cubes.  The number of bands in this cube will be 
the minimum of the number of bands currently loaded from the source cubes.

Image Conversions

The left dialog shows the selection of three bands to be composited to form a true color 
image.  The right dialog similarly forms a true color image treating the components as 
if they represented hue, saturation and intensity (also see Applications->Stereo Mates).  
Checking Permutations produces 6 color output images.

 These are inverses of the previous functions.  Any true color image window, i.e. those 
that show a depth of 24 or 32 in the Info window, can be separated into 3 same size gray 
scale images representing the red, green and blue or hue, saturation and intensity, compo-
nents respectively.  The original image is not affected.  To perform the conversion activate 
the color image window and choose Image -> Convert Image -> Color to R,G,B  or Color 
to H,S,I .

Image to Various Components
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Image to Principal Components
  Image -> Convert Image -> Principal Components uses the Hotelling transform to 
convert a color or cube image into its principal components.  Either the covariance or correla-
tion matrix statistics can be used as the basis for the transform (and optionally saved).  If the 
source is a cube then you will be presented with the following dialog allowing you to trans-
form either just the bands that are currently loaded into memory or the actual cube file.The 
result of transforming an image cube file is a cube file that can be treated like any image cube 
to perform classifications and “spectral” looking plots.

Selecting Window transforms only those bands pres-
ently in memory and produces a cube in memory.  
Selecting File transforms the image cube file and 
produces a new cube file.  The new cube bands are the 
principal components and are ordered in decreasing 
eigenvalues.  The Save... check box writes the various 
matrices to an ASCII file.  See section Apply Trans-
formation for format details.  The two Use selection... 
options allow ignoring any selection rectangle.

Shown at the top are the first 3 principal components generated from 166 enabled bands of a 
210 band image.  The plot and listing of the eigenvalues are also output as well as an image 
representation of the eigenvectors.  The later may be examined via a line profile plot, histo-
gram or using the cursor with the Info window (see section Apply Transformation for format 
details).
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Indexed to Color
 An indexed, or pseudo, image is an 8 bit image similar to gray scale but one in which 
the pixel value is an index into a color table.  Therefore it has at most 256 distinct colors.  A 
gray scale image is a special case of an indexed image in that its color table has the same 
red, green and blue intensity for each of its indices and is the actual pixel value  (HyperCube 
checks all indexed images to see if they are actually gray because this greatly simplifies a lot 
of arithmetic).  If the currently active window contains an indexed image then you can select 
Image -> Convert Image -> Indexed to Color.  This will generate a new true color image.  
If the original image was gray then the new image will also be gray with equal red, green and 
blue components at each pixel.  Note that on the Macintosh a full true color image is 32 bits 
in depth, not 24 as might be expected.  The extra byte is for special effects.  HyperCube also 
handles the Macintosh 16 bit (thousands) color image:  three 5 bit color components plus a 
special effect bit.
 Special note, Mac OS X only:  Eight bit pseudo color Pict images are converted to true 
color when loaded.  This does not apply to Pict 8 bit gray images or any other file types.

Color to Indexed
 This is the most difficult type of color image conversion because there is no one to one 
transformation.  A typical 512 by 512 true color image could have over a quarter million 
colors which must be reduced to only 256 colors.  HyperCube tries to find the best 256 but 
sometimes the results are not acceptable.  Normally, true color to index should only be used 
when the source image has very few distinct colors or to save storage as in making a true 
color image fit on a floppy disk.  Its necessity has become less valid with JPEG compression 
(see section JPEG Files).  You can select the Image -> Convert Image -> Color to In-
dexed   menu when the front most window contains a true color image.

Gray Scale/Color Tables
 You can convert the active image window to a new 8 bit gray scale image by selecting  
the Image -> Convert Image -> Grayscale submenu.  If the image was already a gray 
scale then a copy is formed.  If the image was color, either indexed or true, the three color 
components are combined together to form a single intensity by the following formula used 
to convert NTSC color signals to gray:

     gray = .30*red + .59*green + .11*blue

This method yields a more natural gray image then using equal weights of the 3 components.
 HyperCube contains a submenu called Color Table under 
Convert Image showing several color mappings that may be 
applied to an 8 bit indexed image.  The top one overwrites the 
imageʼs color table with a linear gray ramp forcing an indexed 
color image into some gray appearing image.  The second strip 
complements the existing table so that selecting it twice restores 
the original table.  The remaining 3 menu options overwrite the 
existing color table and color code the image pixels so that pixel 
(index) zero represents the left most color and pixel 255 the right 
most color.  Also see the Classify section describing output products.
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Replace Color
 Any specific color or gray value within an image may be substituted with another value. 
The result is a same sized image with only that modification.  If the image is a cube then a 
copy of the band face is used as the source.  Choosing Image -> Convert Image -> Re-
place Color...  brings up the following dialog with the last two colors or gray values, if any, 
that have been first selected by the command+option+C key combination or Ctrl+Alt+C in 
Windows version (also see section Copy, Paste & Duplicate).  The first selected value will 
be Color 1, the color to search for, and the second as Color 2, the replacement color.
 If Replace all gray... is checked then Color 1 is ignored and every gray value (non-
color) is replaced with Color 2.  This is useful for converting a color overlay to a mask.

The Replace Color dialog was used twice to convert 
the image at below left, a classification mask, to the 
image at its right.  The dialog shows the first conver-
sion, red to yellow.  A second conversion using the 
output from the first replaced the black background 
with gray [128,128,128].    The intermediate yellow 
and black image is not shown.  Replace all gray... can 
be used to convert a color overlay to a color mask.  
See section Image Products.

Original spectral classification 
mask as output from Classify.

After two successive uses of 
Replace Color.
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Image to Mask
 An image can be converted to another image that corresponds to a specific gray level or 
color within the image.  Two types of output are possible.  The first (Binary) produces a same 
size image (mask) that consists of white (255) everywhere that specific color (gray level) 
appeared in the source image and black (0) everywhere else.  The second type (Color sepa-
ration) consists of the chosen color in place of white and black everywhere else, i.e. only the 
color selection itself remains.  This is most useful where the source image does not contain 
numerous colors (gray levels) such as when separating a specific classification color from 
a color composite produced with the Classify function.  The initial color (gray level) to be 
extracted is automatically preset to the last comnand-option C key combination used to copy 
a pixel color to the clipboard (see section Copy, Paste & Duplicate).
 When an image is frontmost, choose Image -> Convert Image -> Image to Mask.  
This will bring up the following dialog window:

The respective red, green and blue components of 
the color to be extracted in generating the mask 
images in the examples below.  Mask Type Binary 
produces white wherever the rgb pixel value is 
[241,167,185] while Color Separation outputs the 
actual pixel value.  If the image to be converted 
is a gray level image then the dialog will instead 
solicit a single gray level with the same options.

A source true color image that was derived from a 
spectral classification.  The cursor was positioned 
over a road and the command-option-C key combina-
tion pressed to store the pixel color into the clipboard 
prior to choosing Image->Convert->Image to Mask... 
from the menu.

Binary Mask Type consisting only of 
black (0) and white (255) values.

Color separation Mask Type consist-
ing of black and the extracted color.
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Histogram Equalization
 HyperCube has three functions within menu Image -> Convert Image -> Histogram 
Equalize to perform histogram equalizations of an image.  In each case a new image is 
generated leaving the source image intact.  Any 
gray or true color image may be the source.  Each 
function attempts to construct an image whose 
histogram matches a particular distribution.  Generally, this can not be done exactly.  For ex-
ample, a non-uniform 256 bin histogram (8 bit gray or a color component) canʼt be mapped 
to a uniform 256 bin histogram, there will be “holes”.  The methods used by the three tech-
niques are as follows:  Uniform attempts to remap the pixel values so that there are an equal 
number of resulting pixels in each of the 256 histogram bins.  If the source image is color (24 
bits) then the red, green and blue 8 bit pixels are treated as a truncated 18 bit pixel (the low 
order 2 bits of each color is ignored) whose histogram is used to remap the 24 bits uniformly.  
The second method, Uniform (ea. color), performs the uniform equalization independently 
on each color (8 bit red, green and blue components) and then combines the results.  The last 
method, Match Image..., uses the histogram of a second image as the target histogram distri-
bution, i.e.,  each component of the source image is remapped so that its histogram matches 
the corresponding component histogram of the Match Image.  Note, if the source image has 
a selection rectangle present then the equalization is based only on the selection rectangle 
statistics but is applied to the entire output image and if the source image is chosen as the 
Match Image (same image) and has a selection rectangle then the entire image is remapped 
to that of the selection rectangle histogram.
 Shown below are examples using the three methods.

Original true color image.

The right image is the result of using Histogram Equalize -> Match Image 
which in this case forced the histogram of  the source image on the left to 
match the histogram within the selection rectangle of the center image.

Resulting image after 
Uniform histogram.

Source image after 
Uniform (ea. color).

Source The Match Image with 
selection rectangle

Result
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Cube Color Linked Image
 The current, if any, linked color composite image can be switched to another existing 
color image as long as it is the same spatial size by selecting Image -> Convert Image -> 
New Cube Link.  The following dialog then appears listing candidate images.  Any previous 
link will be disconnected and any current selection points will be transfered to the new link.

Color to Classmap
 A true color image can be transformed into a classmap in which the first 1024 colors 
(gray shades are excluded) are assigned classes 1 thru 1024 by selecting menu Image -> 
Convert Image -> Color to Classmap.  The classmap can then be modified using all of 
the features in menu Utilities -> Classmap Editor (see section Class Map Editor)  If the 
source image is pseudo color you will be prompted to convert it to a true color image.  In this 
case, there will be at most 256 classes.  Since a typical color image usually contains more 
than 1024 colors this conversion is most useful after masking and/or image arithmetic func-
tions to reduce the number of colors.

Attach Data
 Sometimes itʼs convenient to merge 2 disparate types of images to-
gether.  For example: a classmap (color coded features) and a matching 
elevation image (data values).  This is accomplished by selecting the 
data image window to make it active and then choosing menu Image 
-> Attach Data... .  This brings up a dialog listing all of the candidate 
images.  An image is a candidate to receive data only if the number 
of lines and pixels is the same as the data image.  After data has been 
attached to an image the Info window will show the image color/gray 
values and the corresponding data value as the cursor is moved over the 
image (see section Info Window).  When saving a merged image you 
are presented with a dialog stating that the source image has attached 
data and asking you if you want the data saved as well.  If your answer 
is affirmative then the data is saved separately in 
Raw format (see section Raw) so that it and the 
source image can be reloaded and merged together 
again.
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Image Functions
Statistical Measures
 Functions -> Statistics contains two methods 
for computing the linear correlation between 2 or 
more gray scale images.  The first of these, Pair Cor-
relations..., allows you to select any two non-color 
images from popup menus and then calculates their 
correlation or covariance as a function of pixel and 
line offsets.  The results are listed in a 7 by 7 matrix 
showing the computed values for each given offset.  The Options... button permits changing 
the initial offset between the 2 images and the pixel and line shifts per iteration.  If image 1 
has a selection rectangle then the computation can be confined to the selection by checking 
the Use Image 1 Selection Box.  The check box will only be enabled if there is a selection 
rectangle on image 1. Pairs Correlations can be used to determine how good the registra-
tion is between various bands of a multiband image.  The Image Shift checkbox is used to 
compute where the maximum correlation occurs and via interpolation, what the fractional 
shift is.  Each computation is generated by selecting the Update button.

The linear cross correlation between 
two bands of a multiband data set 
using the default values for offset and 
delta is shown at the right.  The corre-
sponding covariance between the two 
bands is shown below it.

The options dialog window specifies the 
initial pixel and line offset as well as 
their respective steps for each iteration.

The computed pixel shift (shown above) 
between the images after checking Im-
age Shift.  This is in accordance with 
the position of where the maximum 
correlation value appears (i.e., between 
0 and +1 pixel offset to compensate for 
the negative shift value).
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 If the Image 1 popup menu displays a band from a cube image then you can generate all 
of the relative shifts between that band and every band within the same cube.  This is done by 
selecting the List Shift and Cube checkboxes which will ignore the Image 2 popup menu.  
Shown below is the Dialog and the 3 resulting outputs after the Update button is pressed.

A partial list of each band s̓ 
offset relative to band 1.

The relative pixel (horizontal) shift 
between band 1 and each band.

The relative line (vertical) shift 
between band 1 and each band.

A band from an image cube is selected in Image 1 along with 
List Shift and Cube to produce the outputs shown below.
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The sequential band to band correlation 
plot showing the absence of correlation 
within the water absorption portion of the 
spectrum.  Generated from file data.

Same multiband data with band 31 
compared with all of the bands within the 
cube including itself.  Clicking a list item 
highlights its position within the graph.

 If 32 or more bands are used then both the covariance and correlation matrices generated 
in the statistics are converted into  images that can be further analysed by performing profile 
plots, histograms and examining values via the cursor and Info window.

The matching Covariance and Cor-
relation images corresponding to the 
statistics plots shown above.  The im-
age size is the number of bands and 
pixels represent floating point data, 
large values for Covariance and -1 to 
+1 values for Correlation.

 The second type of correlation in HyperCube, 
Functions -> Statistics -> Band Correlations, is 
restricted to multiband images.  It calculates various 
combinations of linear correlation coefficient, covari-
ance, variance,  mean and histogram.  The dialog at the 
right gives you the choice of using either the window 
image data already in memory or the file image data.  
The result is shown graphically with a scrollable list 
window.  Clicking on an item in the scrolled list high-
lights it on the graph.  The radio buttons determine 
the type of comparison and the statistics.  Sequential 
correlates each band with the next band, i.e.  band 1 to band 2, band 2 to band 3 and so on.  
Specific allows you to select any band from the Band popup menu and compare it with all 
of the others.  Shown here are the results of correlation applied to a 210 band image.   The 
vertical marker in each graph corresponds to the highlighted values in the lists.  The list val-
ues may be saved as text by choosing File Menu -> Save when the dialog window is front 
most or copied, (Edit -> Copy), to the clipboard and subsequently pasted as columnar data 
into a spreadsheet application such as Excel™.  The correlation and covariance matrices may 
be saved to a file in ASCII format which can subsequently be opened in Excel™ (see Apply 
Transformation for details).
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The plot above displays the mean pixel value for each of 210 bands.  
The list shows the mean, minimum and maximum value for each 
band.  Band 31 is selected in the list and the corresponding position 
within the plot is indicated by the blue vertical line

The pixel histogram for any of the 210 bands is displayed by select-
ing that option (Hist...) within the radio buttons and clicking on a 
list item which shows the mean, mode and median for that band.
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Histograms
 A histogram of the distribution of the pixel 
values for any single or multiband image can 
be generated for the front window by select-
ing menu Functions -> Plots -> Histogram or 
Functions -> Plots -> Histogram (Masked).  
The later is descibed on the following page.  If 
a selection rectangle is present the histogram is 
confined to those pixels within the rectangle.  If 
the band list for a multiband image has any bands 
disabled then those bands are ignored in comput-
ing the histogram.  If the window is a cube then you will be presented with the dialog shown 
below allowing you to choose either a specific band in memory or the file data.  Also, see 
section Pixel Exclusion which describes excluding certain pixel values.
 A true color image produces three separate histograms:, one for each of the three color 
components: red, green and blue.   If the window is a color map overlay then the output is a 
list of the frequency count of the classes (see section Image Products).
 The histogram  of the underlying data as well as the remapped display gray values are 
generated.  To view a text summary with a cumulative distribution plot of the statistics, 
toggle Detailed Messages in menu Edit -> Options before histogramming.

The underlying data histogram of 
just band 60 with a cumulative 
distribution overlay.

The total file histogram of all 
160 enabled bands.Cube source selection dialog.

The display remapped gray shade 
histogram of band 60 also show-
ing a cumulative distribution.

This summary window 
is displayed if Edit 
-> Options -> Detailed 
Messages is toggled on.
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 Menu Functions -> Plots -> Histogram (Masked) also generates a histogram but uses 
an intermediary image mask that defines the region(s) of pixels to include.  The mask image 
must be the same spatial size as the target image, i.e., same number of pixels and lines, depth 
doesnʼt matter.  Class map masks generate a histogram for each class. 

A four class overlay mask (paritally shown) 
generated by a vector angle classification and 
used to generate the four histograms (see section 
Classify for a description of overlays and section 
Specific Algorithms for creating masks).

A dialog allowing the choice between 
3 types of mask images.

The resulting mask selection dialog for 
choice number 3 shown at left.

Image cube class 1 statistics.

Image cube class 2 statistics.

Image cube class 4 statistics.Image cube class 3 statistics.
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Pixel Exclusion
 For display purposes and to yield better histogram 
plots you can select a value or range of values to be 
ignored (excluded from computation) when generat-
ing certain statistics.  This option permits image pixels 
to be better mapped for display or to see details in a 
histogram that would be overshadowed by a too popu-
lous bin (e.g. a lot of zeros).  All dialogs that contain a 
Remap checkbox obey the current global Pixel Ex-
clusion definitions.  Menu Applications -> Shaded 
Relief  also does not use excluded pixels in comput-
ing estimates for its initial x and y slope scaling but 
does use all pixels in generating the output image (see 
section Applications).  Excluded values do not affect 
analytical operations such as Principal Components, 
Classifications and Image Arithmetic, only what is 
displayed.
 The following dialog is presented by selecting menu Edit -> Options -> Pixel Exclu-
sion.  Enabled exclusions are global, i.e., they are in effect for all images until they are 
disabled.

The dialog shown at right will cause all negative pixels 
to be excluded when generating Histograms and deter-
mining the display remapping necessary when loading 
an image cube.  This will also apply to the initial slope 
estimates in menu Applications -> Shaded Relief and 
to all dialogs containing a Remap checkbox.  It has no 
effect on menu Functions -> Statistics.
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Scatter Plot
 Choosing Scatter... from the Functions -> Plot submenu brings up the image selection 
dialog window shown below.  After selecting two 8 bit images, which may differ in size, a 
two dimensional scatter plot is generated with the origin, point [0,0], at the lower left.  A plot 
point is derived by using image oneʼs 8 bit pixel value as the y coordinate and image twoʼs 
pixel value as the x coordinate as the images are scanned in unison.  Therefore the output 
image will always be 256 by 256 and mostly black.  Each time there is a multiple hit, i.e. 
the inputs generate an x,y already plotted, the color (or gray value) for that point is modified 
from blue (black) towards red (white).  If both selections are the same image then the output 
image consists of a 45 degree broken line of colored dots from the lower left to the upper 
right.  After the output image is generated you may select other color tables from the menu 
string Image -> Convert Image -> Color Table to view different encoding schemes.
 By selecting the scatter plot and moving the cursor over it the corresponding pixels in the 
two input images will be overlaid with red dots.  To force their gray scale restoration choose 
the first color table (linear ramp) as described in the previous paragraph.

The initial coding 
method is determined by 
these check boxes and 
can be later modified 
by choosing a different 
color table.

All currently open 8 
bit gray windows, re-
gardless of size, are 
listed in the popup 
menus.

The red and green component images of a true color 
image were used to generate this scatter plot image.  
The red image pixels are the vertical coordinate and 
the green pixels the horizontal coordinate.  The red 
tulip flower tops form the cluster in the upper left.  As 
the cursor is moved over the plot the inverse trans-
formation shows which pixels in the source images 
contributed to this point.

Points in this region 
correspond to picture 
elements where red is 
the dominant color.

The diagonal band 
maps to values of 
similar intensity in 
the two images.Red Tulips component.

Green Tulips component.
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Line Profile Plot
 A linear plot of an image can be generated 
by first drawing a line and then selecting menu 
Function -> Plot -> Profile.  The line is speci-
fied by positioning the cursor on one endpoint, 
depressing the control key (previous versions 
used the shift key) and clicking and dragging the 
mouse to the other endpoint.  Upon releasing the mouse a marque-like line will remain.  Re-
peat the procedure to select a different line.  Control-click (control-double-click in the Win-
dows version) the mouse without moving it to clear the line or choose menu Edit -> Clear.
 If an image is color, including pseudo color, then three separate profile plots will be gen-
erated for the red, green and blue components respectively.  Plots are resizeable  and include 
the coordinates of the endpoints such that the left coordinate is the start and the right coordi-
nate the ending point. Overviews show properly scaled coordinates.   Vertical coordinates are 
expressed as either gray values ([0,255]) or in data values ranging from the minimum to the 
maximum data within the profile line (see section Plot Scaling/Selection).
 The profile window is an independent window that can be printed or copied to the clip-
board, and saved.  To save a profile as an image activate its window and select menu Edit 
-> Duplicate.  Then save the duplicate as a normal image.  The actual profile values can be 
saved as a text file via menu File -> Save.  The file will consist of 1024 lines of x,y,z triplets 
regardless of the length of the profile line.  Only the x and y are interpolated, each  z value 
is exact.  The x,y,z triplets are also copied to the clipboard when performing Edit -> Copy.  
Moving the cursor over a profile plot line will display the corresponding image x,y,z values 
in the Info window if itʼs enabled (see section Info Window).

A profile line drawn over band 60 of a 
hyperspectral cube with 16 bit pixels.  The plots 
at right show the actual data vs the remapped 
display values.

Same profile values of the 8 bit 
display window.

Profile values of the underlying data.
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Image Arithmetic
 HyperCube allows you to enter general “C” type arithmetic expres-
sions where the operands are images and constants.  The result is an image 
whose size equals the minimum spatial size and maximum pixel depth of 
the individual image operands.  Since the arithmetic generally produces 
values outside of [0,255] you can specify how to remap the resultant 
display image.  All arithmetic is performed to floating point precision and 
remains attached to the resultant image.  If an expression contains a color 
image the output will be a color image limited to the display depth of 8 
bits per color without the attached floating point values (see examples).
 Menu Functions -> Arithmetic... opens the dialog window shown 
below.  The scrollable area contains a list of all of the current images that 
you can use to form an expression and is in order of creation.  Each image name is preceded 
by the letter “s” and a number.  These become the symbols used to form the expression 
instead of using the explicit image name.  The expression itself will be used as the resultant 
image name and it too will be added to the image list.  The expression is typed into the upper 
edit box and must conform to the “C” syntax.  Listed below and on the next page are the op-
erators and functions recognized by HyperCube where s1 and s2 may be images or constants.  
The result is always an image of the minimum spatial size of the image operands with possi-
bly underlying floating point attached data.

  ( , )   left and right parenthesis   ==  equality
  +, -, *, /  arithmetic operators    !=  inequality
  %   modulo       >=  greater than or equal
  &,|   bit-wise and, or     <=  less than or equal
  ^   bit-wise exclusive or    >  greater than
  <<,>>  bit-wise shift left, right   <  less than
  +,-   unary signs      pi  constant (3.14159...)

 fabs(s1), sqrt(s1), pow(s1,s2), exp(s1), log(s1), log10(s1)
 sin(s1), cos(s1), tan(s1), asin(s1), acos(s1), atan(s1), atan2(s1,s2)

The Image Arithmetic dialog window displaying a list 
of images that you can use as operands in an expres-
sion.  The example shown at the right generates an 
image mask of 0 and 255 representing the areas that 
have an x and y slope magnitude greater than 1.
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 Additionally, the following non-C functions are available where n is a constant.  As is the 
case with the C type functions each result is an image (see hist() for additional outputs).

 shift_left(s1,n)  Shift image s1 a distance of n pixels (n may be fractional)
 shift_right(s1,n)  in the specified direction.
 shift_up(s1,n)
 shift_down(s1,n)

 slopex(s1,n)   Generate the slope of image s1 over a distance of n pixels,
 slopey(s1,n)   in the x, y or combined xy direction (n may be fractional).
 slopexy(s1,n)

 int(s1)     Generate an image of the non fractional values of image s1.

 min(s1)     These 6 functions create an image with constant values
 max(s1)     equal to the specified statistic of image s1.
 mean(s1)     
 mode(s1)     
 median(s1)    
 sd(s1)     Standard deviation of s1.

 red(s1)     Extract the red, green or blue plane of a true color image.
 green(s1)    If s1 is gray then the function output is s1.
 blue(s1)
  
 hue(s1)     Extract the hue, saturation or intensity plane of 
 saturation(s1)   a true color image.  If s1 is gray then the output is s1.
 intensity(s1)
 
 gray(s1)     If s1 is true color then return a gray image weighted as
        .30*red + .59*green + .11*blue (NTSC conversion).
        If s1 is gray then use the imageʼs display gray values
        and ignore any attached data.

 rgb(s1,s2,s3)   Form a true color image from 3 arguments where s1, s2
        and s3 represent red, green and blue respectively.
        Equivalent to Image -> Convert -> R,G,B to Color.

 hsi(s1,s2,s3)   Form a true color image from 3 arguments where s1, s2
        and s3 represent hue, saturation and intensity respectively.
        Equivalent to Image -> Convert -> H,S,I to Color.
 
 conv(s1,s2)    Perform the convolution of s1 and s2 (frequency domain).
 corr(s1,s2)    Perform the cross correlation of s1 and s2.

 ps(s10)     Generate the frequency power spectrum of s1.
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 class(s1,n)    Extract, as a color mask image, the nʼth class from class map
        image s1.
  
 band(s1,n)    Retrieve the nʼth band from cube image file s1,
        i.e., access the cube file itself.

 band_sum(s1,n1,n2) Form the simple summation of bands n1 through n2 from
        cube file s1.  Ignore disabled bands.

 hist(s1)     Produce, as a separate output,the histogram(s) of s1.
        Also, outputs s1.

 hist_masked(s1,s2) Similar to hist() but uses image s2 as a [0,!0] mask
        to define the areas of s1 to use in the histogram.

 save_file(s1)   Save image s1 as a TIFF file.  If s1 is a cube
        file (not a specific band) save its corresponding window.

 The following 5 functions compute and use the discrete wavelet transform (dwt or its 
inverse) of argument s1.  If the spatial size of s1 is not a power of 2 then it is automatically 
zero filled to the next power of 2 size (also making a square image) and the transform taken.  
Arg n1 is the number of Haar or Daubechies coefficients to use, either 2 (Haar), or 4, 6, 12, 
20 (Daubechies).  Argument n2 is the multiresolution analysis level and may range from 1 
to log2 of the image size (e.g., 9 for 512 by 512).  A special case of n2 = 0  generates the 
maxmimum level.  Because of the power of 2 requirement, functions dwt() and dwt_inv() 
should first be used by themselves and the resulting power of 2 size wavelet or inverse then 
used freely in subsequent expressions.  The remaining 3 functions can be used directly within 
any expression since their image argument, s1, is zero filled as necessary, processed and 
extracted back to original size.

 dwt(s1,n1,n2)   Compute the forward discrete wavelet transform (dwt) of s1.

 dwt_inv(s1,n1,n2)  Compute the inverse discrete wavelet transform.

 dwt_low(s1,n1,n2,n3)  Compute the forward dwt of image s1.  Keep all transform
        values with magnitude < n3, zero the rest and perform the
        inverse transform to produce a filtered image.
 
 dwt_high(s1,n1,n2,n3) As above, keep values with magnitude >= n3, zero the rest.

 dwt_energy(s1,n1,n2,n3) Compute the forward dwt of image s1.  Rearrange the dwt
        in decreasing energy order.  Normalize and form summation
        until energy sum >= n3 where arg n3 is a percentile [0,100]
        of the total dwt energy.  Zero transform terms less than last
        energy addition and invert to form an image.
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 The relational operators (e.g., <,>,==) produce a mask image consisting of 1ʼs where the 
pixel by pixel relation is true and 0ʼs where it is false.  For example: the expression s1==s2 
creates a mask with 1 for each pixel of s1 and s2 being equal and zero otherwise.  The 
expression: (s1==s2)*s1 shows those pixels of s1 that match s2, whereas (s1!=s2)*s2 
shows those pixels of s2 that differ from s1.  And the expression: ((red(s3)>=green(s3)
)&(red(s3)>=blue(s3)))*s3 displays all areas of the true color image s3 in which the red 
intensity is greater than or equal to both the green and blue intensities; black elsewhere.  See 
more examples later.
 In addition, a new constant type operand is available that consists of a triplet set of num-
bers represented as {n1,n2,n3}.  When used in an expression such as s1*{.95,1.3,.6} the 
red component of s1 is multiplied by .95, the green component by 1.3 and the blue compo-
nent by .6.  You can use the triplet constant anywhere that a single constant is valid.  It will 
force the pixel depth to true color.
 All image operands are converted to floating point before arithmetic is performed.  The 
result of the expression must then be converted back to 8 bits/plane to display an image (the 
underlying data remains the results of the expression and is left attached to the image).
 The Image Arithmetic Options... button allows you to determine how the display pixels 
generated by the expression are remapped back to the [0,255] range.  If the Remap check 
box is unchecked then the expression is truncated (but 
not the underlying data) such that values above 255 
are set to 255 and values less than 0 are set to 0.  This 
is useful when the expression only contains bit-wise 
operators.  Generally, expressions produce pixels well 
out-of-range.  In this case select the Remap check 
box and choose the min & max radio button, then the 
expression range [min,max] will be linearly remapped 
to [0,255].  For expressions that produce a wide non 
uniform range of values choose the median radio but-
ton.  Then, the value of the expression is remapped so 
that values in the range [median - %/2, median + %/2] 
are linearly transformed to [0,255].  Values outside of 
this range are set to 0 and 255 respectively.  The Do 
each color separately checkbox specifies whether one 
set of statistics is applied globally for all three colors or 
whether three sets of statistics are separately used to remap each color independently of the 
others.  Set divide... defines the result of any zero divisors that may occur (almost a certain 
consequence of using the divide operator).  The 3 possibilities set the resultant pixel to zero, 
one or 255.
 Expressions are evaluated from left to right unless parentheses force the order of execu-
tion.  An expression can consist only of constants in which case the output image is a uni-
form color.  All 8 bit  pseudo color images are converted to their respective true color values 
during computation.  The result remains true color, it is not reconverted to pseudo color.  Any 
expression containing only gray results in a gray output image at full precision.  Any expres-
sion containing color produces a color output image at 8 bits per color.
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 The Arithmetic Options dialog allows you to generate a sequence of outputs that are 
assembled into a “synthetic” cube where each plane is the result of one evaluation of the 
sequence.  To use this option check Generate a sequence, and enter the number of ouputs 
and range that will be linearly substituted for the variable ʻt  ̓in the expresion.  For example: 
the arithmetic expression slopex(s1,t) with the options shown will generate a cube consist-
ing of 10 planes where each plane is the slope in the x direction over an interval of ʻt  ̓pix-
els, i.e., 1,2,3,...,10.  The variable ʻt  ̓is not limited to integer values and may be substituted 
anywhere in the expression that the substituion produces correct syntax.  Another example: 
((s4>=mean(s4)-t*sd(s4))&(s4<=mean(s4)+t*sd(s4)))*s4 sequentially displays the 
values of image s4 lying within the expanding interval [mean-t*sd,mean+t*sd] with ʻt  ̓set to 
range from 0 to 3.
 The Save File Name button is used to designate base name for the save_file() func-
tion.  Each file name will be the ʻbase name  ̓concatenated with a 3 digit sequence number.

Band 60 (s1) of HYDICE image cube 
(available at www.tec.army.mil/Hy-
percube/index.html).

An 8 class map (s2) generated via K-means 
using the class mean as the class color.  See 
section Spectral Classifications.

The result of combining the above left gray shade 
image, s1,  and the above right color class map, s2, 
using the arithmetic expresion:
hsi(hue(s2), saturation(s2), gray(s1)) with Remap 
disabled in Image Arithmetic Options. 
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Examples:  
 where: s1 is a data image; s2,s3,s4 are bands of a cube and s5 is the shaded relief of s1

((s1>1000)&(s1<1200))*s1 Keep s1 values between 1000 and 1200, zero rest.

log(s1)       Should also choose a remapping option.

atan2((s2-s3),(s2-s4))  Also try various remappings.

shift_left(s1,3)   Shift the s1 image 3 pixels to the left with wraparound.

shift_up(s1,.5)   Shift the s1 image up .5 lines (fractional shifts are allowed).

slopex(s1,2)    Generate the slope of image s1 over an interval of plus and
        minus 2 pixels in the x direction.

gray(s5)      Use the display gray values of s5 instead of any attached data.

(s1>1200)*{32,0,0}+gray(s5) Generate a red tint image of s5 greater than 1200.

(fabs(slopex(s1,1))>1&fabs(slopey(s1,1))>1)*255   A mask of areas with x and y
                slope magnitude greater than 1.

hist_masked(s2,s2==s3) Generate a hist of s2 wherever pixels s2 and s3 are equal.

A data source image. Corresponding shaded relief 
generated via menu Appli-
cations->Shaded Relief.

The mask image resulting 
from the last expression in 
the examples.

This image of the above source image is the result of apply-
ing the the following arithmetic expression: 
(slopex(s1,1) > 0)*{255,0,0} + 
(slopex(s1,1) < 0)*{0,0,255} + 
(slopex(s1,1) == 0)*{0,255,0}
so that positive x slopes are colored red, negative x slopes 
blue and zero x slopes green.  Expressions may be copied 
and pasted to and from a text window (File->New) and then 
saved.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 62

More examples:
 where s1 is a gray or true color image or cube file band.

dwt(s1,4,0) Compute the discrete wavelet transform of image s1 using Daubechies 4
    coefficients to level 8 (arg n2 = 0 implies the maximum level).
    The resulting transform image is always a power of 2 in size.

Source 256 by 256 by 8 bit 
gray image.

The 8 level dwt  using 4 
Daubechies coefficients.

A profile line displayed over the origi-
nal image along with its plot below.

The resulting filtered image with the same 
profile line and plot shown below.

dwt_energy(s1,20,0,99.8) Compute the 8 level dwt of image s1 using 20
         coefficients and keep 99.8% of the energy of the
          ransform.  Zero the terms representing the remaining
         .2% and invert the tranform to form a filtered image.
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Overlaying Images
 A special image function is provided to allow overlaying one im-
age on top of another.  This could be accomplished by splitting the 
images into red, green and blues planes followed by various logical 
operators previously described in Image Arithmetic and then re-
combining the resulting planes.  The Functions -> Overlay Color...  
menu makes this much easier: you select the two images and the pro-
gram will construct a third true color image that is the result of over-
laying image 1 upon image 2.  The first image is the mask or top and 
the second image is the base or bottom.  Every black pixel in the mask 
becomes clear when placed upon the base thus allowing the base image 
to show through at that pixel.  Every non-black pixel in the mask over-
writes the base image.  The spatial sizes and pixel depths of the source 
images do not have to be the same, the output image will be the size of 
the overlap and true color.  Psuedo color and gray scale are automati-
cally accounted for.  Note that the mask criteria is based upon color, in 

this case black, and not on a zero index if the mask happens to be a pseudo color image.
 Choosing Overlay Color... from the Functions menu brings up the following dialog:

Image 1 (mask) Image 2 (base) Color Overlay
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Adjacency
 This image function can be used to delineate where two or more 
pixels (classes) have the same value within a selected spatial neigh-
borhood.  Four variations are available: the first, Images, cross 
compares the pixels in two different images, the second, Colors, 
uses a single image in the comparison and the third and fourth, 
Classes and Singularities, pertain to spectral classifications.  The 
idea is the same for all: generate an output image consisting of a 
combination of input image pixels that match some criteria any-
where within a specified radial distance of each other.  The neigh-
borhood can range from zero to some arbitrary radius.
 Menu Functions -> Adjacency -> Images is a generalization of equality.  Given two 
images it sequentially compares a pixel of the first image with the neighborhood surround-
ing the similarly located pixel in the second image.  For example, a radial neighborhood of 
1 is interpreted as comparing the source pixel with any of the 4 adjacent pixels in the second 
image (a radius of 1 is not large enough to include the diagonal neighbors).  If Coincidence 
is checked (see below) then the central pixel is also included.  A radius of 2 increases the 
valid comparison region to 12 or 13 pixels depending upon Coincidence.  Fractional radii 
are allowed, e.g. a radius of 1.42 would include 8 or 9 pixels.  If the radius is set to zero then 
the function reduces to equality.  The output pixel  can be set to just the source pixel, just 
the matching neighborhood pixels or, both as selected by the three radio buttons.  The image 
examples below demonstrate how two spectral classification output masks are combined to 
produce a new mask in which the algorithms agree with each other allowing a spatial un-
certainty of 1 pixel, e.g. where Vector Angle and Correlation Coefficient matched exactly 
(Coincidence set) and within 1 pixel of each other.

The two source spectral 
classification outputs 
used as input to the Ad-
jacency function produc-
ing the output shown at 
the lower right.

Dialog is set to produce 
an exact match as well a 
spatial mismatch of a one 
pixel radius.
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 Menu Functions -> Adjacency -> Colors  operates on the front image window and is 
used to extract pixels with two specific colors that are co-located within a selected radius.  
This operation could be done by first separating the source image into two masks of the 
given colors (see section Image to Mask) and then using Adjacency -> Images as above 
but  Functions -> Adjacency -> Colors greatly simplifies this.  The image example below 
shows how a multiple spectral classification output can be transformed into an output show-
ing the outline of everywhere one class is exactly adjacent to another class, e.g. grass and tree 
canopy demarcation.  Again, the selected radius allows a considerable latitude in the equality 
range.  The two colors to be compared are best chosen by first positioning the cursor over 
the source image and using the special command-option-C combination described in section 
Copy, Paste & Duplicate.  The colors will then automatically be filled in when Functions 
-> Adjacency  -> Colors is selected.  Note that checking Coincidence has an effect only 
when the two selected colors are identical in which case the resultant image will consist only 
of that extracted color (see section Image to Mask to accomplish the same thing).

The dialog above was used on image Six Class Map to extract tree [43,96,43] regions 
that are adjacent within a 2 pixel radius to grass [195,255,195].  The output consists 
of only the grass border.
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 The third variation, Functions -> Adjacency -> Classes, is only available when the 
front most image is a classification overlay produced via the Classify function.  This type 
of image displays the member class as the cursor is moved over it.  The intent is to extract 
all of the areas within the overlay that have a common adjacency but instead of specifying 
colors you specify how many of the class members must be present within a certain radius.  
If you select less than the actual number of classes that the overlay possesses then this subset 
could and would change throughout the image.  This permits generating a spectral classifi-
cation using similar signatures from a library (again using Classify) and then entering how 
many of these signatures are needed (found) within a certain radius to reduce the ambiguity 
of false “hits”.  The output may be an image or a mask depending upon the Clear image 
background checkbox.  The image appears where the criteria fails and some combination of 
the class member colors where it succeeds.  If a mask then black appears where the criteria 
fails.  The mask can be overlaid on the original classification source using menu Functions 
-> Overlay Color.
 The following user dialog and examples illustrate how you can increase the accuracy of a 
spectral library classification.

Class map image Four Class Map consists 
of 4 classes.  All four classes are used and 
searched within a 2 pixel radius to generate 
the output mask image shown below right.

This classification overlay image was 
generated by using 4 signatures from a 
spectral library, each depicting some 
characteristic of a vehicle.

After applying Adjacency -> 
Classes to the left hand image.

Vehicles
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 The fourth variation, Functions -> Adjacency -> Singularities, is also only available 
when the front image is a classification overlay produced via the Classify function.  This 
type of image displays the member class as the cursor is moved over it.  The idea here is to 
scan the image for all occurrences of a single class map color (feature) that is surrounded by 
a different feature or features within a specified pixel radius.  Wherever this happens the sin-
gularity is replaced by the surrounding feature with the greatest abundance within the radius.  
If the single class feature is surrounded by imagery (gray) then no replacement is performed.  
The final output of this function is an almost identical class map with single pixel “noise” re-
placed by surrounding features.  Since this modifies what the Classify function thought was 
correct you must carefully inspect the new class map to determine the validity of this opera-
tion.  The best use of this function is to de-clutter class map images before converting them 
from raster  to vector form (See section Class Map Editor). 
 Below are the user dialog and an example of applying this function.

A three times magnification of a portion of 
a six class map as output from the Classify 
function.  There are 169 singularities within 
this subset.

The same subset after removing each oc-
currence of a single class surrounded by 
different classes.

As the radius increases, the probability 
of finding a singularity greatly decreases.  
With a radius of 1, only the top, bottom, 
left and right pixels need to be different.
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Fourier Operations
 Frequency domain filtering is initiated by selecting the menu Functions -> Fourier.  The 
dialog presented allows you to interactively change various filter parameters and apply them 
to an image.  The filterʼs characteristic curve is shown within the plot window as sliders are 
moved. The radii sliders represent the half magnitude point.  The attenuation slider deter-
mines how sharp the filter is.  All filtering uses the same scenario:  select part or all of an im-
age, click the FFT & PS button, select the filter type, move the sliders for the desired effect, 
and click the Inverse button to generate the filtered image.  Fourier is an operator like gray 
mapping, it is unique to the front image window when it was selected.  There can be several 
Fourier operators, each connected to its own image.  The transform is applied to the underly-
ing data represented by the window.
 An important visual key to interactive frequency domain filtering is the power spectrum 
(PS).  It displays the relative amplitude of the frequencies comprising the image.  The center 
of the power spectrum represents the lowest frequency with frequency increasing radially 
outward.  HyperCube shows the power spectrum as an image with the sliderʼs radii superim-
posed upon it.  As you move the sliders the radii change indicating which frequencies will be 
affected for the type of filtering chosen.
 Fourier contains five slider controlled filters and one user selection filter.  These are de-

Fourier dialog with High Boost filter 
chosen and applied to the transform 
of the image at the left.Source image selection rectangle em-

bedded in a 256x256 background.

Power spectrum of the embedded 
image using log compression

The resulting transformed image selection 
extracted from the embedded background.
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fined  as follows:

  Low Pass   Attenuate frequencies above Radius 1.  Use this slider and 
       the Attenuation slider for desired response.
  High Pass  Attenuate frequencies below Radius 1.  Also use Attenuation
       slider to shape response curve.  Because the average brightness
       is zeroed remapping (Options) must be chosen.
  Band Pass  Pass only those frequencies between Radii 1 & 2.  Radii sliders
       select pass band, Attenuation slider determines sharpness.
       Also requires remapping option.
  Band Stop  Attenuate frequencies between Radii 1 & 2.  The inverse of
       a pass band.
  High Boost  Similar to High Pass.  The boost varies from 1.1 to 9.9 and is  
       controlled by the second radii slider (label changes to Boost).
       Remapping should be used for data type images.
  Selection   Attenuate frequencies within a user selection rectangle. Manually
       draw a selection rectangle on the power spectrum image.

The image area to be filtered must be a power of two 
sized square.  HyperCube accomplishes this by automati-
cally embedding the source image or selection rectangle 
in the smallest power of two square image that will 
enclose it.  The border is set to the mean of the image 
(selection) to minimize ringing in the inverse transform.  
All operations then proceed using the embedded image.  
The result will be extracted as a separate image and may 
be optionally pasted back into the source image.  If the 
source is an 8 bit pseudo color image you will be directed to convert it to a true color copy 
using menu Image -> Convert Image -> Indexed to Color.  
 The Fourier Options dialog shown above presents additional controls.  The top check 
box determines whether the inverse image also overwrites the original image patch.  The 
second check box changes the filter characteristic from a tapered one to a vertical cutoff.  The 
Remap check box works exactly as that in the Image Arithmetic section and is a must for 
high pass and band pass filters which zero out the fundamental frequency (image average).  
This is also especially true for any images that represent data.  The PS Compression popup 
is used to present a better display of the power spectrum. 

Typical characteristic 
curves for Band Stop, 
left, and Band Pass, 
right, Fourier filtering.
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Mosaic
 Two or more images can be fitted together to form a composite assemblage.  The manner 
in which they are joined can be uncontrolled by selecting conjugate image points on each of 
the images or controlled by matching image points to a list of externally derived coordinates.  
The geometry used to force the joining ranges from a simple orthogonal transformation to 
a plane to plane projection.  However, the transform must be the same for all of the images.  
Mosaic is more general than Warp (described in the next section) in that the end result is to 
stitch images to a common geometry for a greater view whereas warpʼs objective is to match 
the geometry of one image to another.
 Choosing the Functions -> Mosaic menu, a dialog will appear with several scrollable 
list areas.  Only the Available Images list initially contains anything, namely all open 
images that are candidates for mosaicking.  Click on each Available Images list name to 
highlight it and click the Add -> button to move the image name to the Mosaic Images list.  
Double clicking an Available Images name will also move it directly.  The order of select-
ing images is not important.  To remove an image from the Mosaic Images list click its 
name and click the Remove button or double click its name, it will be returned to the Avail-
able Images list.  Removing an image after starting the control point selections will remove 
all control points.  You are warned of this and are allowed to cancel the removal.
 Once the mosaic list has been determined the program is ready to begin the control point 
selections.  Position the cursor over any image and shift-click the mouse, a colored numbered 
reticle will be left there.  Move to the conjugate position on another image and shift-click 
there.  This can be repeated until each image contains the same matching control point.   Sub-
sequent attempts are disabled until the New Image Cntrl Pt button is clicked.  This permits 
selections for the next control point number.  Each control point must appear on at least 2 im-
ages before going to the next control point.  New Image Cntrl Pt is automatically disabled 
until at least 2 images contain a given control point.  Each control point does not have to 
appear on each image, only on at least two.  As each control point is chosen it appears in the 
lower left scrollable list.  A point may be deleted my clicking on it and choosing the Delete 
Image Cntrl Pt button.  It will be deleted from each image it appears upon and the remaining 
points will be renumbered.  The number of control points determines the degree of trans-
formation (see section Warp) that will be allowed and specifically, the minimum number of 
control points appearing on two or more images.  Therefore if two images have only 2 con-
trol points in common then only the Orthogonal transformation will be available regardless 
of how many common points may appear on other images.

Unselected available 
images.  Data type 
images may also be 
mosaicked together.

List of images to 
form the mosaic.

Two control points and 
their coordinates that 
have been measured.

The image chosen to be 
the geometric control

Type of transform and 
interpolation.

External control has 
been added so that 
the mosaic can be 
fitted to these con-
trol points.

Edit box.
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 After all of the control points have been selected you can mosasic the images by clicking 
the Mosaic Images button or generate an outline showing how the images will be placed in 
the mosaic by clicking the Outline button.  This generates a colored line drawing image that 
can be overlaid on top of the final mosaic using Overlay Color... in the Functions menu.  
The Control Image popup is used to select which one of the mosaic list images defines the 
geometry that the remaining images are conformed to.  The control image shape stays the 
same and the other images are warped to its geometry using the selected Tranformation and 
type of Interpolation.  There are many options that determine how the mosaic is performed 
and the most important one is whether to fit the images to the control image geometry or to a 
set of externally defined control points.
 The previous description was based upon the control image geometry.  Any of the mosaic 
images may be chosen as the control and it will appear “stationary” in the output.  The big-
gest problem with mosaicking to a control image is the cascading of errors: e.g. Image 1 is 
the control and has points in common with image 2 which has points in common with image 
3 but image 1 and 3 have no (or not enough) points in common.  Then any errors between 1 
& 2 and between 2 & 3 cause very obvious misfits between overlap boundaries because the 
global least squares fit is to the control imageʼs geometry.  A way to minimize the effect of 
poor control points is to choose a good image as the control image and then only mosaic it 
and one other image together, then save the resultant mosaic and restart a new mosaic opera-
tion using the added image as the new control image (the current mosaic will generally have 
black areas that would overwrite if it were chosen as the control image).  This has the effect 
of breaking the geometric fit into regions (more degrees of freedom) and results in a more 
aesthetically pleasing final mosaic.
 The alternative method of mosaicking is to fit each image to an externally defined geome-
try where every image control point has a corresponding two dimensional coordinate such as 
X and Y or latitude and longitude.  The steps here are similar to the above.  First, you visually 
identify and select each image control point for which there is a known external coordinate.  
Then enter each external control point by typing the control point number followed by the 
two ordinates in the edit box and click the Add External Cntrl Pt button.  Repeat for each 
control point.  The input order doesnʼt matter, the point number determines the correspon-
dence.  A point can be deleted by clicking it (highlighting) and choosing the Delete External 
Cntrl Pt button or edited by clicking it, correcting it, and choosing the Edit External Cntrl 
Pt (Add External Cntrl Pt automatically changes to Edit... when a point is highlighted).  
The final step is to choose the Options... button and in the subsequent dialog to select the 
Use external control checkbox.  Note that by toggling this option a mosaic can be switched 
back and forth between image control and external control.  See the later sections for all of 
the subtleties available with the various options.

The result of mosaick-
ing the two images in the 
previous dialog to external 
control is shown on the 
left along with the outline 
generated for the same 
pair to the right.  Note 
each control point.
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 Listed below is a detailed description of each of the Mosaic window controls along with 
the possible options and their effect.

Add -> :  Move the selected image from the Available images list to the Mosaic images  
    list.  Double-clicking does the same.

Remove:  Move a selected Mosaic image back to the Available list.  Also may
    double-click.

New Image Cntrl Pt:  Used to step to the next control point, is disabled until the current
       point has been selected on at least two images.

Add External Cntrl Pt: After entering the external control point number and two ordinate
       values in the edit box this button will add the point to the
       external control list.  When an external control point is selected
       in the list this button changes to Edit External Cntrl Pt and the
       selected point appears in the edit box.

Delete External Cntrl Pt : Any external or image control point may be deleted by
        selecting it and clicking this button.  It toggles to
        Delete Image Cntrl Pt when an image control point is
        selected.

Control Image Popup: Selects which of the mosaic images will be the control geometry.
       If Use external control in the options dialog is selected this
       selection has no geometric significance.  In either case the control
       image will always be the top most image in the mosaic, i.e. it
       will overlay the others in common overlaps.  See Options.

Transform Popup:  The type of geometric transformation.  See section Warp.

Interpolation Popup:  What type of interpolation to use in the resampling. See Warp.

Outline:  Generates an output image the same size as the mosaic images but only
    shows the outlines of the individual mosaic images.  Becomes enabled when 
    a mosiac is possible.  Also see Options.

Load...:  Load a previously saved set of external coordinates.

Save...:  Save the current, if any, set of external control points as an ASCII file.

Options...: Bring up the Mosaic Options dialog.  See below.

Mosaic Images: Execute the mosaic operation.  If Use external control is set in the
     Options dialog then this button changes to Mosaic Extern.
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 Selecting the Options... button displays the following user dialog.

The external control points shown 
here were implicitly determined after 
the previously shown example was 
mosaicked.  Because Auto size was 
selected the limits were computed 
by the program so that they encom-
passed the entire mosaic.  If Use 
external limits is selected then the 
mosaic will be clipped to that exact 
area of X,Y min and max.

 Each option and its effect is listed below.

Average pixels...: Where the mosaic forms overlaps the control imageʼs pixel takes   
      precedence followed by the order of the Mosaic images list.  When  
      this option is checked all of the images within an overlap will be   
      averaged together to form the output pixel.

Display mini...:  When checked the Outline button will generate a miniature instead
      of a full scale line drawing.  The mini cannot be correctly overlaid
      with the Mosaic output.

Use external control: The mosaic will be constrained (warped) to the corresponding
       points in the external control point list in the Mosaic dialog.

Auto size...:   If selected then the limits of the external control point geometry will
      be determined by the limits of the final mosaic i.e. by computing the
      bounds of all of the corner coordinates of the individual mosaic
      images.  This is mutually exclusive with Use external limits... below.

User external...:  You may input the geometric bounds limits of the external
      control.  The mosaic will be confined in output size to these limits.
      Note, if Auto size is first selected and a mosaic performed then
      returning to the Options dialog will show the program computed
      limits that enclose the entire mosaic.  These can then be edited to
      customize the output after selecting Use external.
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Warp
 The geometry of one image can be empirically modified to fit the geometry of another 
image.  You can force two completely different types of imagery, such as optical and radar, 
into registration, combine them and thus produce a new product.  The registration points, the 
pixel resampling and the type of transformation used are all selectable.  Warp is the Hyper-
Cube function that accomplishes this.
 After choosing the Functions -> Warp menu, you select two images from the dialog 
popup list of images.  All single images, including 8 bit, true color and data are permissible.  
Using the mouse control points are selected alternately between the images as follows:  posi-
tion the cursor on control point 1 of image 1 and click the mouse while holding down the 
shift key, then position the cursor on the corresponding point 1 of image 2 and shift-click, 
repeat until all control points have been selected.  Each pair of points leaves a cross hair mark 
behind, usually red on image 1 and green on image 2.  The coordinate pairs are listed in the 
Warp dialog window where they can be edited or deleted.  Either image may be zoomed 
to help position the cursor.  The number of points needed depends upon the transformation, 
higher order requires more evenly distributed  points.
 The result of warping is a new image having the same size as the destination (->) im-
age and depth of the source image.  Depending on the transformation there may be pixels in 
the output image that have no correspondence in the source image, these will be set to Off 
image value.  Transformations are performed in a least squares fit manner to distribute the 
error across the control points.  The Residual button shows the mean error of the fit without 
producing an output image.
 Shown here is the Warp dialog after selecting 40 corresponding points between a color 
composite and a control band.

Direction of warp

Click in list to select, 
then edit or delete.

Execute warp

Select images

Directs the user

Eight types available

Pixel resampling

Edit field

Residuals and coefficients 
for the above example 
when the Residual button is 
clicked.

Warp an entire 
loaded cube image.

Or data value
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 The transformation selected has a great affect on the shape of the output image.  The non-
linear transforms are very sensitive to the number of control points and their positions.  Some 
of the transforms along with their arithmetic are defined as:

 Orthogonal: xs =  a*x + b*y + c  Affine:  xs =  a*x + b*y + c
     ys = -b*x + a*y + d     ys =  d*x + e*y + f

 Non-linear(s): xs =  a*x + b*y + c*x*x + d*y*y + e*x*y + f*x*x*x + g
      ys =  h*x + i*y + j*x*x + k*y*y + l*x*y + m*y*y*y + n

 Projective:  xs = (a*x + b*y + c)/(d*x + e*y + 1)
      ys = (f*x + g*y + h)/(d*x + e*y + 1)

 The orthogonal transform preserves shape, allowing only rotations and a single scale 
change.  Two points are required to define it.  The second, affine, is a linear transform that  
preserves parallel lines and is a generalization of orthogonal.  It will transform a square into 
a rotated parallelogram and is the most useful transform for registering two similar images.  
The nonlinear transforms include cross product and second degree terms and produce curved 
lines.  The examples below show how sensitive they are to a slight change in the control 
coordinates.  Affine requires 3 control points, non-linear(s): (4,4,6,8) and projective: (5).
 Three methods of pixel interpolation are possible: nearest neighbor, bilinear and cubic 
resampling.  Nearest neighbor is the fastest, it simply takes the closest source pixel and uses 
it as the output.  That is important if multiband imagery is warped and then used in a clas-
sification as no new intermediate “fringe” classes are created.  Bilinear interpolation uses 4 
surrounding pixels to form a positive weighted average.  Cubic also uses weights but some 
weights are negative.  This produces a slight sharpening in the output image and appears 
superior to bilinear for natural images but produces ringing in artificial images that contain 
discontinuous gray values.  For scale changes between .5 and 2 bilinear and cubic interpola-
tion are almost indistinguishable.
 The figures below demonstrate interpolation and transformation of 
the letter “E” warped to a duplicate of itself.  The control points were 
purposely chosen to be slightly different.  In the last figure a control point 
was edited to increase the mis-registration in order to show how great a 
change occurs in the nonlinear transformation.

Orthogonal, nearest neighbor. Orthogonal, bilinear. Affine, bilinear.

Nonlinear, bilin-
ear using original 
control points.

Nonlinear, 
bilinear after 
editing one 
control point.
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Plot Scaling/Selection
 When a plot is first generated the y axis limits are determined by the minimum and 
maximum of the functional values and the x axis values represent the range of the function.  
They remaine so until changed, even if the plot window is resized.  The vertical axis limits of 
certain plots can be explicitly changed by chosing menu Functions -> Plot -> Scaling and 
the x axis range can be changed by drawing a selection rectangle around the area of interest 
and choosing menu Image -> Magnify Plot (the magnification value selected is ignored).  
Shown belown is an example of these operations.

The dialog corresponding to the histogram shown 
on the left, below.  The rescaled histogram is shown 
on the right after changing Max y to 100,000.

Original histogram with the y axis 
limit set to the maximum functional 
value.  A selection rectangle has been 
drawn to select an x axis subset.

The resulting plot after changing 
Max y to 100,000.

The new plot displaying only values 
within the selection rectangle after 
choosing menu Image -> Magnify Plot.
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Multiband Functions

Band List
 Every multiband image has an associated band list that specifies the wavelength and 
status of each band.  This is necessary in order to correctly plot spectra and perform library 
searches and comparisons.  You can view/modify a band list by selecting menu Windows -> 
Show Band List .  A resizeable window with a scrollable list of 4 columns and several but-
tons will appear.  The columns display the band number, wavelength, band width and status 
for each band.  Except for band number, the items are editable by:  clicking them, typing a 
new value in the edit field and clicking the Edit button.  Double clicking the band number in 
the Mac version will automatically load that band as a single image not connected with its 
cube parent.  You must use Load Selection in the Windows version in order to load a spe-
cific band after highlighting it in the list.
 The band list is the window display of the *.wvl file described in the  Wavelength File 
section.  If a *.wvl (or older .wav) file exists when the multiband image was loaded then Hy-
perCube converts and loads its contents into the band list.  The *.wvl file may also be loaded 
via the Load wav... button.  By choosing the Options... button, the band list can be modi-
fied as desired and then saved as a new *.wvl file via the Save wav... button.  Also, it can be 
copied to the clipboard via menu File -> Save or Edit -> Copy.
 Band list window controls have the following definitions:

 List column: 1 Sequential band number, same as image cube band numbering.
      If the band wasnʼt loaded, i.e. only a subset of the full cube,
      an asterisk appears after that band number.  You can load any band
      as a stand-alone image by double clicking its band number.
     2 Band center wavelength in (usually nanometers or microns).
     3 Band width in same units of measure as wavelength.
     4 Status, if “disabled” (no check mark) then the band is ignored in
      spectral classifications, library searches and histograms. It will be
      highlighted in red on spectral plots.

Mac version band list showing the 
same selection area.

The Windows version has an explicit Load 
Selection button, instead of double clicking.
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Band List Options dialog. 

 

  Enable all  Set the status of all bands to enabled (check mark).  Toggle
      individually by clicking on Status (4) column entry.
  Disable all Set the status of all bands to “disabled”.  Also toggle
      individually as above.
  Revert   Restore the  band list to the last loaded wave length file.
  Options...  Display the Band List Options dialog.  Sets up various distributions
      of wavelengths that can be edited.  See details below.
  Save wav... Save band list as *.wvl file.
  Load wav... Display a standard open file dialog and load the *.wvl file.
  Save hdr... Save the current cube definitions in a *.hdr file.

 In combination with the Band List Revert button, Band List Options allows you to de-
fine a variety of enabled bands for experimentation.  There are 6 mutually exclusive options: 
the first 2 change the wavelengths, the third rescales (a convenient way to convert between 
nanometers and microns) and the last 3 enable or disable bands.  However, the 3 Enable/Dis-
able options will not enable any band that is currently disabled in the Band List.

Start & end is used to set a uniform 
sequence of wavelenghts.  Delta is 
computed.

Start & delta is similar to start & 
end with a user defined delta.

Only  those wavelengths within the in-
terval values defined in Image -> Cube 
Color Composite -> Definitions are 
enabled.

The complement of the  above option, 
i.e., the Color Comp Defs are disabled.

The last of the 3 Enable/Disable options:  
Only enable every n t̓h band that was already 
enabled, e.g., a value of 2 enables every 
other band currently enabled.

Multiply each wavelength and width by 
the scale entered below.  Band width and 
times delta change to Scale factor and 
times wave respectively when selected.
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Band Scrolling
 Every multiband image is loaded into HyperCube so that you can easily scroll through 
the bands in a movie like manner.  The band scroll bar (buttons in the Windows version) is 
at the top left of the image cube window and works like any other Mac scroll bar.  The cur-
rent band number and corresponding wavelength are annotated just above the scroll bar as 
the cube is scrolled.  If a specific bandʼs status is disabled then its annotation is shown in red 
else it is black.  A specific band can be given its own display window by scrolling the cube to 
that band and then choosing Duplicate from the Edit menu.  It becomes completely seper-
ate from the cube.  Any band, whether it was loaded with the cube or not, may be loaded by 
double-clicking a band number in the Band List (see section Band List).

Band scroll bar, number and wavelength.

All controls except for 
Band Scrolling operate 
in the same manner in 
both versions.

Windows version. Mac version.
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Flicker/Superimpose
 While band scrolling permits traversing an image cube in a contigu-
ous fashion sometimes itʼs desirable to jump from one band to another 
to compare differences.  HyperCube contains two functions that facili-
tate this.  The first is the menu Functions -> Flicker Cube and is en-
abled whenever  a multiband cube window is front most and the second 
method is menu Functions -> Flicker/Superimpose which is enabled whenever at least 
one image window is open.  Flicker Cube differs from Flicker/Superimpose in that it is 
specifically for the bands of an image cube and is adjustable, whereas Flicker/Superimpose 
is fixed to the two specific images (of any type) which drive it (see Flicker Image dialog 
below).
 Flicker Cube creates a new window similar to the cube window but with three scroll 
bars at the top which control the rate and the two bands to alternate.  Flicker Cube is an 
operator like graymap and if the cube window from which it is derived is closed then flicker 
disappears.  You can change the spatial offset between the two flickering images by using the 
keyboard arrow keys while the flicker is the active window.  Each keystroke moves image 1 
a single pixel in the arrow direction.   Enable menu Windows -> Show Info for a dynamic 
listing of the current x,y offsets and the alternation between the pixel value under the cursor 
(see section Info Window).  The flicker image can be printed and also copied. 
 The figure below is the flicker window generated from the previous band scrolling exam-
ple.  The flicker rate is nominal and some PCʼs  may not support the higher rates.  Alternation 
continues even if the flicker window is not the active window.

Flicker rate control expressed 
in changes per second.

Currently set to flicker be-
tween bands 60 and 69.
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 The second flicker type function, Flicker/Superimpose, is more general in that it per-
mits any two image windows (and selection rectangles within) to be alternated between or 
superimposed one on another as if viewing through a porthole.  The images are selected from 
two popup menus that appear when menu Functions -> Flicker/Superimpose... is selected.  
The images do not have to be the same size, the viewing window is sized to their minimum.  
The image depth, i.e. 8, 16 or 32 bits, also doesnʼt matter.  If one of the source images is 
modified such as by gray mapping or filtering then the change will be automatically reflected 
in the view window.  Similar to Flicker Cube, if either source image is closed or rotated 90 
degrees the view window will disappear.  The window title alternates between the source 
images when Flicker is chosen.  Also, the keyboard arrow keys can be used to spatially offset 
image 1 relative to image 2.  Enable menu Windows -> Show Info to view the current off-
sets (see section Info Window).
 Below is the dialog in which you select the two images and either Flicker or Superim-
pose.  If Flicker then the rate of alternation for flicker can be set.  If the resultant flicker is 
too fast or too slow close the flicker window and generate another one.  Superimpose places 
a rectangular window (or inset) of the first image upon a base consisting of the second image.  
This rectangle can be repositioned by clicking the mouse within it and dragging it anywhere 
within the window dynamically superimposing image 1 upon image 2.  To reverse the order-
ing, reselect Flicker/Superimpose and swap Image 1 and Image 2 names in the popup 
menus.  Superimpose is most useful when comparing an image band with a classification 
output image (see Products).

Image 1, Six_classes..., has been selected to su-
perimpose itself upon image 2, r49_g55_b18... 
The resultant window is shown at left in which the 
selection rectange can be dynamically moved about 
the window.

Flicker alternates between the 
two images whereas Superim-
pose displays a rectangular 
viewing port of image 1 upon 
image 2.
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Constructing/Modifying a Cube
 HyperCube can generate a new image cube from existing im-
ages of the same spatial size having various pixel types (e.g., byte, 
short, long, float for mono and byte (3) for color).  Any image is 
a candidate including bands of an existing image cube.  However, 
the new cube must be all of the same kind, either mono or color.  
The bands for the new cube may be already resident in memory or 
reside in a folder (see following page).  The in memory technique 
for construction involves two steps: selecting the first band which 
determines the spatial size and adding subsequent bands to the 
cube.  As new bands are added the pixel type of the cube automati-
cally changes to accommodate the maximum number of bits/pixel 
required.   HyperCube can also directly convert a true color image 
into a 3 band cube.  After  completing the construction save it via 
menu File -> Save As..., Multiband .

 1. Click on the first image component.  This will become the first band.
 2. Choose menu Image -> Convert Image -> Plane to Cube.
 3. Click on the second component.
 4. Choose menu Image -> Add to Cube... A dialog appears asking you where
  to insert the new band (see bottom right).
 5. Repeat steps 3 & 4 to complete the cube.  Menu Image -> Delete Band
  can be used to delete the current band face (i.e., first scroll to band to be deleted).
 6. Select menu Windows -> Show Band List and manually set up any
  wavelengths for each band (the default will be band numbers).
 7. Choose menu File -> Save As... and select Multiband to save the cube.

 If converting a color image, an additional dialog is presented asking whether to directly 
generate a 3 band cube (red, green, blue) or the first band of a 
synthethic color cube as shown in the dialog at the right.
 New bands may also be added to an existing image cube 
file by loading the entire cube.  A warning dialog similar to 
that shown at the lower left will appear when the first band 
is added stating that the cube will be disconnected from the 
existing file, becoming an all new cube that must be saved.  
After adding or deleting bands, choose menu Window -> Show Band List to edit the list 
and then File -> Save As..., Multiband (use a different name than the original cube file).
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 The second method to construct a cube is to have an existing set of TIFF image files 
within a folder.  These may have been created by a program such as MATLAB®.  Each file 
name must have the format: *.xxx, where * is a fixed base name and xxx is a zero padded 
value in the range [001,999], e.g., dr.001, dr.002, dr.003,... .  The numbers donʼt have to 
be consecutive, just increasingly ordered and may reside with other files.  The files are loaded 
and automatically constructed into a cube by choosing menu File -> Open As..., Bands and 
then selecting any one of the ordered files as shown by the Windows and Mac dialogs below.  
The first band will be the image file with the lowest number value in the folder.  Note: read-
ing a list of files (bands) like this is the inverse of selecting a cube image window and then 
menu File -> Save As..., Bands (see section Saving Images).
 You can scroll the cube bands and use menus Image -> Delete Band,  Edit -> Dupli-
cate and Image -> Add to Cube to modify it.  After constructing, choose menu Windows 
-> Show Band List and edit the band values as necessary before saving (File -> Save As..., 
Multiband).

Windows Open As..., Bands.

Mac OS X Open As..., Bands.
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Bands 49, 35 and 17 were automatically 
selected from the active image cube file to 
form a composite color image.  The histo-
gram highlight represents 98% of the data 
in these 3 bands. File values between 14 
and 223 will be remapped to the display 
range of [0,255] for each color.

Color Composite
 HyperCube provides a direct function to construct 
a true or false color image from a cube.  Menu Im-
age -> Cube Color Composite allows the user to 
automatically generate a color image for the currently 
active (front) image cube window and to link it to the cube for point selection and classifica-
tion (see sections Spectral Plots and Classify Functions) breaking any previously linked 
color image.  Two methods are provided via a submenu: Specific Wavelengths and Interval 
Wavelengths.  The former finds the three closest bands to the wavelengths set in the Defini-
tions... menu (see below) and the later integrates over three spectral intervals to generate the 
color components.  In each case the data is extracted from the image file.  Disabled bands 
(see section Band List) are ignored so it is possible to have a null interval and HyperCube 
will warn you if this occurs.  The resultant color image is correctly mapped so as to maintain 
the original brightness relationships, i.e. the red, green and blue are normalized as a group.  
 Choosing menu Image -> Cube Color 
Composite -> Definitions displays the 
dialog shown at the right.  If the image cube 
header file contains “color...” keywords 
(see section Keyword Format) then they 
appear in the dialog edit fields else the 
initial wavelength values for the Specific 
wavelengths red, green and blue component 
bands are 646, 545 and 460 nm (or µm) 
respectively.  These correspond to a set of 
Kodak® color separation filters and may 
be changed by editing the dialog fields.  Interval wavelengths values are similarly entered 
specifying the spectral range of integration to be used to form each color component.    Note, 
identical or overlapping values are allowed.  The Remap % determines the area about the 
median of the composite histogram that will be remapped to the [0,255] for each color.  A 
good starting point is 98%.  Use histogram equalization performs a nonlinear stretch of 
the components and is useful when the image cube has an asymmetrical histogram.  Changes 
may be incorporated in the image header file upon closing the dialog and selecting menu 
Window -> Show Band List, Save hdr... (see section Band List).
 If menu Edit -> Options -> Detailed Messages is checked then the composite histo-
gram of the three bands is generated.  This is similar to the histogram described in section 
Statistics except that it represents only the three bands or band intervals.  A typical compos-
ite histogram is shown below.
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Spectral Plots
 Two methods of plotting spectral vectors 
from an image cube are provided: statically via 
Functions -> Plots -> Spectra (Selected 
Points) or Functions -> Plots -> Spectra 
(Dynamic) as a function of the cursor position.  
The former, described here, allows up to 128 
points to be plotted along with  library signatures 
superimposed upon the same plot (see section 
Spectral Classifications).  The later allows the 
simultaneous display of the closest matching 
library signatures to the current cube vector (see Dynamic Displays and Plots in Spectral 
Classifications).
 Points are selected by positioning the cursor and clicking the mouse while holding down 
the shift key.  This draws a numbered colored cross hair on the cube face.  The Plot window 
need not be open when points are selected and if no plot points exist when a Plot window is 
opened it will contain a message indicating what to do.  If the wavelength file is incorrect no 
plotting is possible and the Plot window will contain a warning to that effect.  Having the 
Info window open while you select points facilitates the process by dynamically showing the 
spatial coordinates.  As points are selected they are graphed in the Plot window along with 
a color patch used for toggling them on and off.  The number of color patches that can be 
toggled is determined by the size of the Plot window, resizing the window (lower right grow 
icon) displays more patches.   All of the points can be erased at one time by choosing Clear 
from the Edit menu or selectively in the Classify dialog.  When the cursor is positioned over 
a static Plot window the spectral and reflectance coordinates will be listed in an opened Info 
window.
 The static Plot window contains several controls for customizing the plots:  three check 
boxes, a standard button and dynamic colored push-buttons that toggle on and off their 
matching color plots.  Cube bands that have been disabled in the wavelength file have a red 
highlight superimposed on them.  Controls have the following definitions:

 Scale:   Rescale the vertical plot axis between the minimum and maximum of
     all of the vectors.  Otherwise, the minimum and maximum will be set
     to the arithmetic range of the pixels.
 [0,1]:   Change the vertical axis labelling to the range [0,1] and map the plotted
     values to it.  Also see Scaling...  example below.
 Hide Bad:  If checked then suppress the plot wherever a band has been disabled.
     See section Band List.
 Clear Lib:  Remove any superimposed library signatures.
 

When a plot window is active 
Scaling may selected from the 
Plots submenu to produce a dia-
log window which will result in 
[0,1] changing to [0,1.5].
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A different image cube spectral plot after 
resizing to show all of the corresponding 
color patches.  Numbers 2 and 11 have been 
toggled off.  Because Hide Bad is checked, 
plots within the two major water absorption 
regions are not drawn (disabled in the Band 
List).  The correspondence between a point 
number and its color may be changed using 
the Color Selector item in the Options menu.

Four spectral plots from the 70 band 
image shown at the right.  Each number 
corresponds to the numbered cross hair 
in the image.  Several bands at 750 nm 
have been disabled in the wavelength file 
due to a sensor error.  These points may 
also be selected from a linked red, green, 
blue composite image constructed from 
cube bands (see section Components to 
Color).
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Selection Point Colors
 When HypeCube is launched the correspondence between a selection point number 
and its color is set from an internal default table that will be used when plotting spectral 
signatures and classifying (see Products in Spectral Classifications section).  The color 
sequence is arbitrarily repeated in groups of 10 with each group slightly different in value.  
Therefore, although points 1, 11, 21, 31, 41, 51 and 61... appear as the same red, they are 
not.  The point # to color correspondence can be customized at any time by choosing menu 
Edit -> Options -> Color Selector.  Up to 1024 colors may be uniquely redefined.  When a 
change is made all windows using selection point colors will be updated to reflect the change.  
Classify output products that have already been generated will not be changed (Overlays and 
Masks will use the new color on a subsequent classify).  However, products can be reas-
signed colors and labels after the fact by using menu Utilities -> Color to Name Editor (see 
Dynamic Displays and Plots).  A color that has been copied to the clipboard can be pasted 
as the selected color (see section Copy, Paste & Duplicate).  Also, see Classify -> Options 
-> More Options -> Use source spectra color in section More Options as an alternate 
method of specifying class map colors.
 

 To change a single color click on its patch to highlight it (a small frame is drawn around 
it) and adjust the three sliders for the desired color.  The top half of the palette shows the cur-
rent patch color while the bottom half of the palette changes to show the new color.

 <<  >>   These buttons are used to navigate through the 1024 colors moving
     fowards and backwards 32 colors at a time.
 Spec (N)  Generate a rainbow spectrum in the first N colors ranging from red
     through yellow, green, cyan and blue.  N is the currently toggled color
     patch.  If no patch is selected then N will equal 1024.
 Range (1:N) Generate a smooth range of colors between the colors in patches 1 and N.
     If no patch is toggled then 1024 colors will be generated.
 Set Patch  Change the patch color to the new palette color and update all windows.
 Default  Change the selected color patch to its original HyperCube launch color  
      and   update all windows.  If no patch is currently selected, a dialog
     appears asking you if all patches are to be set to their defaults.
 Save/Load... The current color key correspondence is saved/retrieved to/from an
     ASCII file.  The output is the  same format used in the Color to Name
     Editor, i.e., red, green and blue values followed by a name which in this
     case is the index number.  The default file extension is “c2n”.

Color patch #30 has been selected and the sliders 
adjusted to a new color.  The components of each color 
are shown to the right of the sliders and range from 0 
to 255.  You can not select a gray value (i.e. all three 
colors with the same value).  The Selector will auto-
matically modify the blue value to be different.

Current palette color.
New palette color.
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Spectral Libraries
Format
 The HyperCube program currently recognizes  a spectral signature format developed at 
TEC for the recording of field and laboratory spectra as well as a simple list of wavelength 
and value pairs.  One signature represents the spectra of a single material.  A set of signature 
files constitutes a library of materials.  The various signatures belonging to a library do not 
have to be related in any manner, they are often grouped together to correspond to a particu-
lar sensor run.
 The format of a TEC signature file is very straight forward: a small header followed by an 
ordered set of linearly spaced reflectances.  All of the elements are in ASCII text and can be 
easily edited in a word processor or spreadsheet application.  Almost any ASCII text file can 
be read, edited and resaved in HyperCube, including signature files (see section Loading/
Saving Text Files).
 A library is a text file whose elements are signature file names, i.e. a library contains 
no data except file names.  The library file and all of the signature files must be in the same 
folder.   A large (several hundred) library file can be initially generated by using the Finder 
to select and copy a group of signature file names from View by Name and then pasting the 
names into a document window of a word processor.  There is a Finder limit of the number 
that can be selected at one time and this may need to be repeated.
 The relationship between the library elements is depicted below:
 Each spectral signature, regardless of size, uses the following format:

A window of the folder consisting of 412 spectral 
signature files and the library file, Alibrary.lib.  
Portions of the library file and a signature file text 
are shown at the left and right respectively.

This spectral signature 
file contains a total of 
431 = (2500-350)/5+1
reflectance values.

Alibrary.lib file with an 
entry for each signature 
file name.

. . .. . .



HyperCube Pictorial Userʼs Guide  8/31/04 Page 89

  Line:  Parameter:        Example:
   1  File name        jun19atR.018
   2  Spectrum number      18
   3  Starting wavelength (nm)    350
   4  Ending wavelength (nm)    2500
   5  Wavelength increment (nm)   5
   6  Scan index number (hr)    0
   7  True solar time (hr)     0
   8  Solar azimuth (degrees)    0
   9  Solar azimuth (degrees)    0
   10  -- not used --       0
   11  First wavelength reflectance (%)  11.15
   12  Second wavelength reflectance (%) 11.05
   .  .
   N  N-10th wavelength reflectance  ##.##
   .  .
   438  428th wavelength reflectance   25.27
  439  429th wavelength reflectance   26.61
  440  430th wavelength reflectance   0
  441  431th wavelength reflectance   0

 For TEC format spectra HyperCube only needs the information in lines 3,4 and 5 plus 
the reflectance values.
 An alternate format of a spectral signature is simply a list of wavelength and value pairs.  
The wavelengths and values can be in any units as long as the wavelengths are increasing.  
Each pair should be space or tab separated followed by a carriage return.  HypeCube deter-
mines the format of a spectral signature by first trying to parse it as if it were in the TEC for-
mat.  If that fails it assumes it is wavelength, value pairs.  An example of the later is shown 
below.

These last two measurements 
are filler in this example.

Lines 3,4 and 5 implicitly 
determine the number of 
reflectances.

Wavelengths Values
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Plotting Signatures
 Viewing a spectral signature requires first opening a library by choosing Open As..., 
(Library) from the File menu.  This brings up the standard Mac file dialog showing only text 
type files.  Select the library file containing the signature names (Alibrary.lib in the examples 
so far) and click Open.  A new sizeable window containing a scrollable list of the signatures 
within the library will appear.  Click on any signature name, select Plot Selection and a sub-
sequent window, also resizeable, will open showing a list of reflectances with the correspond-
ing graphical plot.  The average of two or more signatures can be plotted by double-clicking 
the desired signatures, setting Average selections and then the Plot Selections button.  
Double-clicking an item toggles its checkmark on and off.

 Spectra plots have two check boxes that affect the appearance of the graph.  The Scale 
option toggles the vertical axis (reflection) of the plot range.  If unchecked the range is fixed 
to [0,1] else it is set to [min,max]  of the reflectances of the viewable graph.  The second 
check box, 10X, expands the horizontal axis 10 times centered upon the current spectral 
marker, if any.  Clicking within the graph area sets the marker and forces the list to scroll to 
the corresponding wavelength.  Conversely, clicking the list sets the marker within the graph.  
Spectral plots may be printed by choosing Print... from the File menu and a snapshot of the 
window can also be copied to the clipboard.  The list contents can be written to a file in the 
form of a library (see section Spectra Libraries) by selecting Save from the File menu or 
copied to the clipboard via Edit -> Copy.

The corresponding signature to the 
library list after clicking in the graph at 
the 1265 nm position.

Scroll to each signature of interest, 
click on it to highlight it, and then 
click the Plot button.

Double-clicking an 
item toggles it on 
so that an average 
of all items with a 
checkmark can be 
plotted.

Line 1 of the signature file.

Click within the graph to set the 
wavelength marker; the matching 
list element will be highlighted.

The previous spectra plot example 
repeated with both check boxes set. Click and drag icon to resize.
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Drag

Superimposing Signatures
 If HyperCube is running in system 7.5 or higher then the Macʼs “drag and drop” feature 
can be used to overlay signatures on a common spectral plot.  First open a multiband image 
and choose Functions -> Plot -> Spectra (Selected Points).  Then click the mouse in a 
signature plot and while holding down the mouse drag the rectangular outline, which will ap-
pear,  over the spectral plot graph and release the mouse.  The signature will then be plotted 
in black superimposed with any selected cube points and will have its own toggle button.  Up 
to 8 signatures can be “dropped” on the spectral plot window.  The signature will be re-sam-
pled to match the range of the multiband image.

Click and drag the outline of the Spectra graph 
over top of the Plot window and release.  The 
signature will be plotted at the same scale and 
resolution as the existing image cube vector 
plot as shown in the composite at left.  Note 
that a toggling button, L1, has been added to 
the plot for the dragged signature.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 92

Spectral Classifications
General Algorithms
 Spectral classification is the process of segmenting a multi or hyperspectral image into 
regions of similar spectral statistical characteristics or of finding the best match between pix-
els given a specific metric.  HyperCube is designed to perform both.  For example, Mahala-
nobis classify uses previously extracted statistical classes and decides which class, if any, a 
pixel belongs to, whereas Vector angle directly compares image pixel vectors with selected 
pixel vectors.  The criteria of a match is the closeness of the comparison.  This is a function 
of the algorithm used to define the closeness and HyperCube provides several from which to 
choose.  No one algorithm is always better than the others.  Some are very sensitive to noise, 
e.g., Mahalanobis distance, derivative difference, and others, e.g., Euclidean distance, are 
not.  The best technique is to experiment.
 Listed below are the algorithms from menu Functions -> Classify along with their arith-
metic definitions.  Summation extends over all enabled bands (see Band List).

 Abs diff    Σ abs(reference - signature).

 Corr coef    Covariance(reference,signature)/(sd(reference)*sd(signature)).

 Deriv diff    Σ abs(delta(reference) - delta(signature)).

 Euclid distance  Sqrt(Σ (reference - signature)2).

 Fourier    Compare corresponding harmonic terms.  See Options.

 Fourier (no DC)  Same as Fourier excluding the zero (average) harmonic.

 Fourier phase  Compare only the phase of corresponding harmonics.

 Fourier phase delta Compare the phase differences from harmonic to harmonic.

 Kmeans    Unsupervised classifier that segments an image into a user
       specified number of classes.

 Mahalanobis classify Statistical difference between each image vector and the mean  
        vectors of a set of covariance matrices.

 Mahalanobis distance Statistical distance beween reference points and image points.

 Mahalanobis list   A listing of the statistical difference between reference points
        and the mean of a set of covariance matrices.
  
 Matched filter abundance Generate a gray shade output image consisting
         of projections of the source data against a constructed  
         matched filter of a signature(s).

 Matched filter mask   Generate a mask over the image cube wherever the
         abundance exceeds a set tolerance (see description
         on next page).
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 Template    Max(abs(reference - signature)).  Useful for finding very
       similar signatures.

 Vector angle   N-dimensional angle between reference and signature.

 Closeness is defined differently for each of the algorithms.  Euclidean distance uses 
minimum as the criteria whereas the correlation coefficient approaches 1 for the best match.  
This is automatically taken into account by HyperCube but it is not possible to equate the nu-
meric values of one method with corresponding ones in another method because the distribu-
tion of each method is totally different.
 It is important to remember that a classification extends only upon bands whose status 
is Enabled in the Windows -> Show Band List and is spatially confined to any selection 
rectangle.  The Band List makes it easy to test the contribution of a given band by running a 
classification, enabling/disabling the band, and rerunning the classification to see the effect.  
Any statistics required by the algorithm will automatically be recomputed.

Specific Algorithms

 Matched filter abundance does not use a tolerance, instead it directly generates a data 
image where each pixel has a value approximately in the range ~[-2,2].  It is possible to have 
numbers greater than 1.0.  If the pixel used as the matched filter signature is also part of the 
classification region then it will have a value of exactly 1 at its position within the output im-
age.  The matched filter and abundance are defined as:

  matched filter = (cov)-1 (signature-m)/((signature-m)T (cov)-1 (signature-m))
  abundance = inner product of each data vector minus m and the matched filter.
  where:
    cov is the NxN covariance matrix of N bands of imagery
    m is the Nx1 mean data vector
    signature is the Nx1 pixel vector, N being the number of enabled bands.

When Matched filter is chosen as the classify Method the program must first compute the 
band to band covariance of the enabled file bands of the image cube or the corresponding 
subimage selection rectangle, if any.  The determination of the statistics region is via Clas-
sify -> Options -> Stats Region (see Mahalanobis description, next).  The computation is 
done once and the covariance matrix remains the same even if the current selection rectangle 
is moved or a different selection rectangle is drawn.  This allows the statistics for the covari-
ance to be generated for an image region other than the area chosen for the matched filter 
classification region.  To force a recomputation of the covariance choose Classify -> Op-
tions -> Redo stats. Also, changing the state of enabled/disabled bands in menu Windows 
-> Show Band List will cause a recomputation of the statistics on the next classify. 
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 Mahalanobis distance is a generalization of Euclidean distance that uses the statistics 
of the imagery.  Specifically, the Mahalanobis distance squared between 2 vectors, X and Y 
is defined as:

  D = (X - Y)T (cov)-1 (X - Y)
    where:
     D is the resulting scalar (i.e., 1xN times NxN times Nx1 matrices)
     X and Y are each pixel vectors of length N
     (cov)-1 is the inverse covariance matrix of N bands of imagery
     and N is the number of enabled bands.

In HyperCube, X and Y are defined by the various Mahalanobis classify methods as:

 Mahalanobis classify - X is each image pixel vector.
        Y is the mean pixel vector of the region used to generate
        a covariance matrix.  There can be one or more regions, each
        producing a mean vector and covariance matrix.  Classification
        involves computing the Mahalanobis value of an image vector
        for each region and choosing the region (class) with the
        smallest value within a user supplied tolerance.  Selection   
        points are not used.  Regions are defined by user selection
        of a mask image in Classify -> Options -> Stats Region.
        The statistics (covariance) are automatically generated by  
        HyperCube based upon the mask definition.

 Mahalanobis dist -  X is each image pixel vector.
        Y is one or more selection points.
        The image statistics are the same as defined for Mahalanobis
        Classify except that the mean vector is not used and only
        one statistical region is used.  This produces the statistical
        distance between one or more selection points and an image,
        not the distance between the statistical class mean and image.

 Mahalanobis list -  Same mathematics as Mahalanobis Classify except selection
        points are used and the output is a numerical listing
        showing each selection pointʼs distance from the mean vector  
        for each of one or more classes.

Six selection points and their Mahalanobis 
value for each of six statistical regions.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 95

 The image area used for computing the covariance matrix depends upon Classify -> Op-
tions -> Stats Region.  This displays the dialog shown below. There are 4 ways to define 

the regions.  The first type computes the covariance statistics using all of the pixels within 
the image cube or a portion of the image if a selection rectangle is present.  The remaining 
three methods use an image mask. The pixels used for generating the covariance statistics are 
determined by an intermediate image mask that spatially matches the image cube.  A simple 
way to generate a Class map image mask for the fourth method is by using the Classify 
function itself (e.g., select image points followed by method Vector angle).   Classify can 
also be used to generate a detailed zero non-zero mask by selecting image points, toggling 
neighborhood points and choosing Form Neighborhood Mask Image in the Classify dia-
log.
 Statistics are automatically computed when the Classify button is executed (section 
Classify Function) if there has been any change in the Classify -> Options -> Stats Re-
gion -> Select Image Mask selection.  They remain in effect so that a  different area on the  
image cube can be used for classification based upon the same statistics.  Also, any enable/
disable change in a band list (see section Band List) will cause a re-computation of the statis-
tics.  Button Classify -> Options -> Redo stats forces a re-computation and is useful if the 
selected image mask was generated as a class map sequence (see section Classify Options).  
Then the current sequence class map is taken as the sequence cube face and can be used as 
follows:  Select a new face, Redo stats, and then Classify to see the effect of a mask change 
within the sequence (saves having to repeatedly go to Classify -> Options -> Stats Region 
-> Select Image Mask each time the sequence face is changed).
 Some additional considerations: the convariance matrix is very sensitive to noise.  Noise, 
being defined here, is anything that is not representative of that class.  Even a single outlier, 
such as striping in the image, will skew the statistics and produce a non representative covari-
ance matrix.  If the imagery is noisy then try using fewer widely spaced bands (see section 
Band List).  If a two state mask image is selected or in use and Mahalanobis Classify or 
List is chosen as the Classify method then the outputs reduce to one statistical class.

Use every pixel within the image or selection rectangle.

Skip image pixels wherever the mask has a zero, use 
image pixels wherever mask is not zero.  Produces a 
single covariance statistics class.

Skip image pixels wherever the mask is gray (including 
zero) and use image pixels wherever mask is color.  Also 
produces a single covariance statistics class.

Mask must be a class map (section Image Products).  
Each color class produces a covariance statistical class.
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 K-means is an unsupervised classifier that does not use any selection points and requires 
minimal input.  The algorithm segments the image into n classes by initially guessing the 
mean vectors of the n classes.  It then scans the image and determines (using one of the four 
classification metrics listed below) which class each image vector belongs to and a cor-
responding set of new mean vectors.  This procedure is repeated until the number of image 
vectors that changed classes is below a certain minimum or a maximum number of iterations 
has occured.  The number of classes and both termination criteria as well as other parameters 
are user selectable.  Choosing Options in the Classify dialog while the classify Method 
is Kmeans displays the dialog shown below (note: the Options dialog associated with 
Kmeans is different from the options shown for the other classify algorithms).
 See section Image Arithmetic for an example of combining a K-means classification 
and the gray values of a specific band using the hsi() function.

The number of desired classes is limited to 500 
or less.  The actual number of classes generated 
may be less than the number requested.  Use 
menu Functions -> Plot -> Histogram on the 
classify output to list the classes.

A Progress window dynamically displays the 
iteration count and the number of class chang-
es.  When the number of iterations reaches this 
value Kmeans classify stops and outputs the 
results up to this point.

When the number of class changes is less than or 
equal to this value classify terminates.

Remaining options:

 Collect iterations: Each iteration (classify) is assembled into a class cube that can
       be scrolled to view the convergence sequence.

 Plot final class...  Each mean vector forms a spectral plot window.

 Save final class... The final class mean vectors are saved as a spectral library.

 Classification metric  The algorithm that is used to determine which class an image
        vector belongs to by comparing it the mean of each class.

 Use final class means as class colors:
    Natural - Determine mean class colors directly from mean vectors.
    Intensified - As above, but intensity the color.
          Red, green, blue wavelengths are determined by menu
          Image -> Cube Color Comp -> Definitions. 

Various metrics popup menu.
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Classify Function
 The HyperCube vehicle for spectral classifications is initiated by 
choosing the Functions -> Classify menu and is available whenever a 
cube or a linked color band composite window is front.  Each image cube 
can have at most one Classify window.   A classification scenario has 
three basic steps:  decide on the signature to be matched (what to look 
for), choose the search domain (where to look), and pick the method (how 
to look).  The output product is determined by the domains and numer-
ous options.  The simplest classification is to shift-click on a point in the 
image cube window, double-click on it in the Classify list, choose one or more neighborhood 
points  and generate an overlay image of the current Search Domain cube face band using 
Vector Angle as the Method.  This is the default setting of the Classify window and does 
not involve a library.  A Classify window is logically connected to its image cube and closes 
when the cube window closes.
 As you select cube points their coordinates are added to the Classify list.  These points 
are then used to reference one or more surrounding neighborhoods from which you can 
toggle one or more signatures to be averaged together.  The list coordinate is the central 
pixel in the neighborhood and has the same color as the cube selection point reticle but with 
a transparent interior.  It is also the same point that is graphed if a plot window is open (see 
Spectral Plots).  By clicking the mouse within the neighborhood, points may be added or 
removed from the signature mean.  Shift-clicking adds or removes a rectangular region be-
tween the shift-click and last non shift-click point. Any combination of neighborhood points 
is allowed.  If more than one pixel is toggled-on then their mean is formed.  Multiple neigh-
borhoods  are selected by  double-clicking each list point number.  Clicking the Plot Mean 
button produces a graph of the resulting signature and this graph may be superimposed upon 
an open spectral Plot window (see Superimposing Signatures).
 The neighborhood image is generated from the band currently shown on the Signature 
cube window and therefore will change as the cube is band scrolled.  However, if a linked 
color image has been constructed from cube bands (see sections Components to Color and 
Color Composite) then the neighborhood is extracted from the linked color composite.

All four list points have 
been selected as the 
neighborhoods in which 
additional points may 
be toggled-on to form a 
mean signature for each 
neighborhood.  Clicking 
once on point number 2 
highlights it and displays 
its neighborhood.

An 11 by 11 neighborhood 
surrounding the selected 
image cube coordinate.

The Search Domain 
does not have to be 
in the same cube as 
the Signature which 
is fixed to the selec-
tion point cube.
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 The following is a description of each Classify window control.

 Signature:  The signature source is always taken from the point selection cube and  
      its name is shown beneath Signature.  The only exception is when  
       Library is chosen (see below).
   File  Use a selected signature signature from the image cube.
   Library Use a selected signature from the current library as the signature.

 Search Domain: The popup menu beneath this title is used to select the cube in which
      to search.  The Search Domain does not have to have the same
      spatial or spectral dimensions as the Signature source.  A different
      cube is only permitted when Signature and Search Domain are
      both set to File.  Also see Library below for another exception.
   File  Match the selected signature against image cube signatures.
   Library Match the selected signature against all signatures in the library.

 Method:   Popup menu of available search algorithms.

 Library...   Open a standard file dialog to select the library to use.  The name
      of the library will replace Lib:(none) in the Classify window.

 Lib Key   Active after a library load.  Generates a window showing the
      correspondence between a toggled-on library item and the
      color that will be used in the classification.  See the later section on
      Products and earlier section Changing Selection Point Colors.

 Form Neighborhood Mask Image:  
      A separate gray image is generated spatially matching the current   
      selection area and having 255 gray values at each toggled selection  
      point and neighborhood with zero elsewhere.  See ROC Curves.

 Plot √    Generate a spectral signature plot of  toggled-on neighborhood points.  
      If Classify each √ point is checked then the plot will contain each  
      neighborhood and their mean. If  Classify mean of √ points is   
      checked then one mean of all the selected list points and their    
      neigborhood points is formed and plotted.  If Method is Fourier then  
      the plot is pre-filtered.

 Options...   Open the Classify Options window.

 Delete Pt #  Delete the highlighted selection point from the list and move lower
      points, if any, up.  Also affects any current plots.

 Load/Save Pts...  Save the current list of selection points including their
       neighborhood definitions.  Upon loading all points are
       automatically toggled on.
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 Save Sig... If Signature is set to File, then the currently toggled on selections 
     can be saved as a spectral signature of raw values, as a new library
     or added to the currently opened library.  The following dialog is
     presented.

 Classify mean of √ points
 Classify each √ point
    These form a pair of mutually exclusive radio buttons that determine how
    the toggled-on (√) points are used in the classification process.  The default
    is Classify each.  Then each √ point generates a classification region in
    competition with the others.  That is, cube pixels are compared with each   
    point and the closest point is defined as the proper classification.  The
    program requires that the classification criteria be set to Threshold in the
    Classify Options dialog.  If no point matches within the Threshold then
    that pixel remains unclassified (see the next sections, Options & Products).
    If Classify mean is chosen then all of the √ points are averaged together to
    form a single mean signature that will produce a singe classification region.
    Any classification criteria may be chosen in Classify Options.

    Note that if there is only one √ point then either of these choices will produce
    the same result if Threshold is the criteria.  Also, any √ point that has
    multiple neighborhood points selected will still form an average of that
    neighborhood to represent the signature of that √ point regardless of the   
    choice here.

    The color that is used to delineate classification regions is the same as each
    selection point color for Separate and the color of the first selection for
    Mean.  The colors can be changed using the Color Selector described in
    section Changing Selection Point Colors.

 Classify/ROC Curve:
    Perform either a classify or ROC curve.  This button toggles between these
    two as a function of the ROC curve checkbox in Classify Options dialog.
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Classify Options
 Pressing the Options... button in the Classify window opens the following window.

The output format is determined by these radio 
buttons and the checkboxes.

The number of signatures to list when 
Search Domain is a library.

Selected Method Parameters:
 This section shows the currently selected classification Method and allows you to change 
a specific parameter associated with that method.  Presently, only Deriv diff and the various 
Fourier methods have such a parameter and are described below.  The Theoretical best 
and worst tolerances refer to the mathematical closest and furthest difference between the 
signature and search domain vectors.  These are used to set thresholds and sequence limits 
and vary depending upon the alogorithm (Method).  For instance, Vector Angle and Fourier 
Phase range from 0 to π radians whereas Corr Coef ranges from 1 (best) to -1 (worst).  The 
various metric distances such as Abs Diff are normalized to the range [0,1] regardless of the 
arithmetic range of the search image cube.  Euclidean distance is normalized to the sqrt of 
the number of enabled bands.  The Methods which allow parameters are described below.

Deriv diff delta:  The sample distance from signature point to point used to compute the
      derivative.  Generally, signatures are quite noisy and using a delta
      greater than 1 provides a better indication of the true slope.
      However, if there are few or widely spaced bands some important
      signature variation may be skipped.

Fourier terms:  The low order number of Fourier transform harmonics to be used
      in comparing signatures in the frequency domain.  The greater the
      number of terms the finer the discrimination and sensitivity to noise.
      The smaller the number the greater the filtering and immunity to noise.
      A good starting point is 8 and this value must not exceed the number
      of enabled bands divided by 2.

Redo stats:   Available with classify methods Mahalanobis and Matched Filter.
Stats Region:  Used to define the region for generating needed covariance statistics.
      See description in section Algorithms.

Each classify Method has a theoretical math-
ematical range and is shown along with any 
parameter that must be set for that Method.

There are 4 ways to compare a signature within 
the search domain.  If Classify each is set then 
the criteria will be forced to Threshold.

If enabled then each spectral signature is fil-
tered based upon its energy distribution before 
being used in a classification or plot.
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Classification Match Criteria:
 The four mutually exclusive radio buttons in this area specify how the mathematical dif-
ference between the source signature spectra (vector) and the search domain spectra is used.  
The first one, Threshold, is the most direct.  It allows you to enter a tolerance in the range 
given by the Selected Method Parameters section just described.  Then, each computation 
is compared with this tolerance and if it is between it and best then the image cube pixel is 
defined to be classified as the source spectra, otherwise not.  If more than one point is being 
classified, i.e. Classify each, then the closest point to the best within the tolerance, if any, 
determines the classification.  

 Threshold: A value in the range: [best,worst] that serves as a breakpoint.
     Computations within [best,value] are classified, outside this range are not.
     Example: if the Method is Vector Angle then the tolerance range will be
     listed as 0 (best) and π (worst).  Setting the tolerance to .08 means that
     all vector angle differences between 0 and .08 will be considered to be   
     “classified”.  The color given to a classified region is the same as the   
     selection point color and may be changed via the Color Selector.
     Threshold is the only criteria possible if Classify each is selected.

 Percentage: Generate a color image using the selection point color to indicate the
     closest percentage of the entire distribution of the match.  For example,
     if the percentage is 10% then the upper (best) 10% matching pixels
     are defined as classified.

 Equal Distribution: Generate an N color output image where N is chosen by you.
       The entire match distribution relative to the source spectra  is   
       divided into N equal areas.  Each area then becomes a
       classification region.  Unlike the other criteria, the closest region  
       has the color of patch 1 in the Color Selector, the second closest
       region has the patch 2 color and so on.

 Countable: Generate an output image with the N closest matches delineated.
     For example: if N equals 50 then the 50 closest matches will define the
     classification region.  Good for showing very small targets.

Classification Output(s):
 This section defines the form and number of output products.  There are 2 types and both
produce an image.  Each generates the appropriate color classification regions for the Match 
Criteria listed above.  Their difference is how an unclassified region  appears.  The Color 
Mask leaves these areas black while the Color Image shows the current cube face band 
where there is no classification.  Both selections produce a true color image.  Note that the 
colored regions correspond exactly to the color currently defined for points in the Color 
Selector.  If the colors donʼt seem appropriate for the given classification change them in the 
Color Selector and redo the classification.  Also, see the color note above regarding Equal 
Distribution.  Flicker/Superimpose is very effective in dynamically comparing a classifica-
tion output with a source image (i.e. the linked Color Composite or an image cube band).
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 Color Mask:  The output image has a color where a classification is define as
      successful and black otherwise.  The only output possible if
      Equal Distribution is selected.

 Color Image:  A copy of the current cube face band will be used as a base image and  
      the classified regions will be overlaid.

 Generate Sequence: If checked then the 2 tolerance values entered below the 
      checkbox define a range of Match Criteria in which a sequence of
      classification images will be generated.  The number of outputs is user  
      selectable.  The outputs are arranged into a synthetic cube for display  
      (see Products).  The example below will generate a synthetic cube of  
      10 images where image 1 represents a classification tolerance of 0 and  
      image 10 a tolerance of .5 (in this case radians).

 ROC curve:  This option is available if Classify mean of √ points and
      Generate a sequence are both selected.  No image output is

      generated, instead a plot of the number of classify hits versus tolerance  
      is generated.  See ROC Curves section for details.
 ROC Mask...  Displays a popup menu dialog allowing you to select the
      “ground truth” mask image to be used in generating ROC curves.

Library Parameters:
 This last section is applicable only when the Search Domain is Library.  In this case the 
output is not an image but ordered sets of matching library signatures.

 Closest lib matches:  You can specify how many library signatures to list
        (see the Products section).

 Lib:File match lists:  Generates a list of the library elements found in the image
        and a list of the source library elements that didnʼt match.

 Ignore Disabled bands:  Available when Signature and Search Domain are both  
        set to Library.  In this case you may want to perform
        matching at every spectral band value by including any
        wavelengths that are disabled in the Band List.

 Enable Dynamic Display: Available when Signature is File and Search is Lib.
         As the cusor is passed over the Cube or Link image
         a real time display of the closest library matches is
         dynamically displayed.  If a dynamic spectral plot is 
         enabled, then the closest 2 library spectra will be plotted.
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Pre-Filter:
 Enable wavelet spectral denoising: If checked then each enabled cube file spectral
      signature is filtered using the discrete wavelet transform.
      The parameters are determined by the dialog window shown below.

 Parameters... Displays the following dialog.

Filtering can be applied selectively:
only file spectra, only library spectra or both.

The percentile of the total energy of a spectra in the 
wavelet transform domain to keep.  Generally, this 
number should be very close to 100%.  By displaying a 
cube selection point and enabling filtering you can plot 
(Classify:Plot) and drag the filtered signature onto the 
selection point plot window as a comparison.

Specifies the number of Haar (2) or Daubechies (4,6,12,20) 
coefficients to use in the wavelet transform.  The greater the 
number, the smoother the filtering.

This plot, Functions -> Plot -> Spectra (Selected Points), displays a cube selection point (red) 
versus the same signature (black) used for Classification with Enable wavelet... checked (see 
section Superimposing Signatures).  The wavelet filtering values applied are those listed in 
the dialog window above.  Disabled bands, highlighted in red, are not filtered and therefore 
remain the same in both signatures.
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More Options

 When performing a classification you may request several output products that can be 
generated in addition to the class map.  By selecting More Options... in the Classify Op-
tions dialog the following dialog appears.

Three options have been selected:  produce a 
difference image between the selected classifi-
cation point and each spectral signature within 
the image cube, compute the average of all 
spectral signatures within the image, and  use 
the source color (determined by menu Image ->  
Cube Color Comp -> Definitions) of the selec-
tion point as the class map overlay color.  The 
mean spectra does not depend upon the clas-
sification points whereas the difference image 
does.

A single selection point within the delineated area shown on the left is 
used to produce the overlay type classmap appearing to the right.

The plot of the mean of all 47,872 spectral signatures in the classification area.  
Bad bands are zeroed.  A plot that includes bad band values can be generated 
by choosing Enable All in the Band List and then reclassifying.  The difference 
image (shown right) is coded so that the brightest values represent the closest 
match to the chosen selection point(s) for the given classification method.  How-
ever, the data attached to the difference image gives the actual metric difference 
(e.g. radians for Vector angle) as the cursor is moved over the image and the 
Info Window (menu Windows->Show Info) is active.
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The selected option will produce two plots: The ac-
tual value produced by the Method used in the clas-
sification for each pixel and a histogram that plots 
a relative frequency count of  how often a specific 
difference occured.  Any section of each plot can be 
magnified by dragging a selection rectangle about 
the area of interest and then choosing the Image -> 
Magnify -> 1x menu.  The magnification factor is 
ignored, instead, the selection rectangle is expanded 
to full size.

Each of the 49,970 spectral signatures is plotted against the Vector Angle differ-
ence between it and the chosen classification point shown on the previous page.  
The maximum difference is 1.22 radians.  By dragging a selection rectangle any-
where within  the plot and choosing Image->Magnify->2x a new plot consisting of 
just that region will be constructed.  This may be repeated on the new plot to get 
even finer detail.

This Histogram is essentially the same plot plot as the Difference plot reordered so 
that the horizontal axis represents Vector Angle differences (in radians) versis how 
frequently this difference occured.  This plot may also be magnified repeatedly.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 106

Image Products
 Each Classify produces  an image(s), an ordered set of spectral file names or an ROC 
plot.  The image can be a color representation of the goodness-of-fit or a composite consist-
ing of the color representation overlaid on an image background.  The background is auto-
matically chosen to be the Search Domain band face so for example if band number 35 is 
visible, a duplicate is made and used as the overlay base.  The colors of the mask/overlay 
are the same colors as √ points in the classify list.  If a selection rectangle is present on the 
Search cube face then the classification and resultant image is limited to the rectangle size.
 An output image has one or more classification regions depending upon the various op-
tions described in the previous section.  The default is one region per √ point or √ library 
spectra.  However, if the Classify mean radio button is chosen then the average of all √ 
points is formed for the source signature for comparison and therefore only one classify 
region is generated.  Shown below is a source image with four selected points, and 2 clas-
sification outputs using the default Vector Angle Method with tolerances .08 and .8 radians 
respectively.  Each region color corresponds to the selection point color and can be changed 
via the Color Selector (see section Selection Point Colors) or Use source spectra color 
in More Options.
 The utility of the classification output can be greatly expanded by using Flicker/Super-
impose in the Functions menu or compositing it with another image via Overlay Color 
or using image Arithmetic.  Furthermore, classifications can have labels that dynamically 
change as the cursor passes over them (see section Dynamic Displays and Plots).

Four selected points 
on a linked color 
composite.

The top right output is the result of using 
the Vector Angle Method with a toler-
ance of .08 radians.  The base image cube 
shows through where the angle exceeded 
the tolerance.  The right image is the same 
classification re-run with a tolerance of .8 
radians which just about forces each pixel 
into one of the classification regions thus 
oblitering the underlying image.
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 One of the more interesting products of Classify is the generation of a synthetic cube 
consisting of a linear sequence of classification tolerances.  For example, the Classify Op-
tions dialog shown below will generate 11 outputs ranging in tolerance from 0 to .1 radians 
that will be automatically collated into an 11 band synthetic cube also shown below.  Besides 
band scrolling, most of the HyperCube functions that can be applied to a spectral image cube 
can also be applied to the synthetic cube, such as: Gray & Color mapping, Flips, Rotates, 
Flicker/Superimpose, Magnify and Filtering.  The exceptions are Shifts, Histograms and 
Statistical Measures.

Starting tolerance of the first output.

Ending tolerance for the last output.

The number of outputs in the synthetic 
cube.  In this instance the output se-
quence will be: 0, .01, .02, .03, .04, .05, 
.06, .07, .08, .09 and .1 radians tolerance.

Shown left and right respectively are two views of the resulting synthetic cube.  The left one 
has been scrolled to the fifth output band in which the overlay tolerance is .04 radians while 
the right view has been scrolled to the the last band showing a tolerance of .1 radians.

Vector Angle is the chosen Method.

If checked then a plot of “hits” versus 
“false alarms” will be generated.
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 The classification regions of a classify image can be tabulated by selecting menu Func-
tions -> Plots -> Histogram when the image is active.  The result is list of each class name 
and the frequency with which it appears in the image.  Zero frequency classes are omitted.  
The list can be selected (normal drag selection and command-C key) and pasted into another 
program, e.g., Excel®.  Below is  a portion of a very detailed Lib:File classification and the 
histogram of the selection rectangle area within the image.

At the left is a portion of a classmap generated via a Lib:File classification.  The library con-
tained several hundred signatures.  At the right is part of the histogram frequency count list-
ing for this classmap.  Each library signature has multiple measurements.  The first column 
contains the index of the library signature in the color key.  See sections: Library Searches 
and Class Map Editor for a description of the class name and color association.
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F(Signatures)
 Whenever the Classify dialog is active you can construct the eigenvectors and/or ortho-
normal basis of the selected signatures via menu item Functions -> F(Signatures).  Either 
image or library signatures must have been toggled on and Classify each... must be select-
ed.  If from a library they are resampled to the enabled bands of the attached image cube.  Ei-
genvectors requires 2 or more signatures while Orthonormal 1 or more.  The covariance or 
the correlation of the signatures may be chosen for the eigenvectors computation.    Since the 
number of signatures is usually much less than the number of bands the resulting eigenvalues 
and hence eigenvectors have little significance after the N-1 value where N is the number of 
signatures used.  Compare this with the HyperCube menu item Image -> Convert Image 
-> Principal Components that uses all of the pixels within a cube (or selection rectangle) 
to compute the covariance.  Orthonormal uses the Gram-Schmidt method and the number of 
signatures can not exceed the number of bands.  Orthonormal also produces the correspond-
ing projection matrix defined as: A(ATA)-1AT where A is the column matrix of orthonormal 
vectors.  Both methods generate matrices that are saved to a file and can be used in Utilities 
-> Apply Transformation.

 Mathematically, the following matrices are produced for the particular instance of an im-
age cube with 160 of 210 bands enabled and 10 signatures.
 Eigenvector matrix (Matrix.ev): 160 rows x 160 columns.
 Orthonormal matrix (Matrix.gs): 160 rows x 10 columns.
 Projection matrix (Matrix.pm); 160 rows x 160 columns.

 Below and on the following page are examples of the Eigenvectors method and the re-
sult of applying the matrix to the original image cube using menu Windows->Apply Trans-
formation.

F(Signatures) dialog set to compute the 
eigenvectors corresponding to 10 Classify 
signatures.  The result is a matrix file. Classify selection points.
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First principal component. Second principal component.

The left and right im-
ages are the first two 
bands of the cube re-
sulting from applying 
the eigenvector matrix 
to the original data 
using Utility Apply 
Transformation.
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ROC Curves
 One type of classification output is a ROC (Receiver Operating Characteristic) curve.  
This produces a plot of the probability of correctly classifying a data set (statistically not 
committing a Type I Error) verses the probability of erroneously classifying a data set (statis-
tically of committing a Type II Error).  This relationship is commonly referred to as the “hit 
rate” verses the “false alarm” rate as a function of a varying decision criteria.  In HyperCube 
the criteria is the tolerance for a given classification algorithm.  The validity of whether or 
not a signature is classified correctly is determined by a previously constructed “ground 
truth” image mask matching the classification area.  A mask pixel of zero means there 
shouldnʼt be a match and a nonzero pixel means there should be.  During the ROC computa-
tion as each image point is classified (matched against a given spectral signature) a tabulation 
is maintained of whether an image point was classified (within tolerance for the given algo-
rithm) and if the classification was correct according to the “ground truth” image mask.  Each 
tolerance value produces one tabulation.  A sequence of linearly spaced tolerances (~250-500 
values) produces tables that are then normalized to form the ROC plot.
 The ROC option is available when Classify mean of √ points is selected in the main 
Classify window along with Search Domain set to File and the Generate a sequence in 
Classify Options checked.  It is similar to generating the classification image sequence pre-
viously described.  After checking the ROC curve box the ROC Mask... button is clicked 
to select the ground truth image mask from a popup list of images.  This image must spatially 
match the classification area used in generating the ROC sequence of classifications.    Note 
that  “Classify mean of √ points” always results in a single classification region so the sum-
mation is over a single class.
 Listed below is a representative scenario for generating a ground truth mask from an im-
age cube and then forming the various ROC plots shown on the following pages.

 1. Choose several image points representing the same classification feature.
 2. Select one or more neighborhoods around each point (to form a good average).
  If these points exactly delineate the ground truth then click the Form Neighborhood 
  Mask Image button and Classify mean of √ points and continue at step 7.
 3. Choose an algorithm such as Vector Angle and Classify mean of √ points.
 4. Choose Classify Options and set up a sequence of ~15 outputs and Color Image.
 5. Click Classify.  Choose the output within the sequence of images that best
  represents ground truth for this feature.  Select Convert Image -> Image to Mask
  menu to extract the mask.  This mask can then be further edited (e.g. PhotoShop®)
  to give it more validity.
 6. Clear all of the selection points that were used to generate the mask and select a
  new point from the cube that represents the feature in the mask.  Or, open a library
  and select a signature from the library list (see section Library Searches) and
  select Library as the Signature in the Classify window.
 7. Choose an algorithm from Methods in the Classify window.  Select Classify
  Options, check Generate sequence and ROC curve and then ROC Mask... .
   Select the mask image generated above from the popup (this only needs to be done
  once).  Return to Classify Options and enter the number of outputs (~250) and a
  broad range of tolerances for the chosen algorithm.  Return to the Classify window.
 8. The Classify button will change to ROC Curve.  Click it to generate the plot.
 9. Repeat steps 7 and 8 for each algorithm.  Step 6 may also be repeated to see its effect.
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The mean of six points representing a 
typical tree canopy  was used for this 
image mask that was extracted from a 
sequence of 15 classifications using Vec-
tor Angle.

The selected image point on this 
linked color composite was the 
classification signature to be 
matched when generating the ROC 
plots shown below.

From above clockwise are the ROC plots corresponding to Vector Angle, Euclidean 
Distance, Fourier Phase and Derivative Difference respectively.  The vertical axis 
is the hit rate and the horizontal axis is the false alarm rate.  The greater the area 
under each curve the more discriminating the algorithm.  Ideally, the Hit Rate would 
approach 1 while the False Alarm Rate stays near zero producing an area close to 1.

Clicking within the graph displays a green dot 
and highlights the corresponding tolerance value.  
Conversely, clicking within the scrolled list shows 
the corresponding plot position.

The Pts checkbox switches the 
plot from continuous to a discrete 
scatter plot which the ROC actu-
ally represents.
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Fifteen selection points along with various neigborhood points were 
used to generate the resulting selection mask shown to the right by 
choosing Form Neighborhood Mask Image in the Classify dialog 
above (see section Classify Function).  Each target point represents 
the same physical material.  The library spectral signature of this 
material was used in the classification to produce the four ROC 
curves shown below.  Note that the classification area and the mask 
selected for the ROC curves must spatially  coincide which in this 
case was automatic.

These plots correspond to the same four methods shown on the previous page that 
were used in discriminating the tree canopy.  Here they give a quantitative measure 
of target verses background discrimination.
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Library Searches
 Choosing Library as the Search Domain produces a list of library signatures that best 
match the criteria selected by the user.  The list is ordered in decreasing closeness with a 
numerical value derived from the classification Method.  The numbers are only meaningful 
within the same method and are most useful in detecting a cluster of matching signatures, 
i.e. items that are physically similar.  The spectrum of any listed signature can be plotted in a 
spectral signature window by double clicking it and can be added to the spectral plot window 
by dragging its graph (see the Superimposing Signatures section).
 A library is loaded by choosing the Library... button in the Classify window.  Once load-
ed the name will replace Lib:(none) and the Library option radio buttons under Signature 
and Search Domain will then become available.  Loading a library connects it to the clas-
sification process whereas using menu File -> Open As..., and selecting Format: Library  
does not and that library remains independent.  However, signatures from the later may also 
be dragged onto the spectral plot window.
 The steps to perform a typical library classification are as follows:
  1. Load the image cube file and select one or more (if averaging) image points.
  2. Choose Classify... from the Functions menu.
  3. Click the Library... button to load a spectral library.
  4. Select (√) one or more cube points from the Classify coordinate list.
  5. Click the Signature: File and the Search Domain: Library options.
  5. Choose a classification from the Method popup menu.
  6. Click the Classify button.  A list(s) of matching library signatures will appear.

The Library Search window lists the library signatures matching the selected image cube 
file point.  The top signature in the list has been superimposed upon the Plot window.
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 The opposite of the previous example is also possible: i.e., choosing one or more library 
signatures and generating a classification output (Lib:File search).  The region colors are then 
taken from the patches in the Color Selector as follows: the lowest √ library signature index 
corresponds to the first color patch, the next higher √ library signature index to the second 
color patch and so on (see right hand example below for an alternate method of defining the 
color correspondence).  In the same manner that the selection point color correspondence 
can be chosen, so can the library signature color correspondence by choosing menu Edit -> 
Options -> Color Selector.  The color to name correspondence can be displayed by click-
ing the Lib Key button in the Classify window.  This generates a palette like image of the 
correspondences.  This can be saved like any other image.  Shown here is a typical output.  
To select (toggle on) a complete library, click on the library window and then choose Select 
All from the Edit menu.  Up to 1024 signatures can be selected.  To deselect (toggle off) all 
choose Edit->Clear menu or double click individual selected spectra.  Section Dynamic 
Displays and Spectral Plots describes how to change both the color and the associated 
name after a Lib:File classification has been made.
 If Lib:File match lists is checked (default) in Classify -> Options then two lists are 
generated in addition to the classmap.  One contains a list of the library selections that are 
in the classmap and the other list contains the library selections that are not in the classmap.  
Toggling a list item will display its corresponding spectra.  Empty lists are not generated.

At left is a portion of 412 color to library 
signature correspondences after Select All was 
chosen in the Edit menu to toggle-on all of the 
library entries showing the default colors.  At 
right is the same library color coding after 
Use source spectra color has been selected in 
Classify: Options: More Options.
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Dynamic Displays and Spectral Plots
 Each time a classification output image is created a list is generated that associates the 
colored regions with the selection point number or library signature name corresponding to 
that region.  Then, as you move the cursor over the classified image the name appears as a 
small label next to the cursor.  The 
labelling font and its position can 
be changed by choosing menu  Edit 
-> Options -> Labels. This brings 
up the submenu displayed at the 
right.  If a classification image is 
saved the correspondence list is 
also automatically saved using the 
name of the image concatenated 
with a “.c2n” extension and if the 
image is later loaded the correspondence list is also loaded and associated with that image.  
The correspondence between the color of a region and the label name that appears is com-
pletely editable by using the Utilities -> Class Map  Editor described later.
 Below are two examples of classificaion outputs showing the region labels for a specific 
cursor position.

On the left is the output image from a 4 point selection File:File classification showing point 
#1 s̓ region label.  Vector Angle was used with a tolerance of .08 radians.  To the right is the 
classification output of a different image cube resulting from a Lib:File search.  The label and 
color of either image can be changed via menu Utilities->Class Map Editor.

Cursor
Position
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The dynamic display of 4 library spectra that most 
closely match the image cube spectrum at the cursor 
position.   The graph is the corresponding dynamic 
spectral plot of the top 2 library spectra (red and 
green) along with the cube plot in black.  In this case 
the Method chosen was Vector Angle.

 A dynamic display of the current image cube 
vector position can be shown by selecting Spec-
tra (Dynamic) from the Plot submenu.  As the 
user moves the cursor over the image cube or 
linked color composite the plot is automatically 
updated.  The data is read from the image disk file and works best when the cube file is in 
BIL or BSQ format.  If the user has enabled Dynamic Display in the Classify Options dia-
log, described previously, then the two closest library spectra will also be plotted on the same 
graph.  Similar to the static Selected Points plots, you can ʻScaleʼ and ʻHide Badʼ.

Dynamic spectral 
plots of the same 
cube vector point 
with and without 
the optional check 
boxes selected.

 A dynamic display similar to a classification output image can be generated when per-
forming a File:Lib search.  Normally, this consists of selecting an image cube point and 
classifying it against a library of signatures 
producing an ordered list of best matches.  
However, if the En- able Dynamic Display 
check box in the Clas- sify Options dialog is 
selected as shown here then the match vector 
is chosen from the cursorʼs position on the image cube.  A label containing the best matches 
will be computed and displayed as the user moves the cursor.  The dynamic search remains 
in effect until any mouse click in the Classify window.  It must be restarted by clicking the 
Classify button.  If a color composite Link image of the cube image has been created then 
the dynamic display will also appear when the cursor is moved over the linked image.
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Class Map Editor
 The correspondence between the color and name of an image 
classification can be modified by using Utilities -> Class Map Edi-
tor.  You can do this after the image is generated or at a later time as 
long as the classification image has an associated *.c2n file.  A clas-
sification image is a true color image where each pixel is either a gray 
value (including black if itʼs a mask) or a specific color.  Associated 
with each color is an ASCII string comprising the name that will be 
displayed whenever the cursor is over that color or no display when 
over a gray (image) pixel.  The Editor allows changing that associa-
tion so that a color or group of colors may be “renamed” or the color 
itself changed with a corresponding change in the image.  For example:  a classification re-
gion titled “Water” and represented by a light cyan color can be changed to “Shallow Pond”  
with a medium blue color.  A single colored region can be changed to any other color (not 
gray) as long that color is not already used for a different region.  You can choose multiple 
items using the shift key for contiguous and the command key for non-contiguous selections 
(Windows version uses the Ctrl key for non-contiguous).  As each item is chosen the cor-
responding class on the image will flicker in white.  So, as multiple selections are made they 
produce a larger and larger composite region.  The Apply button will consolidate all of the 
selected items into the displayed name and color and change the image appropriately.  Apply 
is not reversible.  Therefore, it is best to make a duplicate (Edit -> Duplicate) of the class 
map image before editing it.
 

The Editor window on the left shows 2 highlighted items that have been selected and are 
about to be consolidated into a single class with the name and color shown.  The classmap 
image on the right shows where these 4 items are located by flickering them in white.  When 
Apply is clicked both items will have the color: {195,255,195} and the item list will be up-
dated.  The Search button displays a dialog allowing you to enter a text string and every list 
item containing that string will be highlighted as if manually selected.  The Export... button 
saves a single item in the ESRI Shape File format (see section ESRI Shape Files).
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 Scrollable List For each classification region the associated name and color.
      Click to select, edit name and color followed by  Apply or return.
      Multiple lines may be selected via shift click and command click.

 R:G:B:   The color components as each is selected.  Edit as desired.  The
      color patch below shows the composite.

 Apply    Change the selected list name to that of the edit field and color
      and update the image.  Hitting the return key is same as Apply.

 Delete    Remove the selected list item and replace its color with black.

 Color Key   Generate a legend type image (see section Library Searches).

 Load/Save  The color to name correspondence may be saved without having
      to resave the image.  It must be saved as ʻ”name”.c2n.  A previous
      (e.g. master) may be loaded to overwrite an original correspondence.
      This is an ASCII file and is also compatible with Edit->Options->
      Color Selector.  See section Selection Point Colors.

 Search   This displays the dialog shown below and is used to select items based
      upon their common names.  Each item containing the search string
      will be highlighted.  No modifications are made until Apply is clicked.

If Preclear is checked then any 
existing highligting is cleared 
else items matching the search 
string are added to currently 
highlighted items.

Various combinations of the 
current and new colors and 
names may be selected.

 Sort All of the elements in the list, i.e., the class 
names will be re-ordered according to 
this dialog option.  This makes it easier to 
group a large class map by color such as 
classifying against a library.
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 Export Item...  Convert a single item into a shape file as specified in the ESRI
      Shapefile Technical Description - July 1998.  Brings up the user
      dialog shown below presenting a number of options. 

      Save files: Solicits a file name using the item as the base name
          and produces the three files listed.  The .shp
          extension is a must, the other two are automatic.

      Plot shape: Generates a vector plot of the result at 2 times size.
          This plot will exactly match a 2 times magnified
          image of the class map.  See sections Magnify and
          Flicker/Superimpose.

      Flip output: Invert the y coordinate so that the origin is at
          the upper left instead of the imageʼs lower left.

      Transform: Convert shape file coordinates to the transformation
          specified by Image to Reference Coordinates.

The left image is a 2x magnified view of a six class map.  The main dark green 
regions are the selected item in the Class Map Editor that was Exported to a 
shape file.  The right image is the vector plot output showing the class outline in 
green and any interior voids in the complement color, magenta.
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Spectral Calibration
 HyperCube has the ability to empirically calibrate a cube against a set of two or more ref-
erence spectral vectors.  The reference may be from an external file, another cube or a library.  
Calibration uses the same point selection and neighborhood toggling as is done for a Clas-
sification. It can be invoked whenever a Classification window for a given cube is active by 
choosing  Functions -> Calibration.  Calibration produces a gains and offsets file that may 
be saved or immediately applied so that you can see the effect on a classification or plot by 
toggling it on and off.
 The idea behind calibration is simple, try to compute a separate linear transformation, 
gain (or scale) and offset, for each band that will convert that bandʼs pixel values to the same 
values in a reference set.  The assumption is that the difference between the measured and 
reference spectral values is closely represented by a linear change.  In practice this isnʼt exact 
so more than two spectral vectors (selection points) are used in a least square solution.
 A typical calibration scenario is as follows:  Suppose there are four panels in the source 
cube that have known spectral reflectance signatures (somewhere else).  Then choose four se-
lection points over these panels and toggle them on as if doing a classification.  You may then 
choose additional neighborhood points around these if an average spectral signature for each 
panel is desired.  Bring up the Calibration dialog as stated above.  The Meas column will 
be the measured spectral vector for the given point and the Ref column will be the desired 
reference spectra and initially will be zero.  The next step is to put data into the Ref column 
that you want the Meas value to be transformed into.  This could be done by manually enter-
ing the data as described below (very tedious for hyperspectral data!).  However, the easiest 
method is to drag an existing reference spectral signature plot over top of the calibration win-
dow list.  It will be automatically interpolated from its wavelengths to the cube s̓ wavelengths 
(see section Plotting Signatures).  The signature plot can come from a library list (see 
Spectral Libraries) or from another cube.  The later is extracted by loading a second (refer-
ence) cube, selecting a point, opening a classification window, toggling that point on and then 
clicking the Plot √  button.  The resulting signature plot can then be dragged onto the calibra-
tion window.  The final method of entering Ref data is to read it from a previously generated 
file. Its format is ASCII tab delimited text pairs of wavelength and value.  Note that it is not 
defined by a band number.  The wavelengths are used to properly interpolate the values into 
the cubeʼs wavelengths.  If the cubeʼs spectral range extends beyond the Ref values then the 
corresponding Ref data is zero filled.

Band and 
wavelength.

Current point.

Generate gains and offsets. Apply (remove) them to (from) current cube.

Save/Load Ref for 
the current point.

Bring up the Ref 
scaling dialog.

Edit highlighted or selected item. Next or previous point.
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 The various Calibration Dialog controls are defined below:

Scrollable List: Contains four columns listing the Band, Wavelength, Meas value
     and Reference value for the given Pt. #.  Clicking on a
     Meas or Ref column item allows that item to be edited, see Edit button.

Pt. #:    The current selection point number shown in the list.  May be manually
     edited or incrementally changed with the adjacent arrow buttons.

<- ->:    Step to the previous or next selection point.

Edit->:    Enabled when a Meas or Ref item is highlighted (clicked on).  The high
     lighted item will be changed to the number in the edit field.  Works in
     conjunction with the two radio buttons described next.

Selected Item: If on then only the selected (high lighted) Meas or Ref item will be
     changed.  Mutually exclusive with Band Range.
Band Range:  If on then all of the items within the Band Range specified will be   
     changed to the same given value.  Mutually exclusive with Selected   
     Item.

Save Ref...  Displays a standard Mac save dialog and saves the current point Ref data
     as ASCII tab delimited wavelength, numeric value pairs.

Load Ref...  The opposite of Save, loads a previously defined Ref file and interpolates
     as necessary to overwrite the current point Ref data.

Scale Ref...  Brings up a dialog that permits you to enter a numeric value that will
     immediately be multiplied times a specific Ref column or all Ref columns. 
      A convenience to change the range of the Ref data.

Zero G & O...  When checked the gain and offset computed for each disabled band
     is set identically to zero.  When these gains and offsets are then applied
     to a cube the disabled bandʼs spectral values will then be zero.
     See section Band List for a description of disabled bands.

Compute   This button becomes active when at least two Classify points are selected.
     When clicked the gains and offsets are computed and shown in a separate
     data list window that can be saved via Save in the File menu.
     Also generated is a data list showing the corresponding residuals from the  
     least squares solution.

Apply    Becomes active after a Compute and immediately applies the gains and
     offsets to the current cube meaning that any plots are automatically
     updated and subsequent classifies will accommodate them.

Remove   Remove any gains and offsets that may be in effect for the given cube.
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Four selection points from cube Frames 
5-8r have been chosen as reference val-
ues.  Point #2 s̓ spectra is shown below 
and is being dragged over the corre-
sponding point #2 listing of  data8a s̓ 
calibration window

These are the four points of data8a that 
have been selected as the matching 
spectral vectors to the four reference 
vectors of Frames 5-8r along with the 
data8a calibration window below.

Spectral plot of point #2 of Frames 
5-8r.

Point #2 of data8a s̓ calibration window before 
the drag operation.

Point #2 after the drag operation.  The spectral 
plot values have been interpolated and placed 
into the Ref column.  This is repeated for each 
of the remaining points followed by the Compute 
button which then produces the Gains and Offsets 
values along with the Residuals for each band.  
These may be applied immediately (Apply) to 
data8a or saved (File->Save).

Drag
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Saving Images
 HyperCube saves images as HDF, JPEG, NITF, Pict, .SUN, TIFF, 
Raw or Multiband depending upon the File menu item chosen and on 
the internal format of the image.  If the image has not as yet been saved 
a standard save file dialog with the suggested name will appear asking 
for confirmation if the file already exists to overwrite it.  Subsequent 
saves of the same image will perform the save directly automatically 
replacing the old image with the same name.  However, if the image 
has been modified since the last save the confirmation dialog will again 
be presented.  To save a specific band, scroll the cube to the band, 
choose Duplicate from the Edit menu and then Save.  To save all of 
the bands within a cube image as sequentially numbered TIFF files, 
choose menu File -> Save As..., Bands.  File -> Open As..., Bands will reload the bands 
into a cube (see section Constructing/Modifying a Cube).
 File->Save As... is used to save images in HDF, JPEG, NITF, Raw, SRF, TIFF or 
Multiband format.  If HDF, NITF, SRF or TIFF is selected from the Format popup then no 
other dialog is required.  Raw is used to save a single image and allows specifying a rectan-
gular subset and the pixel type.  Selecting Raw displays:

The dialog edit fields are defined as:

 Starting pixel: First pixel defining the image rectangle to save.  These first 4 edit
      fields are preset to the current dimensions of the image.

 Starting line:  First line to save.

 # of pixels:  How many pixels per line to save.

 # of lines:   Corresponding number of lines to save.

 Pixel type:  Either byte, short, float or long.

 Interleave:  If the image is true color then this popup will be enabled  to allow the  
      image to be saved as a 3 band cube with the specified interleave.

The Save As... Raw dialog 
defining the file format for a 
true color screen dump im-
age saved in Band interleave 
order.  Because it is true color 
it will be saved as a 3 band 
cube.
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 The Save As... function is also used to save an image cube as a multiband image.  The 
dialog is similar to the previous Raw dialog with the addition of two more edit fields and a 
check box to selectively dump only bands whose status is Enabled in the Bands List.  Un-
like the Raw dialog, the Interleave popup is always enabled, not just for true color.  Save 

As... also generates a new *.hdr, and for multiband a new *.wvl, file.
The additional dialog items are defined as:

 Starting band: The first band of the cube to start saving.  The default is the first band.

 # of bands:  How many bands to dump beginning at the Starting band.  The
      default is the number of bands in the image cube.

 Donʼt save dis... If this check box is set then disabled bands specified in the Bands List
      will be skipped.  This option is unavailable if all bands are enabled.

Note: To change the format of the multiband file use menu Utilities -> Reformat Cube 
File.  It is much more general and operates directly on the file pixels images that have been 
loaded into memory. 
  Save As..., Bands can be used when an image cube window is active.  Its purpose is 
to save each band of the cube as a  TIFF file forming a set of sequenced images that can be 
made into a QuickTime™ movie using a program such as Adobe Premiere™.  The user cho-
sen name will be concatenated with the a number (e.g. name.001) as each band is extracted 
and automatically saved.  These band images can be automatically reloaded and formed into 
a cube using menu File -> Open As..., Bands by selecting any one of the numbered images.

An entire 256 band image cube is 
specified with no subsetting.  The 
grayed-out appearance of the check 
box indicates that there are no dis-
abled bands in the Band List.
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Printing
 Any HyperCube window or underlying image can be printed to the currently chosen 
printer using the functions File -> Page Setup... and File -> Print.  These bring up the 
standard Mac or Windows dialogs with options usually specific to the type of printer.  The 
default is to print the contents of the front most window with its name below centered on the 
page.  Print Image prints the entire image regardless of what is shown within the window 
whereas Print Window limits itself to just the way the window appears including any opera-
tions being performed on the window such as gray mapping or filtering.  Print Image will be 
replaced by Print Text if the window contains any ASCII lists. Whether window or image, 
the output will always be resized to fit within the print area.

Selects either print the entire 
image or just that portion 
shown in the current window.

Macintosh Print Dialog details

The corresponding Print dialog in the 
Windows version.  The HyperCube 
options appear at the bottom.

If a selection rectangle has been 
drawn then you have the option of 
just printing its contents.

You have the option of 
omitting a title or border.

The desired output resolution.  
However, the image will al-
ways be scaled, if necessary, 
to fit the page.
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Reformatting a File
 Menu Utilities -> Reformat File... operates on Multiband, Raw, 
NITF sequential multiband and NITF mono image files.  If the file 
to be reformatted has a *.hdr file these values will be extracted and 
inserted as defaults into the appropriate edit fields of the Reformat dia-
log window.  A new *.hdr file will be generated along with an updated 
*.wvl file if one existed for the source image cube.  NITF multiband 
and mono files donʼt have a separate hdr or wvl file, all sizing informa-
tion is contained in the source file.  Reformatting a NITF file produces 
a cube or mono file, not another NITF file.  Selecting a single output 
band from a multiband image essentially extracts the band and writes a 
single raw type image.  The Reformat dialog is shown below.

The upper elements define the spatial 
format of  the data.  Normally, this is 
retrieved from the *.hdr file or directly 
from a NITF file.

This dialog area specifies the format 
of the converted output file.  Its initial 
values are set equal to the source file 
size and are edited as desired.

The example shown will generate a full size cube 
scaling 16 bit signed pixels to floating point pixels 
while limiting the range to [0,1200] and reversing 
the order of the lines.  Swap bytes will change the 
byte order to PC (little endian).

Check boxes used to change the order 
of pixels within a line, the order of the 
lines within a band and whether any 
scaling, limiting or byte swapping is 
to be applied.

 # Pixels:   The number of pixels per line in the source file.

 # Lines:   The number of lines in the source file.

 # Bands:   The number of bands in the source file.

 Header bytes: The number of bytes in the source file preceeding the image data.

 Pixel type:  Size and type of the source pixels.

 Interleave:  Structure of the source file: band, line or pixel.

Utilities
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 # Pixels, Lines, Bands:  The subset of the source file to be reformatted.

 Start pixel, line, band:  Starting coordinates within the source file for subsetting.

 Output Pixel type:   Output pixel size.  If Limit... is checked then output
         pixels are kept within the Min & Max range, else they
         are automatically limited to the range of the pixel type.

 Output Interleave:  The format structure of the output cube.

 Min, Max:     The lower and upper ranges for limiting the output pixels.

 Flip left <-> right:  Change the order of pixels within a line.

 Flip top <-> bottom:  Reverse the order of the lines, i.e. first line last.

 Apply scaling:   Modify each output band  according to the type of scaling
        selected in Scaling/Calibration.  If  checked then each band
        is modified by: scale * band + offset.

 Swap bytes...   This check box allows swapping the order of bytes within
        16 bit and 32 bit pixels.  Note that this applies to the output.
        The source byte order is taken from the header and if it is
        unknown you will be prompted for a best guess.

 Output header bytes: Directly copy the source file header bytes to the output file.

 Reverse band order: Output the bands in reverse order.

 Reverse wavelength... Also reverse the order of the output wavelength file.

 Scaling/Calibration:  This brings up the following user dialog which is used to
        determine the type of scaling to be applied to the output.
        The Apply scaling option checkbox becomes active after
        returning from this dialog.

Apply this scale and offset to 
every band.

Select a  file containing a 
separate scale & offset pair 
for each band.  The number of 
pairs must equal the number of 
bands in the source file.

A typical gains and offsets 
file content: a pair of val-
ues for each band...
0.00716025 -0.0044436
0.0054349 -1.367508
0.00553983 -1.2478907
0.00583894 -1.2276135
0.00571494 -1.1864042
0.00562544 -1.1921199
0.00553107 -1.5069996
 ...   ...
Scale and offset pairs are 
separated by a space or 
tab.

-- or --
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Converting a Library to a Cube File
 HyperCube can create an image cube whose pix-
els are the spectral signatures from a library.  This is 
accomplished via Utilities -> Library to Image Cube 
File...  which is enabled whenever a Library List win-
dow is front most.  Each signature is replicated into a 
square block (for clarity).  Blocks are placed side by side and row by row in the same order 
that the signature names appear in the Library List.  The total number of blocks and their 
rectangular arrangement (per row and the number of rows) is initially chosen by the program 
and can be edited by you.  Null signatures are added to fill out the last row.  If you enter 
values that produce a block total that is less than the number of signatures in the library then 
only that number of signatures will be converted.
 After selecting Library to Image Cube File... the following dialog appears:
 The upper portion shows the structure of the library while the lower portion defines the 

size of the resulting image cube.  Note in this case that the total number of blocks (18*23) is 
2 greater than the number of signatures, 412, in order to make the cube somewhat square and 
that the resultant image cube file size will be almost 183 megabytes, (16 * 16 * 18 * 23 * 431 
* sizeof(float)).  These values  can be edited and a Block size of 8 (~46 MB) still yields a 
usable image cube.  The image cube is stored in band interleave by pixel (bip) format with 
floating point values along with newly created header and wavelength files.  The Reformat 
Cube File utility can be used to reconstruct a different format image cube.
 If the Library List window already has attached spectral data, as is the case when opened 
from a Classify window, then you are immediately presented with the save file dialog re-
questing a name for the image cube.  If the library list does not have attached spectral data, 
i.e. opened using Open As..., Library, then there will be a delay of several seconds while the 
spectral signatures are being loaded before the save file dialog appears.

The 431 band image cube will consist of 288 
floating point pixels/line by 368 lines with the 
last 2 blocks containing zero filled signatures.

The structure of the library is determined by 
reading the first spectral signature in the Li-
brary List (see section Spectral Libraries).
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Converting a Library to an ASCII File
 The currently active (front most)  Library List 
window can be saved as a text file by choosing Utili-
ties -> Library to ASCII File.  You are presented with 
the following dialog describing the size of the library 
along with several options defining the format to be 
used when generating the ASCII file.

 If the Library List window is already loaded such as part of a Classify window then the 
standard save file dialog is presented else there will be a delay while the library data is ex-
tracted followed by the save dialog requesting the name of the ASCII file.

The structure of the library is determined by reading the 
first spectral signature in the Library List (see section 
Spectral Libraries).

If Rows is selected then each row will be a complete signa-
ture (431 points in this case). If Columns is selected then 
a row will consist of all of the spectral values for each sig-
nature  for a given wavelength (412 values per row  shown 
here).

Include Wavelengths adds an extra row or col-
umn at the beginning containing the wavelengths. 

Small portions of a library saved 
in row and column form respec-
tively and opened in Excel™.  In 
each case the wavelength option 
was included.
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Concatenate Images
 Two images may be combined side to side or top to bottom to 
form a new single image by choosing Utilities -> Concatenate Im-
ages.  The images donʼt have to be the same spatial size, the output 
will be sized to the minimum dimension of the two.  They must have 
the same pixel depth, i.e. both 8 bit or both 32 bit.
 The dialog below shows the result of combining two bands from 
an image cube that were first separated from the cube using Dupli-
cate in the Edit menu.

Bands 60 and 69 from an image cube concatenated left to right.  
The bands were first extracted from a loaded cube via Duplicate.
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Concatenate Files
 This utility allows you to make one continuous file from two or 
more files by reading each file and sequentially concatenating their 
contents to create a single new output file, e.g. combining individual 
Landsat file bands into a contiguous BSQ (Band Sequential) cube. 
The source files are not altered in any way.  Compare this with the 
previously described Concatentate Images, which operates only on 
images loaded for display.
 You start the process by selecting menu Utilities -> Concatenate 
Files which brings up the following dialog:

Each button press displays the 
standard open file dialog.  Any 
type of file may be selected.

Each selected file is added to 
the list.  A selection may be re-
moved by clicking it and press-
ing Delete Selection.

Display the standard save file dialog 
and solicit a name for the concat-
enated file.

Ignore all selections and exit 
without creating an output file.
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Changing a Window Title
 It is often convenient to be able to change the title (name) of a 
window without having to first do a Save as... .  An example is 
when printing where the title can be changed to something more 
descriptive and then listed below the output (see section Printing and 
note below).  To perform the change activate the window and choose 
Utilities -> Change Window Title.  This brings up the following 
dialog.

The current window name, Frames 5-8r 
being changed to a more descriptive title.

 Note: Window titles may consist of up to 63 characters, while file names are limited to 31 
characters.  You will be alerted when saving an image window with too many characters.

If checked and window is a 
cube then the loaded bands will 
be renumbered starting at 1.
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Apply Transformation
 The active image cube file can be transformed into another cube 
file by mulitplying each spectral vector (signature) by a linear trans-
formation in the form of an M x N matrix.  The matrix must be an 
ASCII file  (File->Save As Text and and answering affirmative to 
Matrix) or such as those optionally saved via menu items Image -> 
Convert Image -> Principal Components, Functions -> Sta-
tistics -> Band Correlations and Functions -> F(Signatures). 
The format consists of a single line containing the dimensions of the 
matrix, (# rows tab # columns) followed by the M rows of the matrix 
with each of the N column elements separated by a space or tab and 
ended with a return.  An example of a 4x3 transformation matrix is:

 4 3
 4.6864242694e-01 -6.9847956895e-01 2.5492193504e-01
 5.0310142892e-01 4.5755700310e-01 7.0505069625e-01
 5.0999322932e-01 -2.8597312694e-01 -3.8238290256e-01
 5.1688502971e-01 4.7009281141e-01  -5.4009410160e-01

 Algebraically, the following occurs:
  AP = B   for the forward transformation
  AP-1 = B  for the inverse transformation
  APT = B  for the transpose transformation, where
      A is each 1 by M spectral signature in the source cube
      P is the M by N transformation matrix
      B is each resulting 1 by N new spectral signature
      P-1 is the inverse of matrix P, PTis the transpose of P
 If the Output complement option is checked then  A - B is formed.

 You can use less than M rows or N columns of P, the unused rows are treated as if they 
are zero and unused columns reduce the output vector dimension to 1 x cols.  This allows 
you to construct an output cube using just the first significant vectors (columns) of a matrix 
file (see sections Image to Principal Components and F(Signatures)).
 

The source cube that will be transformed.

The transformation matrix to be applied.

The number of rows and columns of the transfor-
mation matrix to use.  In this case all of the rows 
and columns will be applied.  Setting cols less 
than the number of enabled bands reduces the 
output cube to the same depth as cols.

Generate the new transformed cube file.  
It will be in BIL floating point format.
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Applications
Shaded Relief
 An image can be rendered into a synthetic image (or sequence of images) 
that depicts the effect of uniformly illuminating it with a parallel light source, 
e.g. the Sun.  Each gray value, or its associated (attached) data (see sections 
Files, Data..., Raw, Multiband, NITF Files, TIFF Files), is interpreted as 
an elevation that intersects and reflects the light source as a function of the 
angle of incidence between the light and the slope of the elevation.  Choos-
ing Applications -> Shaded Relief...  when a gray image is the front most window brings 
up the Shaded Relief dialog.  Any excluded pixel values are ignored when computing the 
initial x and y slope scales (see section Pixel Exclusion). 

Elevation angle above 
the data plane of the light 
source.

Heading angle measured 
CCW from the east or 
positive X direction.

The denominator used in 
computing the slope in the X 
and Y directions.  Initial values 
are computed from the aver-
age slope within the image.  
The lesser these values are the 
greater the shadowing effect.

If Anaglyph is checked then a red:cyan stereo anaglyphic image is also generated 
using the specified Parallax value.   See section Stereo Mate for an example.

Gray image representation of data used to 
generate the Shaded Relief image shown 
to the right using the values defined in the 
above dialog.

Resulting Shaded Relief with the light com-
ing from the upper left 45 degrees above the 
“horizon”.  The fine vertical striping is part 
of the data and not an artifact.  The source 
image s̓ data is also copied to this image.

If Az sequence is checked 
then a synthetic cube of # 
values between Start Az 
and End Az is generated.  
Choosing this option dis-
ables Anaglyph.
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Stereo Mate
 A Base image along with a Data image representing elevation  that is 
spatially registered to the Base image can be used to form a new version of 
the Base image with elevation induced displacements.  If the Base image 
is 8 bits and is used as the red component and the Stereo Mate as the green 
and blue image components. The resulting color anaglyph can be viewed 
in stereo with red and cyan glasses.  If the Base image is color the Stereo 
Mate will also be color and if placed along side of each other as narrow strips you 
can view with a pocket stereoscope.

If the Base image is a cube band 
then this check box allows generat-
ing a stereo mate for every band in 
the cube.

Multiplicative factor applied 
to the Data image.

An anaglyphic stereo 
image generated by us-
ing R,G,B to Color and 
selecting red as the base 
image and blue and green 
as the stereo mate.  View 
via red and cyan glasses.
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Perspective
 A data image of elevations can be reconstructed as if viewed from 
almost any perspective by applying basic photogrammetry.  If there is a 
corresponding Base image, i.e., each feature pixel is one-to-one with an el-
evation then the features themselves can be drapped across the elevations to 
yield a different perspective.  The process is initiated by selecting Perspec-
tive... from the Applications menu which displays the following dialog.  All values may be 
interactively modified.

Base Image:  Feature image that is transformed into the perspective view.  The Data
     image may also be used if no Base image exits.

Data image:  An image whose pixels are interpreted as elevations.  See section Raw.

Starting pos.:  The coordinates of the perspective or view point relative to the Base
     image.  The origin is the upper left pixel with positive X in the right
     direction and positive Y moving downward.  Z is above the image.
     After selecting the Base image, X,Y,Z are preset to above the middle of
     the Base image at a height of the maximum of X and Y.  You can readily
     edit these values.  Note that X,Y,Z is a point, not a direction, that is
     determined by Omega, Phi and Kappa.

Ending pos.:  If Generate a sequence, below, is checked then this is the ending
     view point of a uniform set of view points and angles that will be used to
     generate a synthetic cube movie.

Generate a sequence: If checked then # equally spaced view points are constructed and
     assembled into a cube.

Omega, Phi, Kappa: The rotations about the X, Y, and Z axes respectively in degrees.
      If Link Omega & Phi is checked then the perspective orientation is   
     fixed pointing to the center of the Base image.  Therefore, a Sequence
     will produce a fly-by perspective with an invariant center.

X

Y

Z

DTED point 

Image point

Focal length
Perspective point

Phi

Kappa

Omega
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A shaded relief image generated from 
elevation data  is used as the Base im-
age and provides the features that will be 
viewed from a different  perspective as 
shown to the right.

The reconstructed perspective image 
using the photogrammetric parameters 
entered into the previously described user 
dialog.

Link Omega & Phi to X,Y,Z: If checked then Omega and Phi are automatically
     computed as a function of X and Y so that the perspective view is pointed
     at the center of the Base image.  You can check this box to force a
     centered view, click an Outline button  and then uncheck it to modify   
     Omega and Phi manually for a more desirable view.  See the Outline   
     buttons described below.

Data scaling:  The multiplicative factor applied to the Data.  The smaller the number
     the “flatter” the perspective appears.  Usually, a value of .05 is a good
     starting point.  The larger the scaling the more exaggerated the effect of 
     elevation and the longer the computation time.

Focal length:  How far behind the perspective point the imaging plane lies.  The greater
     the focal length the larger the nominal magnification.  A small Focal
     length is analogous to a wide angle lens.  The initial value is set equal to
     the Z coordinate and produces a one-to-one scale.
     Changing the Focal length does not change the output image dimensions.

Reset:    Set the perspective back to the initial starting values as if viewing
     the image from a point directly over the center with no rotations.

Perspective:  Generate the perspective image(s).
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The above dialog was used to select and generate the perspective im-
age shown here.  Both images were then rotated 180 degrees to produce 
the final views shown below.  Note that Link has been selected to force 
pointing at the center of the source image.
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 Applications -> Radiance -> Emmisivity processes 
thermal images, generally in the range of 3 to 18 microns, 
that are in radiance units of Wm-2µm-1.  Structurally, there is 
no distinction between a thermal image cube and a visible 
to SWIR cube, only the wavelength definition.  HyperCube 
allows you to generate a temperature data image and op-
tionally, an emissivity cube.  The temperature is derived by 
comparing the radiance of each image cube pixel with the 
radiance of a series of black body curves.  The closest match, via a user specified tolerance, 
produces the temperature for that pixel.  There is also a utility, Plot BB Curve, that can dis-
play a black body radiance curve for any given temperature.
 Shown below are the various user dialogs that are available.  Note that the routines 
require wavelengths to be in microns (µm) but that the temperature can be in centigrade, 
Kelvin or Fahrenheit.  Any questions regarding the applicability of these functions should be 
directed to timothy.d.evans@usace.army.mil.

Applications->Radiance->Plot BB Curve dialogs, on the left, and their cor-
responding black body radiance curves on the right for the given temperature 
and wavelength ranges.

Radiance
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 Menu Applications -> Radiance -> Emissivity displays the following dialogs.  The 
default values shown were used to produce the displayed outputs from a thermal image cube.

The output image at left is a mask showing the warmest, red, and coolest, blue, regions 
within the thermal image cube, i.e., those temperatures 2 or more deviations from the mean.  
At right is a shaded relief of the temperature image that has been similarly coded.  The cool-
est region coincides with a creek.  Below is the histogram of the temperature data image in 
units of degrees Kelvin.
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 Menu item Applications -> Radiance -> ISAC per-
forms the “In Scene Atmospheric Compensation” (ISAC) 
algorithm on a thermal hyperspectral image which as in the 
Emissivity function must be in radiance units of Wm-2µm-1.  
This function attempts to remove the effects of the atmo-
sphere and is described in publication: JGR-Atmospheres: 
Young, Johnson and Hackwell, “An in-scene Method for 
Atmospheric Compensation of Thermal Hyperspectral Data”, 21 December 2002.
The current options available are shown below.  Details of the implementation in HyperCube 
may be obtained by contacting timothy.d.evans@usace.army.mil.

A synthetic cube is generated where 
each plane is an sdtol mask dependent 
on a value from the sequence.  No other 
output is produced.

Only bands between these limits  will 
be used in computations.

If checked, any bands that are disabled in 
the Windows->Band List and will also be 
excluded from computation.

Various possible output products that 
may be selectively enabled if sequence 
has not been selected in the main dialog.

Source image
Black body output 
mask for an sdtol 
value of .0045.

Graphs of transmit-
tance and upwelling 
versus wavelength 
respectively.
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Miscellaneous
Icons
 HyperCube has a family of 8 Finder icons.  Five of these are regular Mac data types and 
represent TEXT, JPEG, PICT, TIFF and Sun Raster Format files.  The other three represent 
the HyperCube application, unformatted binary data and PhotoShop™ convolution kernels as 
shown in the figures below.

Double clicking an image icon will automatically launch HyperCube and the load the corre-
sponding image.  Similarly, a *.wvl or *.hdr icon can be double clicked as well.
 The Windows version does not have an icon family, only the application has an icon.  
Any HyperCube documents must be opened within the application.

HyperCube application icon.

ASCII text file, e.g., *.hdr, *.wvl.

Image files saved in JPEG, NITF, Pict, SRF, and TIFF formats.

Unformatted image file saved as Raw.

PhotoShop™ convolution kernel of type 8BCK.

Error Messages
 When HyperCube detects an internal error such as 
running out of memory it generally can recover enough 
to allow you to at least save and print.  There is one se-
rious type of error dialog that may be presented indicat-
ing that an immediate exit is warranted.  But if you have 
generated some result that just must be saved or printed 
then HyperCube can be forced to continue at risk of an 
immediate crash.  Generally, the exit path should be 
taken especially if it is followed by another dire warning.
 This error message will not appear in the Windows version.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 144

Capturing the Screen
 The contents of the main display screen may be captured  at any time other than a modal 
dialog (i.e. those demanding attention) by simultaneously pressing the command 1(one) keys 
(Ctrl 1 in the Windows version).  This creates a new true color window of the entire display 
that may be saved like any other pict image.  Note that a full screen color window requires 
approximately 2MB for 832 pixels by 624 lines.  HyperCube checks for sufficient memory 
and warns if it is insufficient.
 Additionally, in the Windows version you can automatically copy the entire active win-
dow to the clipboard by depressing Ctrl-Print Screen.  Then choose File->New... followed 
by Edit->Paste to place it in a window where it can be saved.

Saving and Copying Scrollable Lists
 Any window which has a scrollable list, e.g. spectral plot, band correlations, that does 
not contain a specific Save button may still be written to a file by selecting Save from the 
Edit menu.  This will bring up the standard file save dialog.  The data will be formatted as 
tab delimited ASCII text and can be reread by any application that reads text.  Also, this same 
scrollable list may be copied to the clipboard as tab delimited, c/r terminated lines of text by 
choosing the Edit -> Copy menu and then pasted into another application.

Loading/Saving Text Files
 Any small text file can be opened and displayed in a scrollable list.  This is especially 
useful for examining header files.  The file is opened by choosing menu File -> Open As 
and Text from the fromat dialog popup.  It can then be edited (Cut, Copy and Paste) and 
resaved.  The up and down arrow keys and the page up, page down keys are used to navigate 
through the text.  Choosing File -> New... and selecting the Text option will open a blank 
Text window that may be typed into and saved as text.
 An image or any selection may be saved as an ASCII text file by choosing menu File -> 
Save As and Text as the format (and optionally as a matrix, see section Apply Transfor-
mation).  The pixels are tab delimited with each line followed by a return.  The size of the 
resulting file may be 4 or 5 times larger than the source.
 Note: Any embedded zeros within a text file are automatically removed when the file is 
read.  Carriage returns on the Windows version are followed by a newline character.

Using menu File->Open As, Text and selecting a header file, 
*.hdr, results in the window at left.  This may be edited and saved, 
functioning as a simple word processor.  Dragging the cursor 
within the window s̓ content area will automatically scroll expos-
ing additional lines as will the arrow and page keys.  Text will 
either wrap-around or limit itself to a line if a carriage return oc-
curs within the width of the window.  The window may be resized 
as necessary.  
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HyperCube Menus

 The availability of a specific menu function is directly keyed to the current active win-
dow.  If an item is not enabled and you think it should be, itʼs most likely because it is not 
applicable to the front most window or is ambiguous.  For example, Embed Wavelength is 
enabled only when a cube window is front, likewise for Classify.  Fourier and other opera-
tors can only be used when an image window is active and Convert Image is very depen-
dent upon the active windowʼs bit depth. 
 Some menu functions produce operators that become attached to the window that is ac-
tive.  Color Map, Gray Map, Filter, Flicker Cube, and Fourier are examples of attached 
operators.  When the parent window is closed the operator window disappears.

Windows version main Menu Bar.

The Windows menu will 
contain Cascade and Tile in 
the Windows version but not 
the Mac version.

Open As... is a Mac 
only menu item.
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File

 New...  Create a new empty image window that can be used to paste the current
    clipboard.  You are presented with the following dialog options which
    are preset according to the contents of the clipboard.

 Open...  Presents the standard Mac open file dialog showing only Pict type files.

 Open As... A modified open file dialog which includes TIFF and other image files.

 Load Sel... Available when an overview is front most.  Brings up the last dialog
     used to open the source image with the requested size fields set to
     correspond to any selection rectangle that appears on the overview.
     See section Overviews.

 Close   Close and dismiss the currently front most window.  Any modified
     window first presents an opportunity to save it.

 Close All  Closes all open windows.

 Save   Save the current active image window as a Pict file.

 Save As... Present a modified save dialog allowing you to save in Pict and
     other type formats.

 Page Setup... Bring up the standard printer setup dialog for the chosen printer.

 Print...  Display the print dialog and print the contents of the front window.

 Quit   Immediately exit HyperCube.  No warning is given to save anything.

Pixels  Width of window
Lines  Height of window

Text  Create a new Text window
Image  Create a new Image window.

Gray scale 8 bit gray window
Clipboard... 8 bit pseudo color window
True color  32 bit full color window
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Edit

 Undo  Not implemented in the present HyperCube version.

 Cut  Also not implemented as yet.

 Copy  Copy the current front window to the clipboard.  If a selection rectangle is
    present then copy just its contents.

 Paste  Paste the contents of the clipboard to the front window.  You can position it  
    before embedding.

 Clear  De-toggles enabled items in Library list, Classify points list and Cube points.

 Select All  Toggles on all items in a Library list or Classify points list.

 Duplicate Make an exact copy of the current front window contents but not its
     functionality.  Equivalent to performing: Copy, New and Paste.

 Options A submenu with the following sub-functions.

Sound    Toggle alert sound on/off.
Detailed Mess... Toggle debug info on/off.
List allocat...  Display a snapshot of internal structures.
[0,0] Image Origin Change the upper left coordinate origin from [1,1]
      to [0,0]
Labels    A submenu specifying the font, size and position of
      dynamic labels (see Dynamic Displays and Plots).
Mag/Rot Interp... Interpolation for magnify and rotate (see Image menu).

Color Selector... Display the selection point to color correspondence
      editing window.
List Clipboard... Whatʼs currently in the clipboard.
Image to Ref...  Display a dialog defining the correspondence between
      an image coordinate and a reference coordinate.
Pixel Ex...   Displays a dialog specifying certain pixel values that
      are excluded from histogram computations.
      See section Pixel Exclusion.
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Applications

 Shaded Relief...  Solicit the elevation and and azimuth of an artificial light source
       and generate a reflective relief of an image or its attached data.

 Stereo Mate...  Produce an anaglyphic red and cyan stereo image from elevations.

 Perspective...  Generate a perspective view given a base image and its matching
       digital elevations.

 Radiance...   Construct a new radiance image cube from an existing thermal
       radiance cube using various techniques.
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Image

 Convert Image A submenu used to change the structure of an image.

 

 Attach Data... Data from one image is copied and attached to another image.
 
 Add to Cube... Presents a dialog list from which to choose images for a new cube.

 Zoom in   Magnify the current image window by 2.

 Zoom out  Demagnify the current image window by 2.

 Flip   A submenu allowing images and cubes to be reversed and reflected.

 Rotate  Multiple 90 degree rotations of image and cube windows.

R,G,B to Color... Select 8 bit images to form a color image.
H,S,I to Color...  Select 8 bit hue, saturation and intensity  
      to form a color image.
Indexed to Color Changes 8 bit pseudo color to true color.
Complement  Complement a color image.
Color to R,G,B  Separate a color image into planes.
Color to H,S,I  Separate a color image into hue, saturation  
      and intensity.
Color to Indexed Change true color to pseudo color.
Replace Color... Substitute one color with another.
Image to Mask... Change a specific color (gray) to a mask.
Grayscale   Convert color to gray image.
Hist Equalize...  Perform various equalizations.
Principal Comp... Convert color to principal components.
Plane to Cube  Use a gray image as cube base.  This
      menu item toggles with Color to Cube.
Color to Cube  Convert true color image into a 3 band   
      image cube.
New Cube Link... Change the present cube color composite  
       link.
Color Table   Change present 8 bit pseudo color table.

Left  -> Right Reverse the pixels within a line.
Top -> Bottom Reverse the order of the lines.
Band Order  Change the loaded bands within a
     cube so that the last is first.

90 cw  Rotate image or cube 90 degrees clockwise.
90 ccw 90 degrees counter clockwise.
180 cw 180 degree rotation.
General User input of rotation.
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 Magnify ...  Toggles between Magnify Image and Magnify Selection
      depending  on whether the active image window has a selection
      rectangle.  Generates a new magnified/minified view of the image or
      selection rectangle by the factor chosen in the submenu.  Certain
      plots (e.g., data histograms, eigenvalues) can also be magnified.

 Delete Band  The current cube face band is deleted from the image cube.  This
      does not affect the image file.

 Embed Wave... Write the wavelength into each band of the loaded cube.  Useful
      before Save Bands function.

 Cube Color Composite A submenu enabled when a cube image is front.
      Generates a true color image using the values set in Definitions... to
      determine which bands of the cube file to use.  The new color image
      is automatically linked to the cube (see sections Color Composite
      and Classify Functions).

Static 5x5...  Display a static 5 by 5 kernel
     convolution static dialog.
Dynamic 3x3... Display an interactive 3x3 kernel
     convolution dialog.

 Color Map...  Display interactive dialog of color balance controls for color images.

 Gray Map...  Change the contrast and brightness of any image or cube window.

 Filter    A submenu of static and interactive spatial domain image filtering.

Specific Wave Use the 3 closest bands to    
     the values set in Definitions...

Interval Wave Integrate all bands lying in   
     each interval to form the    
     red, green and blue
     components.

Definitions... Display a dialog allowing
     you to specify the red,
     green and blue wavelengths 
     for a cube color composite.

 Shift   Left and right pixel and line cyclic shifts of image windows.
Left, Right, Up, Down Direction of shift.
Even   Just even numbered line.
Overwrite If toggled, results overwrites source.
Enter Shift Allows user specified shift value.
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Functions

 Flicker Cube  Generate a new cube window devoted to flickering between bands.

 Flicker/Superimpose Display a dialog of image names from which to choose the   
        sources for an image flicker or image superposition.

 Statistics   A submenu of statistical functions to be applied to the current cube.

 Plot    A submenu of graphical operators.

 Arithmetic...  Open an interactive window allowing you to execute arithmetic
      expressions involving 8 bit images.

 Overlay Color... Generate a composite image from a mask and base image.

 Adjacency...  A submenu for comparing and outputting spatially near pixels.

 Classify...  Open up the classification dialog window for the current image cube.

 Calibration... Open the calibration dialog for the frontmost Classify window.

 F(Signatures)... Compute eigenvector matrix of Classify signatures.

 Fourier...   Display an interactive dialog to perform frequency domain filtering
      upon the current 8 bit image window.

 Mosaic...   Display an interactive dialog to select and control the merging of
      two or more images into a composite assemblage.

 Warp...   Display an interactive dialog to select and control the geometric
      transformation of one image to another.

Histogram  Perform a pixel distribution histogram of
     the current image or cube.
Hist (Mask...  Same as above using an image mask.
Spectra (Se... Display the spectral plot window for the
     selected active cube points.
Spectra (Dy... Dynamically display a spectral plot as the
     cursor moves over a cube.
Scatter...   Generate a 2 dimensional plot of the
     pixel distribution between 2 images.
Profile   Draw a gray level density plot of the active
     image profile line.  If the image is color
     draw plots for red, green and blue.
Scaling...   Selectable when a plot window is active. 
     Allows you to change the plot axes. 

Pair Corr... Cross correlation computation between 2 images.
Band Corr... Cross correlation between successive cube bands.



HyperCube Pictorial Userʼs Guide  8/31/04 Page 152

Utilities

 Reformat File... Open a dialog for reformatting the spatial and/or pixel type of a file.

 Library to  A submenu to convert the current front most library list window into  
      an image cube file or an ASCII text file.

 Class Map Editor Enabled when a classification image is front most.  Permits
       changing the region color and name association.

 Concatenate Images... Display a dialog allowing you to select two images that
         will be concatenated in either pixel or line order to form
         one new image.

 Concatenate Files...  Display a dialog allowing you to select multiples files
         to be concatenated into a single sequential new file. 

 Change Window Title... Solicit a new title for the current active window.

 Apply Transformation... Multiply a cube file by an orthogonal transformation.

Windows

 Show Info  Display a small dynamic window that shows various HyperCube
      details as the cursor passes over other windows.

 Show Band List Display a listing of the wavelengths of the current image cube and  
       allow you to set the status of various bands.

 Cascade   Windows version only.  Arranges all of the open windows in an
      overlapped diagonal order.

 Tile    Windows version only.  Resizes and rearranges the open windows in
      a row by row pattern.

 “Names”   A dynamic list in order of creation of HyperCube windows.  The
      front most window is preceded by a check mark.
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Index
Symbols
%  18,28
*.c2n file  118
*.hdr  16,78,125,127,143

band list  78
*.wav  125,127,143
*.wvl  77

band list  77
.ev  109
.gs  109
.pm  109
.wav  27,77
.wvl  27,77,125,127,143
[0,0]  39
[0,1]  19,85
[1,1]  39
{constant,constant,constant}  59
180 cw  149
8BCK  143
90 ccw  149
90 cw  149

A
Abs diff  92
Add to Cube...  149
Adjacency  64
Affine  75

image to reference  26
Algorithms  92
Anaglyph  135,136
Arithmetic  106,151

sequence  60
Arithmetic functions

non standard  57
standard C  56

Arithmetic operators  56
Arrow keys

flicker offset  80
ASCII  72

Saving images  144
Attach Data  46
Averaging

spectral plots  90
Azimuth  135

B
Bands

loading  124
Band Correlations  49,151

sequential  49
specific  49

Band List  77,92,122
revert  78
scaling  78

Band Order  35,149
Band Scrolling  79
Binary  44
Black body  140
Block size  129
Brightness  31
Byte  124
Byte order  17,127

C
Calibration  121
Cascade  152
Classic  5

Info window  39
Pict  7

Classifications
principal components  41

Classify  66,67
Classify...  92,145,151

overlays  106
Classify Each  99
Classify Mean  99,111
Classmap Editor

Color to Classmap  46
Class Map Editor

ESRI Shape Files  11
singularities  67

Clear  30,85,147
Clear Lib  85
Close  146
Close All  146
Coefficients  29

Daubechies  103
Haar  103

Color Balance  33
Color Composite  97,101,150

color keywords  84
save hdr  84

Color Image  102
Color map

histogram  51
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Color Map...  33,145,150
Color Mapping

hue, sat, int  33
Color Mask  102
Color overlay  43
Color Selector  99,101,115
Color separation  44
Color Table  149
Color to cube  82
Color to Indexed  42,149
Color to Library  115
Color to Planes  40,149
Columns  134
Command-option-C  43,87
Complex data

HDF  12
Concatenate Files  132
Concatenate Images  131
Constructing a cube  82
Contrast  28,31
Control-click

profiles  55
Convariance

noise  95
Convert Image  149
Convolution  57
Convolver

3x3  37
5x5  37
offset  37
scale  37

Coordinates  39
Copy  30,147
Copy color  87
Corner coordinates

image to reference  26
Correlation  47,49

pairs  47
Corr coef  92
Countable  101
Covariance  49,93

pairs  47
Crash  143
Cross correlation  57
Cut  147
C language  56

D
Daubechies  103

coefficients  58
Delete  30,31
Density plot  55
Deriv diff  92
Descrete Wavelet Transform

image arithmetic  58

Detailed Messages  7,14,15,51,147
cummulative histogram  51
ERDAS Imagine  10
HDF tags  12
histogram  51

Difference image  104
Difference plot  105
Double clicking  77
Dpi  126
Dragging a selection  30
Drag & Drop  91
Duplicate  30,124,147
Dynamic Displays  85

E
Edit  85
Eigenvector  109
Eigenvectors

signatures  109
Elevation  135
Embed Wavelengths  145,150
Emissivity  140
Enable Dynamic Display  117
Energy

wavelets  58
ENVI®

header file  23
wavelength file  27

ERDAS Imagine®  9
Error Messages  143
ESRI  11
ESRI Shape File

exporting  118
Euclid distance  92
Excel™  49
Export shapefile  120

F
False alarm  111
False hits  66
Filter  150
Filtering

3x3  36
5x5  36
center  37
convolution  36
deniose  100
diagonal  37
edge  37
frequency domain  68
spatial  36
wavelet  103

Flicker
arrow keys  80
x,y offsets  80
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Flicker Cube  80,151
Flicker Image  80
Flip  35,149
Floating point  17,124,127
Fly-by  137
Focal length  138
Form Neighborhood...  98,111,113
Fourier  68,92,145,151

high boost  69
low pass  68
no DC  92
phase  92
phase delta  92
power spectrum  68

Frequency
histogram  108

Frequency domain
functions  57

G
Gains & Offsets  20
Gains & offsets  128
GeoTIFF  15
Gram-Schmidt  109
Grayscale  149
Gray Map...  31,145,150
Green dot  112
Ground truth  102,111

H
H,S,I  40
Haar  103

coefficients  58
Harmonic  92
HDF

Hierarchical Data Format  12
Header  16

*.hdr files  23
saving  18,78

Header file
image to reference  26

HFA  10
Hierarchical File Architecture  10
Histogram

color mapping  33
cumulative distribution  51
Detailed Messages  51
exclusions  53
file  51,52
gray mapping  33
masked  52
of classifications  105
Plot  151
summary  51
window  51,52

Histogram equalization  45,84
matching  45
uniform  45

Hit rate  111
Hotelling  41
hsi

K-means  96
Hue  40

color mapping  33

I
Icons

appl  143
Pict  143
Raw  143
Text  143

icords
keyword  25

Image Arithmetic  56
** operator in  56
abs,...,atan2  56
remapping  59
shift_left...  57

Image cube
adding to an  82
constructing an  82

Image Shift  47
Image to Mask  44
Image to Reference  120

change in origin  26
Indexed to Color  42
Info

band statistics  49
Info Window  39,85

color mapping  33
cursor position  39
NITF coordinates  14
Show Info  39
spectral coords  85

Intensified color
classify  104

Intensity
color mapping  33

Interleave  19,124,129
Interpolation  75
Interval Wavelengths  84
ISAC  142

J
JPEG  14,15,42

baseline  13
compression  13
markers  13
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K
Keywords

definitions  24
Kmeans  92,96

classes  96
class color  96
iterations  96
options  96
plots  96

L
Latitude  71
latitude  25
Left  36
Left -> Right  35,149
Lib:File

match lists  115
Library...  98,114,129

List  129
Library to Cube  129
Lib Key  115
Linear  31

correlation  47
Link  46
Linked image  97,150
Link to Cube  40
List allocation  147
Load

Bands  83
Loading

by double clicking  77
Longitude  71
longitude  25
LZW  15

M
Mac version 8.6  5
Magnify

bilinear  38
cubic  38
minification  150
replicate  38
selection rectangle  38

Magnify Image  150
Magnify Selection  150
Mag Interpolation  147
Mahalanobis

classifier  92
classify  92,94
distance  92,94
list  92,94
parameters  100

Mask  43,44,63,149
creating  95

Matched filter  93
abundance  92,93
mask  92

Match Criteria  101
Countable  101

Matrix  134
eigenvector  109
orthonormal  109
projection  109
save  134

matrix
save  144

Mean signature  104
Menus  145
Method  114
More Options  104
Mosaic  70

control  73
options  73

Multiband  16

N
New  31,146
NITF

coordinates  14
mono  127
Overviews  22
reformatting  127
Saving  124

Non-linear  75
NTSC  42

gray()  57

O
Omega, Phi, Kappa  137
Open...  146
Open As...  7,129,146
Operator  33
Options  147
Orthogonal  70,75
Orthonormal  109
OS X

Info window  39
memory  5
Pict pseudo color  42
TIFF  7

Outline  71
Overlay  63
Overlay Color  66
Overview

Load Selection  146
TIFF  14,15
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Overviews
scale factor  21
scaling  21
selection rectangle  21
starting band  21

P
Page Setup...  126,146
Pair Correlations...  47,151
Palette  87
Paste  30,147
Percentage  101
Perspective  137
PhotoShop™  37,143
Pict  30,143
Pixel Exclusion

histograms  51
shaded relief  135

Pixel type  17,124
Planes to Color...  40
Plane to plane  70
Plot  114,151

profile  55
scaling  76
scatter  151
selection  76
spectra  85,91

Plotting Signatures  121
Plot Scaling  85
Power spectrum  57

compression  69
Premiere™  125
Principal Components  41

Apply Transformation  134
signatures  109

Print...  146
spectra  90
windows  126

Print Image  126
Print Window  126
Profile  55

Control-click  55
Projection  109
Projection matrix  109
Pseudo color  42

Q
QuickTime™  125
Quit  146

R
Radiance  140,142
Radius  64
Raw  16,124,143

Redo stats  95
Ref  121
Reference coords  23
Reformatting  127

Multiband  127
NITF  127
Raw  127

Reformat Cube File...  125,127,129,152
Remapping  29
Remap bands  29
Replace Color  43
Residuals

example  74
Image to Reference  26
warp  74

Right  36
ROC  111
ROC curve  99
ROC Mask  102
Rotations  35,149
Rows  134
Rubberband  32

S
Saturation  29

color mapping  33
Save

Bands  83
images  124
Image Arithmetic  146
Overviews  22
signature  99

Save As...  146
Scale  19,85

gains & offsets  128
spectra  90

Scaling
plot  76
selection  76
wavelength  78

Scatter  151
Scatter...  54
Screen capture  144
Search

classmap  118
Search Domain  98,114
Selection point  87
Selection rectangle  30,31,33,41,47

data mapping  34
plots  76

Sequence  102
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